LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How can i change file associations under fedora core 2? (http://www.linuxquestions.org/questions/linux-software-2/how-can-i-change-file-associations-under-fedora-core-2-a-209263/)

Braveheart1980 07-24-2004 07:25 PM

How can i change file associations under fedora core 2?
 
I was wondering how can i change file associations under fedora core 2.eg to play a wmv file with mplayer

PS I've done right click --> open with --> gmplayer and choose to always open such files with mplayer , a bar pops up updating information but next time i double click an wmv file gmplayer doesn't open!

Andrew Benton 07-25-2004 08:23 AM

The menus are different in Fedora, (sorry I can't be bothered rebooting) but in regular Gnome 2.6 if you click the Main Menu> Applications> Desktop Preferences> Advanced> File Types and Programs, scroll down to Video, click it to expand the menu then click Microsoft WMV video .wmv and then click Edit. Fill in gmplayer in the Program to run box, click OK and close everything up and you're done.

Braveheart1980 07-25-2004 08:42 AM

I use KDE !

qwijibow 07-25-2004 09:51 AM

Settings->Configure Konqueror->File Associations

Braveheart1980 07-25-2004 07:05 PM

It seems like a bug 2 me.I've done that choose gmplayer for every video file , the same bar pops up but after that whenever i tr to double click a video file mplayer doesn't start!!!!!!!!!!!!

qwijibow 07-25-2004 08:51 PM

like i said.....
set mplayer as the TOP program for use with the video files in the file association section of KDE's konqueror.

Braveheart1980 07-26-2004 02:58 AM

I did!In fact i even erased other programms from the list so only mplayer is there.But whenever i check back the list no program is there!!!!!

qwijibow 07-26-2004 03:35 PM

ignore the "List" just click the icon (or double click, depending on your style) and the program at the top of the file associations will run.

Braveheart1980 07-26-2004 05:37 PM

Well that is my problem!I've removed all other programms , left just gmplayer and whenever i check the list there is NO program associated!!!

evannextel 07-28-2004 05:52 PM

yeah im curious about how to do this so i can set xmms for all mp3's. Using fedora core 2 and gnome. I found the preferences and then filetypes, it was set for xmms, but for soem reason rhythm box pops up if i lclick on an mp3

Braveheart1980 07-29-2004 02:53 AM

Well i figured it out! U have to remove all other programs and then don't set the program u want to open a file just like that ( eg gmplayer ) but u have to put the whole PATH to it ( eg /usr/bin/gmplayer ) . Then it works!

titopoquito 07-30-2004 12:58 PM

@ evannextel
I had the same problem. Maybe you find the answer in the following thread, where I posted my solution to this problem, it's about Gnome 2.6 and filetypes or mime-types.
Hope this helps ...

Other thread on linuxquestions.org
.
titopoquito

evannextel 08-01-2004 11:51 AM

ok im reading through that. in the freedesktop.org.xml file, mp3 is already listed. Now I'm assumign that all that file does is defines Filetypes. What decides how thoose filetypes are treated.

PS this is really annoying since the program that is set to open mp3's wont play them. I still find it funny that red hat wont support mp3 play back.

titopoquito 08-01-2004 12:12 PM

I'm sorry I can't write the entries I made, since I am running Windows right now and have some tasks running ...

I suggest you get the Gnome 2.6 Administrator's Guide. Chapter 5 is focusing on mime-types. There are five files I made additions, one was the shared-mime-thing from freedesktop.org. The other files or locations I made changes to are:

/etc/gnome-vfs-mime-magic ---- here I added some info about file content sniffing. I guess it's no longer used, since the above mentioned freedesktop.org file contains an appropriate entry. I would change it as well, even if it's gain may be minimal or none, it does do no harm either.

/usr/share/mime-info ----- here are .mime as well as .keys files. I think this is the directory you should take a deeper look at.

/usr/share/application-registry, here especially gnome-vfs.applications --- this file contains the applications known to Gnome and the mime-types they are able to open.


In my special case I had to create an mpc (Musepack) mime-type and to assign it to an program (xmms). Along this I run into one or two files for the totem-movieplayer (I guess it was in /usr/share/mime-info), that did my mp3s open in totem-movieplayer. I had to remove the lines concerning mp3-files and put them in an extra file (xmms.mime or xmms.keys, I don't remember).

Hope this helps. If you need it, I could post the chages I made for the Musepack-audio-files.

titopoquito


All times are GMT -5. The time now is 06:05 AM.