LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-18-2003, 06:08 PM   #1
homestead1000
Member
 
Registered: Jul 2003
Location: San Diego, CA USA
Distribution: RH 7x,8x,9x, RHE 3, Fedora Core1
Posts: 38

Rep: Reputation: 15
High CPU usage and lag when using 'cp'


Hi All. Hope you can help.

specs:

compaq dl580 w/ 2 intel zeon 700mhz
1gb ram
hw raid 5 w/ 1gb swap partition
OS RH 7.2 stock kernel 2.4.7-10smp

Problem:

When I copy a file from one location to another using 'cp' on the local machine my load average jumps to 3.+ and the machine laggs badly. Kjournald,kswapd,kreclaimd, and bdflush are suspect since their very active during this period.

The file being copied is 789meg and being copied within the same partition.

results of 'top' immediatly after job finishes:

10:54am up 3:21, 2 users, load average: 3.15, 1.81, 0.78
40 processes: 38 sleeping, 2 running, 0 zombie, 0 stopped
CPU0 states: 0.1% user, 0.1% system, 0.0% nice, 99.3% idle
CPU1 states: 0.0% user, 1.1% system, 0.0% nice, 98.3% idle
Mem: 1028476K av, 1023160K used, 5316K free, 0K shrd, 5464K buff
Swap: 2048152K av, 0K used, 2048152K free 969832K cached

PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME COMMAND
5 root 14 0 0 0 0 SW 0.9 0.0 0:03 kswapd
7 root 10 0 0 0 0 SW 0.1 0.0 0:02 bdflush
141 root 10 0 0 0 0 SW 0.1 0.0 0:03 kjournald
1107 root 10 0 1960 1960 1676 R 0.1 0.1 0:00 sshd
1160 root 10 0 1056 1056 856 R 0.1 0.1 1:52 top
1 root 9 0 520 520 452 S 0.0 0.0 0:04 init
2 root 8 0 0 0 0 SW 0.0 0.0 0:00 keventd
3 root 19 19 0 0 0 SWN 0.0 0.0 0:00 ksoftirqd_CPU0
4 root 18 19 0 0 0 SWN 0.0 0.0 0:00 ksoftirqd_CPU1
6 root 9 0 0 0 0 SW 0.0 0.0 0:00 kreclaimd
8 root 9 0 0 0 0 SW 0.0 0.0 0:00 kupdated
9 root -1 -20 0 0 0 SW< 0.0 0.0 0:00 mdrecoveryd
16 root 9 0 0 0 0 SW 0.0 0.0 0:00 cpqfcTS_wt_0
17 root 9 0 0 0 0 SW 0.0 0.0 0:00 scsi_eh_0
20 root 9 0 0 0 0 SW 0.0 0.0 0:00 kjournald
142 root 9 0 0 0 0 SW 0.0 0.0 0:00 kjournald
143 root 9 0 0 0 0 SW 0.0 0.0 0:00 kjournald
144 root 9 0 0 0 0 SW 0.0 0.0 0:00 kjournald
516 root 9 0 780 780 664 S 0.0 0.0 0:00 dhcpcd
592 root 9 0 592 592 496 S 0.0 0.0 0:00 syslogd
597 root 9 0 1192 1192 448 S 0.0 0.1 0:00 klogd
617 rpc 9 0 588 588 504 S 0.0 0.0 0:00 portmap
645 rpcuser 9 0 764 764 664 S 0.0 0.0 0:00 rpc.statd
813 root 9 0 1272 1272 1148 S 0.0 0.1 0:01 sshd
846 root 9 0 1012 996 816 S 0.0 0.0 0:00 xinetd
886 root 9 0 2064 2064 1496 S 0.0 0.2 0:00 sendmail
914 root 9 0 0 0 0 SW 0.0 0.0 0:00 scsi_eh_1
933 root 9 0 484 484 420 S 0.0 0.0 0:00 gpm
951 root 8 0 660 660 576 S 0.0 0.0 0:00 crond
1021 xfs 9 0 3584 3584 868 S 0.0 0.3 0:00 xfs
1057 daemon 9 0 568 568 500 S 0.0 0.0 0:00 atd
1087 root 9 0 448 448 384 S 0.0 0.0 0:00 mingetty
1088 root 9 0 448 448 384 S 0.0 0.0 0:00 mingetty
1089 root 9 0 448 448 384 S 0.0 0.0 0:00 mingetty
1090 root 9 0 448 448 384 S 0.0 0.0 0:00 mingetty
1091 root 9 0 448 448 384 S 0.0 0.0 0:00 mingetty
1092 root 9 0 448 448 384 S 0.0 0.0 0:00 mingetty
1108 root 9 0 1284 1284 1004 S 0.0 0.1 0:00 bash
1161 root 9 0 1960 1960 1676 S 0.0 0.1 0:00 sshd
1162 root 7 0 1284 1284 1004 S 0.0 0.1 0:00 bash

Any help would be greatly apprecicated.

Ed
 
Old 07-19-2003, 01:02 AM   #2
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Check if the drives are using DMA with hdparm.

You can try using reiserfs or JFS. kjournald is usually run with ext3 but I'm not sure. I searched the internet for weeks on kjournald. What I came up with is several people have trouble with kjournald.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
High Cpu usage untak Debian 21 01-23-2007 07:21 AM
cpu usage high corbintechboy VectorLinux 2 07-27-2005 09:11 AM
Rhythmbox high cpu usage Pipedream Linux - Software 0 11-07-2004 04:17 PM
xine high CPU usage Phathead Slackware 1 07-14-2004 02:16 AM
locking at high CPU usage charon Linux - Newbie 4 03-10-2004 03:21 AM


All times are GMT -5. The time now is 01:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration