LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-07-2003, 03:58 PM   #1
superimposed
LQ Newbie
 
Registered: Nov 2002
Distribution: mandrake linux 8
Posts: 7

Rep: Reputation: 0
Hi guys and gals, I'm having an interesting lilo issue in Mandrake 8, Please help.


I hope someone can help me...

I have "STF"LQ.org and apparently everyone else has normal
lilo problems. My problem is when I am in X and Drake
Control Center, the boot options for Lilo shows the option
for windows, but the block where you specify the "HDA1" it
is completely blank. No choice can be made. If I follow
through withit anyways, it will show the drive as ()
Obviously it doesn't work. Here is what happened which
caused this. I formatted my Dos Partition which was solely
Win98. I then installed an NTFS file system and
repartitioned for 3GB. I could not complete the
installation for lack of a serial #. I left it alone and
formatted the remainder of the drive for Win98. If I
fdisk my boot records it will boot to Win98. I can boot
into Linux with the CD or if I reset Lilo and it will boot
into Linux but it will not give me any option except for
default loading to my main Linux "HDA5". It doesn't even
ask me to use the RX boot, which is specified in my Lilo?
I'm puzzled. Is there any way to tell Linux to detect the
Win98 installation as bootable?

Thank you,
Bruce
www dot superimposed dot com
Superimposed MEdia
 
Old 07-07-2003, 04:06 PM   #2
Obi Perrin
Member
 
Registered: Nov 2002
Posts: 136

Rep: Reputation: 15
It seems that whatever GUI tool you are using to configure LILO is flaky and lacks options. It's easier just to modify LILO's configuration file then update it. Can you post the contents of your /etc/lilo.conf file, and what partition is windows 98 on? hda1?
 
Old 07-07-2003, 04:41 PM   #3
superimposed
LQ Newbie
 
Registered: Nov 2002
Distribution: mandrake linux 8
Posts: 7

Original Poster
Rep: Reputation: 0
Hi Obi,

That's what's puzzling me. When I go to /mount/windows
there is no "plus" symbol next to it, and when I click on
the folder it shows zero items. It show my cdrom and floppy
drive but when I choose the windows, it just states 0 files.
For some reason Linux won't detect my Win98 partition, which
was actually installed after my NTFS partition. I'm really
confused how to make it work, besides reinstalling Mandrake.
 
Old 07-07-2003, 05:03 PM   #4
Obi Perrin
Member
 
Registered: Nov 2002
Posts: 136

Rep: Reputation: 15
Hmm, it could be that your partitioning has changed the number of the Windows 98 partition. How's about the following?

The output of "fdisk -l /dev/hda" (note, that's a small L, not a capital I).

The contents of the file /etc/fstab

And the contents of /etc/lilo.conf

The first command should give us the place of the Windows 98 partition, from which we can then edit Linux and LILO to recognise it.
 
Old 07-07-2003, 05:05 PM   #5
superimposed
LQ Newbie
 
Registered: Nov 2002
Distribution: mandrake linux 8
Posts: 7

Original Poster
Rep: Reputation: 0
Thank you Obi,

I'll try it tonight after work. I should be able to
report back with the results this time tomorrow.
 
Old 07-08-2003, 09:43 PM   #6
superimposed
LQ Newbie
 
Registered: Nov 2002
Distribution: mandrake linux 8
Posts: 7

Original Poster
Rep: Reputation: 0
I did what you suggested and I found out the NTFS is on
HDA1 and Windows is on HDA3. I will post what is set on
HDA2 when I get home because I can't remember what was on
it. That'll be in a little while.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello guys and gals. I am new to this forum. I got the link from an article in PC Mag Tony Empire Linux - Networking 8 09-07-2005 11:36 AM
Hi guys n Gals Ldnswitch LinuxQuestions.org Member Intro 1 12-08-2004 10:29 AM
Help Please - Interesting Network Issue ned911 Linux - Networking 6 12-27-2002 02:45 PM
RH 8.0 interesting install issue Risc91 Linux - Distributions 5 10-04-2002 09:36 AM
Lilo or Grub ??? please help guys Rampage2884 Linux - Newbie 18 04-09-2002 02:38 PM


All times are GMT -5. The time now is 11:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration