LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-05-2003, 08:34 AM   #1
fusebox
LQ Newbie
 
Registered: Apr 2003
Location: Estonia
Distribution: Debian and Gentoo
Posts: 14

Rep: Reputation: 0
Hercules Radeon 8500 FDX LE 64 MB


Hi.
I'll get stright to the point.
I have RH 7.3 Valhalla.
I have 'Hercules Radeon 8500 FDX LE 64 MB' graphic card.
I want to install drivers for it.
( because when i tryed to play Unreal Tournament the game was very slow and i can't watch movies normally-with xine i hear sound but there is no picture, and with mplayer(i have a picture but i cant switch movie to fullscreen mode )
Maybe installin drivers wil fix this problem but Hercules dont support linux.
So i decided to try ATI drivers for my card, because Hercules is 'powered by ATI'
Next i went there: http://mirror.ati.com/support/driver...e&cmdNext=Next
and downloaded driver package for Xfree 4.2.0 ( fglrx-glc22-4.2.0-2.5.1.i586.rpm )
I runned 'rpm -ivh fglrx-glc22-4.2.0-2.5.1.i586.rpm'
You can see the output at: http://elu.dyn.ee/output.txt
Now if i run 'fglrxconfig', my X confuguration will be messed up and i need to make new config. I don't get it, whats wrong. Or is there any other chance to get movies work fine? ( btw with my old 16Mb Banshee, movies worked fine )
I would be grateful for any help
 
Old 04-05-2003, 09:47 AM   #2
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
Did you upgrade your compiler along the way or are you still using gcc-2.9.6?

Your exact distro was used by ATI to compile these, that's why there's a pre-built module for it [...2.4.18-17.7.x] but your system won't use it, so it reverts to building it's own, tailor made for your system, ...that fails with the same errors.
 
Old 04-06-2003, 11:56 AM   #3
fusebox
LQ Newbie
 
Registered: Apr 2003
Location: Estonia
Distribution: Debian and Gentoo
Posts: 14

Original Poster
Rep: Reputation: 0
Hmm yes im using 2.9.6
I should upgrade it but apt-get etc says that i already have the newest version.
Anyway i found gcc-3.2.2 but it has dependecy problems etc. So i should install/upgrade ~15 packs
Hmm but what if i change my linux distro. RH 7.3 -> RH 9.0, may this fix my video problems?
 
Old 04-06-2003, 12:36 PM   #4
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
>Hmm yes im using 2.9.6

OK, I thought you may have upgraded and that's what could have been throwing the install off.
I didn't mean to upgrade it, you'd be better off getting R_H 9.0 instead,
Now can 9.0 solve your problem?
It could but I really don't know why it won't install on R-H 7.3 as it should be a relatively simple task to install a driver on the distro it was originally compiled onto.
Only thing I could think of, is you must have upgraded something that broke compatibility with the driver.

...dunno ...sorry I can't help more, but if installing 9.0 is not a big deal to you, I know I'd give it a try, but then you'll need a different driver pkg if 9.0 comes with XFree-4.3.0.
Do a search for "user" "DaOne", he's posted a link to new drivers on a ATI related german site and the glx1_X4.3 pkg seems to be working on everything from 8500 to 9700pro.
I have them installed for my 8500.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon 8500 3D mep]-[isto Linux - Hardware 2 12-12-2003 09:25 AM
tv-out with radeon 8500 -> not booting! hesher Linux - Newbie 0 06-11-2003 06:31 PM
RedHat 8.0, Hercules Radeon 9700 Pro LordChaos Linux - Hardware 9 05-10-2003 10:11 AM
Mandrake 9.0 and Radeon 8500 buttercrunch Linux - General 4 10-27-2002 11:53 PM
Radeon 8500 HELP (please) TheDreamX Linux - Newbie 0 04-14-2002 10:19 PM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration