LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Help with PHP, Apache, and FC5 (http://www.linuxquestions.org/questions/linux-software-2/help-with-php-apache-and-fc5-466157/)

slincks 07-21-2006 03:32 AM

Help with PHP, Apache, and FC5
 
I am installing php using fedora core 5, I encounter this problem

(Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: cannot restore segment prot after reloc: Permission denied) after I after my command vi /usr/local/apache2/conf/httpd.conf......

please send me a solution regarding this problem.......please help me to find out how to solve this problem......

Sincerely yours.......

Linux Users


billymayday 07-21-2006 03:36 AM

How did you install apache, because on my fc5 box, httpd.conf is in /etc/httpd/conf ?

chadl 07-21-2006 08:54 AM

I googled your error message, and found the following site:
http://en.wikibooks.org/wiki/Install...arCRM_On_Linux

If you note the answer provided:
Quote:

If you get the following error: “ Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so : cannot restore segment prot after reloc: Permission Denied” Type (as root):

chcon –t shlib_t /usr/local/apache2/modules/libphp4.so
If that works, then it was a problem with SELinux preventing access from apache to libphp4.so.

Mara 07-21-2006 03:22 PM

Moved: This thread is more suitable in Linux-Software and has been moved accordingly to help your thread/question get the exposure it deserves.

jtshaw 07-21-2006 04:29 PM

I modified the title to make it more descriptive of the help you are seeking. Please try and be a bit more specific with your titles in the future, it helps to attract members that are more likely to be able to help you with your problem.

slincks 07-24-2006 02:36 AM

Thanks Chadli
 
I try this command chcon t shlib_t /usr/local/apache2/modules/libphp4.so but it seems it doesn't work...I try to start my /usr/local/apache2/bin/apachectl the error would still the same.....thanks for helping me........god bless

billymayday 07-24-2006 07:00 AM

slinks, exactly how are you trying to start it?

deepwaters 10-14-2006 01:58 PM

hi i am having trouble with my httpd (apache) i have read (redhat &fc5 bible)and did as it said in the book i can get the var/www/html/* to work but not public_html i uncommented UserDir "public_html"
and made all the file to home/user name 777 to public_html and i still get Forbidden
You don't have permission to access /~celnix/index.html on this server
where am i going wrong? i got it to work on windows 2003 webserver but -hell if i can get it to work on linux fc5 or redhat 4.3

deepwaters 10-15-2006 05:02 PM

had a few goes and changed a few things but still no go.

<Directory public_html>
Order Allow,Deny
Allow from all
</Directory>

<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
UserDir "enable all celnix"

#
# To enable requests to /~user/ to serve the user's public_html
# directory, use this directive instead of "UserDir disable":
#
UserDir "public_html"
am i going at it the wrong way or is there more to this permission thing?

gulli 04-10-2007 03:26 PM

system-config-securitylevel

SELLinux

modificar politicas sellinux

Servicio httpd

habilitar todos




Quote:

Originally Posted by slincks
I try this command chcon t shlib_t /usr/local/apache2/modules/libphp4.so but it seems it doesn't work...I try to start my /usr/local/apache2/bin/apachectl the error would still the same.....thanks for helping me........god bless


gkiran.ch 05-21-2010 10:49 PM

Not sure if my solution will be helpful to your issue however it may useful to some in future.

I had the same issue while installing PHP and i had to disable selinux temporarily.

#setenforce 0

then run the command # make would work.

Thanks
Kiran


All times are GMT -5. The time now is 02:41 PM.