LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-07-2002, 01:22 AM   #1
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Rep: Reputation: 30
help with making new fstab


running mandrake 9 beta3. Need to make a new fstab that does not utilize supermount. I checked out quit a few places but everyftab I wrote didn't work. Here is my default fstab..

/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdb6 /home ext3 defaults 1 2
none /mnt/cdrom supermount fs=iso9660,dev=/dev/hdc,--,iocharset=iso8859-1,codepage=850,ro,nosuid,umask=0,nodev 0 0
none /mnt/cdrom2 supermount fs=iso9660,dev=/dev/scd0,--,iocharset=iso8859-1,codepage=850,ro,nosuid,umask=0,nodev 0 0
none /mnt/floppy supermount fs=vfat,dev=/dev/fd0,--,codepage=850,iocharset=iso8859-1,nosuid,umask=0,unhide,nodev 0 0
/dev/hda1 /mnt/win_c vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda5 /mnt/win_d vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda6 /mnt/win_e vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0

I want super moutn disabled (supermount -i diable) because every time I load a game with WineX i get the cd error. I saw a lot of people with the same problem but all their solutions did not work. I have a burner which is inaccessible with the default fstab. If you post please include things liek why this goes here. All the fstab sites I looked at looked similiar to this

http://www.humbug.org.au/talks/fstab/fstab.html

but it wouldn't work when i made the fstab thanks for all the help.

Gonus
 
Old 10-07-2002, 01:43 AM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Well, really from that page, it would seem that should explain it all quite well. Here's what I'd put in place of the cdrom entry:
Code:
/dev/cdrom       /mnt/cdrom   iso9660     noauto,owner,ro         0  0
and for your burner:
Code:
/dev/cdrw       /mnt/cdrom2   iso9660     noauto,owner,ro         0  0
Because those are similar to my entries

I believe by removing those supermount options from your fstab will make it so that you don't use supermount for those particular devices. This would be good if you wanted to continue to use it for other devices, meaning you didn't want to disable it completely.
You will also need to make the symlinks if your distro hasn't:
ln -sf /dev/hdc /dev/cdrom

And for your burner drive:
ln -sf /dev/scd0 /dev/cdburner
ln -sf /dev/scd0 /dev/cdrw

Don't forget to logout and back in. And this should all be done as root btw.

Cool
 
Old 10-07-2002, 11:11 AM   #3
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
Ok. Will give that a try. Just curious, why is it /dev/cdrom vice /dev/hdc? Or is cdrom expected to be replaced with hdd? wanna make sure I do it right.

Thanx
 
Old 10-08-2002, 09:28 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Well, if you make the symlinks I talked about, then /dev/cdrom will actually be pointing to your correct cdrom device, /dev/hdc

If you cdrom device is /dev/hdd then replace that in the symlink I provided. To find out which one, simply do this as root:
eject /dev/hdc
and see if you cdrom device ejects. If it does, then you are good to go.

Cool
 
Old 10-08-2002, 03:02 PM   #5
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
Hi
If you only want to get rid of automount you can fire up
mcc (be root) choose; moint points , your cd device, options
there you can change that.
For experimenting anyways, back up your fstab, take the lines
concerning the removable media like cd or floppy out , save it
reboot and then use them from command line only.
That makes sure no supermount or automount daemon is
messing around.
regards

oh for the difference in fstab entries; if you use the proper symlinking the /dev/cdrom should work fine but mandrake uses
/mnt/cdrom redhat and some others /dev/cdrom
 
Old 10-09-2002, 03:58 PM   #6
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
with supermount -i diable it gets rid of the supermount in fstab. I can mount cdrom. I can ls and see contents of cd in cdrom. This is what I get when I try to mount cdrom2 with mount cdrom2 (this is doen in mnt dir)

mount cdrom2
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems

when I mount -t cdrom2 I can then cd to cdrom2 but i can not see contents of the cdrom. same when i mount /dev/scd0. Any ideas?
 
Old 10-09-2002, 09:10 PM   #7
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
SO, just to clarify:
If you:
su -
ENTER PASS
mount -t iso9660 /dev/scd0 /mnt/cdrom2
cd /mnt/cdrom2
ls
You get nothing?

Cool
 
Old 10-09-2002, 11:16 PM   #8
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
doh I didn't know I needed to enter /mnt/cdrom2. Will try that and let you know what happens thanx.

Gonus
 
Old 10-12-2002, 02:27 PM   #9
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
here is what I get for that
i enter:

mount -t iso9660 /dev/sdc0 /mnt/cdrom2

i get:

mount: special device /dev/sdc0 does not exist

any ideas?
 
Old 10-12-2002, 04:24 PM   #10
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
I am thinking that's a typo here, not in your command right:
/dev/scd0
NOT
/dev/sdc0

Anyway, you might need to find out where the drive is use:
cdrecord -scanbus
and it should tell ya.

Cool
 
Old 10-13-2002, 07:51 AM   #11
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
cdrecord -scanbus
Cdrecord 1.11a28 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schillin g
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.6'
scsibus0:
0,0,0 0) *
0,1,0 1) *
0,2,0 2) *
0,3,0 3) 'LITE-ON ' 'LTR-24102B ' '5S54' Removable CD-ROM
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

I know the cdr works I can burn cds in linux but I can't mount it.
 
Old 10-13-2002, 07:58 AM   #12
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
and yeah was a typo. I get same error that I started wth then.
 
Old 10-13-2002, 07:58 AM   #13
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
presumably you should be using scd3, not scd0 as that's where it is on the scsi bus...
 
Old 10-17-2002, 07:11 AM   #14
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
did you get that from the cdrecord -scanbus? Where it shows up as the 3rd? Wouldn't the symbolic links that it creates be correct if I could burn cd's? Or is that the sd03 that it burns to and the sym links to the cdrom device are bad? Would they need to be updated to read scd3 instead of 0? I have given up on the cdrecorder so far because everytime I insert a cd it ejects it. No matter what format it is. But if this is a possible solution I will give that a try. I thought it was a broken piece of gear.

Gonus
 
Old 10-17-2002, 02:23 PM   #15
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Well...

This line suggest it's scd3:
0,3,0 3) 'LITE-ON ' 'LTR-24102B ' '5S54' Removable CD-ROM

You could create symlinks, but you shouldn't create them for actual devices, so I wouldn't say to symlink /dev/scd0 with scd3

Instead, a lot of program will look for /dev/cdburner; /dev/cdrw; or /dev/cdwriter

So you will want to make the symlink between scd3 and those devices rather.

BUT, most of your programs have a built in feature to autmagically discover your burner device, see if you can locate the one your program uses, or do it all command line.

Did it not work?

I am a little confused by your reply as to what you want now..

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 07:15 AM
newbie vs fstab. fstab wins :( blop Linux - Newbie 3 01-07-2005 06:54 AM
making drives mountable and writable by non-root users in fstab asdfjkl Linux - Hardware 5 10-19-2004 11:10 PM
(version 5.1 chapter 08 fstab) vs (man fstab) rgiggs Linux From Scratch 2 06-03-2004 06:55 PM
fstab and devices (making) TheBman Linux - Hardware 14 12-31-2003 10:55 AM


All times are GMT -5. The time now is 02:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration