LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   help with making new fstab (http://www.linuxquestions.org/questions/linux-software-2/help-with-making-new-fstab-32097/)

gonus 10-07-2002 12:22 AM

help with making new fstab
 
running mandrake 9 beta3. Need to make a new fstab that does not utilize supermount. I checked out quit a few places but everyftab I wrote didn't work. Here is my default fstab..

/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdb6 /home ext3 defaults 1 2
none /mnt/cdrom supermount fs=iso9660,dev=/dev/hdc,--,iocharset=iso8859-1,codepage=850,ro,nosuid,umask=0,nodev 0 0
none /mnt/cdrom2 supermount fs=iso9660,dev=/dev/scd0,--,iocharset=iso8859-1,codepage=850,ro,nosuid,umask=0,nodev 0 0
none /mnt/floppy supermount fs=vfat,dev=/dev/fd0,--,codepage=850,iocharset=iso8859-1,nosuid,umask=0,unhide,nodev 0 0
/dev/hda1 /mnt/win_c vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda5 /mnt/win_d vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda6 /mnt/win_e vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0

I want super moutn disabled (supermount -i diable) because every time I load a game with WineX i get the cd error. I saw a lot of people with the same problem but all their solutions did not work. I have a burner which is inaccessible with the default fstab. If you post please include things liek why this goes here. All the fstab sites I looked at looked similiar to this

http://www.humbug.org.au/talks/fstab/fstab.html

but it wouldn't work when i made the fstab thanks for all the help.

Gonus

MasterC 10-07-2002 12:43 AM

Well, really from that page, it would seem that should explain it all quite well. Here's what I'd put in place of the cdrom entry:
Code:

/dev/cdrom      /mnt/cdrom  iso9660    noauto,owner,ro        0  0
and for your burner:
Code:

/dev/cdrw      /mnt/cdrom2  iso9660    noauto,owner,ro        0  0
Because those are similar to my entries :)

I believe by removing those supermount options from your fstab will make it so that you don't use supermount for those particular devices. This would be good if you wanted to continue to use it for other devices, meaning you didn't want to disable it completely.
You will also need to make the symlinks if your distro hasn't:
ln -sf /dev/hdc /dev/cdrom

And for your burner drive:
ln -sf /dev/scd0 /dev/cdburner
ln -sf /dev/scd0 /dev/cdrw

Don't forget to logout and back in. And this should all be done as root btw.

Cool

gonus 10-07-2002 10:11 AM

Ok. Will give that a try. Just curious, why is it /dev/cdrom vice /dev/hdc? Or is cdrom expected to be replaced with hdd? wanna make sure I do it right.

Thanx

MasterC 10-08-2002 08:28 AM

Well, if you make the symlinks I talked about, then /dev/cdrom will actually be pointing to your correct cdrom device, /dev/hdc

If you cdrom device is /dev/hdd then replace that in the symlink I provided. To find out which one, simply do this as root:
eject /dev/hdc
and see if you cdrom device ejects. If it does, then you are good to go.

Cool

mrGee 10-08-2002 02:02 PM

Hi
If you only want to get rid of automount you can fire up
mcc (be root) choose; moint points , your cd device, options
there you can change that.
For experimenting anyways, back up your fstab, take the lines
concerning the removable media like cd or floppy out , save it
reboot and then use them from command line only.
That makes sure no supermount or automount daemon is
messing around.
regards

oh for the difference in fstab entries; if you use the proper symlinking the /dev/cdrom should work fine but mandrake uses
/mnt/cdrom redhat and some others /dev/cdrom

gonus 10-09-2002 02:58 PM

with supermount -i diable it gets rid of the supermount in fstab. I can mount cdrom. I can ls and see contents of cd in cdrom. This is what I get when I try to mount cdrom2 with mount cdrom2 (this is doen in mnt dir)

mount cdrom2
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems

when I mount -t cdrom2 I can then cd to cdrom2 but i can not see contents of the cdrom. same when i mount /dev/scd0. Any ideas?

MasterC 10-09-2002 08:10 PM

SO, just to clarify:
If you:
su -
ENTER PASS
mount -t iso9660 /dev/scd0 /mnt/cdrom2
cd /mnt/cdrom2
ls
You get nothing?

Cool

gonus 10-09-2002 10:16 PM

doh I didn't know I needed to enter /mnt/cdrom2. Will try that and let you know what happens thanx.

Gonus

gonus 10-12-2002 01:27 PM

here is what I get for that
i enter:

mount -t iso9660 /dev/sdc0 /mnt/cdrom2

i get:

mount: special device /dev/sdc0 does not exist

any ideas?

MasterC 10-12-2002 03:24 PM

I am thinking that's a typo here, not in your command right:
/dev/scd0
NOT
/dev/sdc0

Anyway, you might need to find out where the drive is use:
cdrecord -scanbus
and it should tell ya.

Cool

gonus 10-13-2002 06:51 AM

cdrecord -scanbus
Cdrecord 1.11a28 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schillin g
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.6'
scsibus0:
0,0,0 0) *
0,1,0 1) *
0,2,0 2) *
0,3,0 3) 'LITE-ON ' 'LTR-24102B ' '5S54' Removable CD-ROM
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

I know the cdr works I can burn cds in linux but I can't mount it.

gonus 10-13-2002 06:58 AM

and yeah was a typo. I get same error that I started wth then.

acid_kewpie 10-13-2002 06:58 AM

presumably you should be using scd3, not scd0 as that's where it is on the scsi bus...

gonus 10-17-2002 06:11 AM

did you get that from the cdrecord -scanbus? Where it shows up as the 3rd? Wouldn't the symbolic links that it creates be correct if I could burn cd's? Or is that the sd03 that it burns to and the sym links to the cdrom device are bad? Would they need to be updated to read scd3 instead of 0? I have given up on the cdrecorder so far because everytime I insert a cd it ejects it. No matter what format it is. But if this is a possible solution I will give that a try. I thought it was a broken piece of gear.

Gonus

MasterC 10-17-2002 01:23 PM

Well...

This line suggest it's scd3:
0,3,0 3) 'LITE-ON ' 'LTR-24102B ' '5S54' Removable CD-ROM

You could create symlinks, but you shouldn't create them for actual devices, so I wouldn't say to symlink /dev/scd0 with scd3

Instead, a lot of program will look for /dev/cdburner; /dev/cdrw; or /dev/cdwriter

So you will want to make the symlink between scd3 and those devices rather.

BUT, most of your programs have a built in feature to autmagically discover your burner device, see if you can locate the one your program uses, or do it all command line.

Did it not work?

I am a little confused by your reply as to what you want now..

Cool


All times are GMT -5. The time now is 06:02 AM.