LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-23-2003, 10:34 PM   #1
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
help with GLIB and GTK


I am trying to install xmms on mandrake 9.2 and of course i am having dependency problems. every time i run ./configure for anything i am trying to install i get varying different errors. with xmms i am getting:

checking for glib-config... no
checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

so i tried to install GLIB 1.2.10 but it extracted to the current directory wich is my download directory where should GLIB be extracted to ??? thanks for any help.
 
Old 12-24-2003, 04:35 AM   #2
fr0zen
Member
 
Registered: Nov 2003
Location: 127.0.0.1
Distribution: xubuntu
Posts: 217

Rep: Reputation: 30
Make sure you run configure as ./confogure --prefix=/usr

Mandrake installs GTK, GLIB and all its other fans into the /usr directory. You also need the devel packages, too. You can install these via the MDK Control Panel (software management). Just search for dev or something similar.

Good luck.
 
Old 12-24-2003, 05:13 PM   #3
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Original Poster
Rep: Reputation: 46
Thanks, I fixed that but now i get 1.2.2 not found but it is installed and i just installed 1.2.10 and it still says not found. I assume because its looking for the earlier version not the newer one but it says it found 1.2.2 but then it says its not installed??

How do i fix this? I dont know how to set envionment variables or remove the older version. Thanks

checking for GLIB - version >= 1.2.2...
*** 'glib-config --version' returned 1.2.2, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
 
Old 12-25-2003, 05:42 PM   #4
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Original Poster
Rep: Reputation: 46
Anyone have any idea how to fix this problem? I cannot install the devel packages from cd every time i try i get errors that i cannot copy and past cuz they are in dialog boxes and they are no help anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 11:57 AM
glib and gtk + charnel Linux - Software 3 04-13-2005 10:46 AM
Glib/gtk what is it ? i really need him ? SlackwareMan Linux - Newbie 6 07-31-2004 05:56 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Gtk/glib tombomb300 Linux - Software 7 10-01-2003 02:30 PM


All times are GMT -5. The time now is 08:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration