LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-04-2003, 04:56 PM   #1
mlbaker
LQ Newbie
 
Registered: Mar 2003
Posts: 13

Rep: Reputation: 0
help with dependencies for ant on RH9


Hello all. Im working on installing ant on RH9. I have managed to get rid of all the dependencies except for one. I have searched the web, and cant find the missing package. The missing package is java-devel. I have the java sdk installed as you can see in the second command. Just for more info i searched for java also.

Thank you for any help!
Matt.

[root@localhost mlbaker]# rpm -i ant-1.5.2-13jpp.noarch.rpm
warning: ant-1.5.2-13jpp.noarch.rpm: V3 DSA signature: NOKEY, key ID c431416d
error: Failed dependencies:
java-devel is needed by ant-1.5.2-13jpp
[root@localhost mlbaker]# rpm -qa |grep -i j2sdk
j2sdk-1.4.1_02-fcs
[root@localhost mlbaker]# rpm -qa |grep -i java
gcc-java-3.2.2-5
[root@localhost mlbaker]#
 
Old 04-04-2003, 09:48 PM   #2
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
did u try www.rpmfind.net ?
 
Old 04-05-2003, 01:07 AM   #3
mlbaker
LQ Newbie
 
Registered: Mar 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Doublefailure,

I had not, but java-devel was not found when i did a search. Thank you for the suggestion.

I installed ant on RH8 from the rpm with no problem. I dont know why this dependency is popping up. I thought maybe the rpm that i need would be on the RH9 disks, so I searched the first three RH9 disks for any rpm that had java in the filename. I found two. Neither of them had devel also in the filename....

Thanks,
Matt.
 
Old 04-05-2003, 02:14 PM   #4
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
why don't u just install binary file from sun
get rid of sdk rpms and install binary file
 
Old 04-05-2003, 03:08 PM   #5
mlbaker
LQ Newbie
 
Registered: Mar 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Doublefailure,

Haha! Ya, but im new to linux, and am trying to learn how to use the package management system. I guess the package management system is only good for some things.

Since the java rpm seems to be working good I downloaded and installed the binary version of ant. Setup a few environment vars and everything seems to be working great.

Thank you for your help,
Matt.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lftp dependencies RH9, package manage? malaka56 Linux - Software 1 07-09-2005 08:56 AM
RH9 Hanging at "Finding Module Dependencies" linuxharsha Linux - Software 2 03-23-2005 10:37 AM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 08:58 PM
Installing gaim-0.74 on RH9 - File Dependencies Cr4wford Red Hat 5 11-30-2003 02:30 PM
RH9 boot freezes @ Module Dependencies evil.messiah Linux - Newbie 6 07-23-2003 09:59 AM


All times are GMT -5. The time now is 10:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration