LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-25-2004, 03:33 AM   #1
limiter
Member
 
Registered: Oct 2003
Posts: 47

Rep: Reputation: 16
help setting up Apache to use cgi scripts


i am running fedora core 1
i did:
;apt-get install httpd'
'apt-get install perl'
'apr-get install perl-DBI'

it setup folders in /var/www/ where there is a /html /cgi-bin folders
i placed a .cgi file in the /cgi-bin/ folder and ensured that the file pointed to the installation of perl, made sure that both the folder and file where CHMODed to 755 (even 777 to be sure). And i still am getting a Internal server Error (500).
I downloaded "redhat-config-httpd" program to try and edit my config file through a GUI, i thought i had set the configuration in that program to allow for cgi-scripts to be ran in the /var/www/cgi-bin folder but it still does not work.
Yes i did try to re-start the server so i know that the changes i made are in effect.
please please can someone help me? i've been sitting here tinkering trying to make it work for 4 and a half hours straight and have been scouring the internet to try and see if i can get help but nothings come up.
I would give a link to my website but i am behind a university firewall and do not have a static IP accessable from the outside.
 
Old 03-25-2004, 03:34 AM   #2
limiter
Member
 
Registered: Oct 2003
Posts: 47

Original Poster
Rep: Reputation: 16
output of "httpd -l" is (because i know this is important somehow
core.c
prefork.c
http_core.c
mod_so.c

so shouldn't i have some kind of mod_cgi file show up when i do this?
 
Old 03-25-2004, 01:59 PM   #3
limiter
Member
 
Registered: Oct 2003
Posts: 47

Original Poster
Rep: Reputation: 16
ok, con someone please help me? i know it has to be my config file. When in the terminal i type "perl perl_test.cgi" my perl test file runs just fine. However when from a browser on my laptop i type in my local address: http://10.65.0.xx/cgi-bin/perl_test.cgi i get an internal server error. If i just type in http://10.655.0.xx/perl_test.cgi it just shows all the code of the perl file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant run CGI scripts on Apache! mylo2003 Linux - General 5 11-09-2004 09:22 AM
apache & cgi scripts maze_fire Linux - Networking 1 08-12-2004 02:58 PM
configuring apache for cgi scripts ash_r_c Linux - Software 1 09-23-2003 04:03 PM
Apache 2.0.43 will not run cgi scripts RobbieRoy Linux - Networking 5 09-04-2003 02:56 PM
Apache cgi scripts! boyinfrance Linux - Newbie 2 06-22-2002 10:33 PM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration