LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   HELP nvidia + xorg.conf = BIG PIXELS (http://www.linuxquestions.org/questions/linux-software-2/help-nvidia-xorg-conf-%3D-big-pixels-251393/)

fatblueduck 11-05-2004 02:55 AM

HELP nvidia + xorg.conf = BIG PIXELS
 
I have tried very hard to figure out a solution to this problem and I have been unable. I am using the volatil 2.6.9 'vanilla' development kernel from kernel.org. I am using the gentoo linux distro. Here is the problem.

I have my xorg.conf gile edited to run Display at default depth 24 with
modes "1440x900" "1280x1024" "1280x960"
when I run startx, the nvidia logo is huge and pixelated and the desktop is as well
If xorg.conf is edited with the 'nv' driver, the desktop is a normal size, but there is no nvidia.

running /var/log/xorg.0.log shows me these troubling lines...
(WW) NVIDIA (0): The user specified HorizSync "31.500-100.00" has been
(WW) NVIDIA (0): adjusted to "31.500-55.000" (the intersection with
(WW) NVIDIA (0): EDID-specified HorizSync "29.000-55.000")
(WW) NVIDIA (0): The user specified VertRefresh "59.000-75.00" has been
(WW) NVIDIA (0): adjusted to "59.000-60.000" (the intersection with
(WW) NVIDIA (0): EDID-specified HorizSync "0.000-60.000")


I'm pretty sure that all P25s use the same 31.5-100 horiz sync and 59-75 vert refresh rates.
Anyway, I've always used those refresh rates succesfully. I am wondering if there is something compiled into the kernel which affects the display of x-windows. I have installed the system three times in a row, and each time this has happened (on one install I used the 2.6.8 kernel) The one thing that all of these installs have in common is that they are the first three times I have configured my own kernel.

No one on the gentoo message boards seems able to help me and I hope someone here might be able to help me. Thanks

Hammett 11-05-2004 03:55 AM

Have you tried to override what EDID says about refresh rates? I know there's an option to nvidia drivers to override this, but cannot remember which. Anyway, on the nvidia readme you have all the options to pass to nvidia drivers.

fatblueduck 11-05-2004 05:42 AM

I added Option "IgnoreEDID" "1"
to my xorg.conf
startx went nuts, showing bands of flourescent ping, yellow dots, and the like.
I didn't check the log (I'm pretty sure you have to be in Xwindows to do it?) I simply Alt+Ctrl+Bckspce'd out of there.
Thanks, I really thought that passing the IgnoreEDID option would solve the problem. Looks like I am in a dead end again.

bigjohn 11-05-2004 06:48 AM

The only time I've had a weird problem like that is when I used the virtual screen sizing thing i.e. where the system is actually generating a screen size much bigger than your actual monitor, and you can run/scroll off the edge of the screen. That was when I was meddling with debian though (if my memory serves me correctly).

Quote:

have tried very hard to figure out a solution to this problem and I have been unable. I am using the volatil 2.6.9 'vanilla' development kernel from kernel.org. I am using the gentoo linux distro.
Or, given your comment as above, have you looked here :confused:

regards

John


All times are GMT -5. The time now is 04:40 AM.