LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-08-2004, 03:26 PM   #1
ihealthbuzz
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
HELP! GLIBC 2.3 Upgrade in redhat 7.2 problem


Hi everyone.. I am new to redhat and inherited a system with RH 7.2. However, I need to upgrade to GLIBC 2.3 in order to run a program. However, I have tried to download the rpm for 2.3 but no luck. It gives me tons of dependency errors. What is the easiest way to upgrade? Anyone have experience with this on redhat? I read that this is a troublesome and painful procedure.... please help!!! I called redhat tech support and they just said go to google.
 
Old 10-08-2004, 03:34 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
you will have a LOT of dependencies, and reall you shouldn't be that suprised... that distro is over 3 years old, forever in linux. you'll need to either satisfy those deps... or compile glibc from source.

you *might* be able to get an updated RH72 rpm for glibc specifically, as despite being old, updates do still come out for old distro's.. i'm still on 7.3 on my webserver.

you might have better luck coming from the other side. if possible get this problem program in source and compile it under glibc 2.2, should be ok.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat 8 glibc problem k3di Linux - Software 8 05-10-2005 11:41 AM
glibc upgrade with upgrading kernel, problem? Gates1026 Linux - General 3 04-15-2005 03:10 PM
upgrade glibc problem chamalsl Linux - Newbie 3 01-29-2005 05:31 AM
upgrade glibc-2.2.4 to glibc-2.3.2 on redhat 7.2 Shuja Red Hat 0 07-28-2004 06:10 AM
wrong upgrade of glibc . Can i go back to the correct version? RedHat 7.3 enrique-t Red Hat 1 03-06-2004 02:52 PM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration