LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-10-2004, 08:18 PM   #1
edman007
Member
 
Registered: Sep 2003
Distribution: Slamd64
Posts: 168

Rep: Reputation: 30
help getting my video card working fully(xfree86 config maybe?)


my video card is working for stuff like KDE and Gnome, but games like amercias army and Wolfenstein Enemy Territory won't work at all

amercias army says:
Code:
Couldn't set video mode: Couldn't find matching GLX visual
and Wolfenstein Enemy Territory says:
Code:
Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
Failed to detect XF86DGA Mouse
Using 8/8/8 Color bits, 16 depth, 0 stencil display.
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
GL_RENDERER: Mesa GLX Indirect
blah..blah..blah..
Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
i have uncommented 'Load "glx"' and 'Load "dri"' and commented out this:
Code:
#    SubSection  "extmod"
#      Option    "omit xfree86-dga"   # don't initialise the DGA extension
#    EndSubSection
but it still dosen't work, what else do i have to do to get it to work, i have slackware current, 2.6.1 kernel, and ASUS v9520 Magic geforce fx 5200 vid card with 64mb ram
 
Old 01-11-2004, 12:34 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Have a look at your
/var/log/XFree86.0.log
and see which module it actually loads...


How did you set X up in the first place?
If you are running the slack-defaults then
you're probably on the VESA driver, which
in fact doesn't support OpenGL. You will
probably want to get nVidia drivers for
Linux of their web-site.


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to downgrade to XFree86-3.x? (old video card..) forrest44 Slackware 3 03-09-2005 03:17 AM
Fedora 2 2Wire card not fully working anthony1101 Linux - Laptop and Netbook 26 01-19-2005 03:44 PM
Fedora 3 2Wire card not fully working (possible wrong driver?) anthony1101 Linux - Laptop and Netbook 1 11-30-2004 12:44 PM
XFree86 Problems with Dell Video Card wood_dog Linux - Newbie 2 11-14-2004 01:28 AM
Problem with Xfree86 and video card pengStudent Debian 4 12-08-2003 01:30 PM


All times are GMT -5. The time now is 09:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration