LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 03-12-2005, 08:20 PM   #1
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Rep: Reputation: 30
Exclamation Help getting Japanese characters to display correct


I can't figure out what I need to do to get Japanese characters to display correctly. They are displaying, but they are just boxes with 4 hexadecimal numbers in them and no matter what I try, the font just won't display. Here's what I have installed:
  • xfonts-intl-japanese - International fonts for X -- Japanese
    xfonts-intl-japanese-big - International fonts for X -- Japanese big
    uim - Simple, secure, and flexible input method collection and library
    uim-common - Common files for uim
    uim-fep - uim Front End Processor
    uim-gtk2.0 - GTK+2.x immodule for uim
    uim-utils - Utilities for uim
    uim-xim - A bridge between uim and XIM


Uim IS working and I can input japanese just fine, but it still won't display right even though I have the fonts installed. I'm running wdm as my display manager. Does anyone have any clue on how I can get this working???

I am using this guide: http://www.jw-stumpel.nl/input.html and put the following in my .xinitrc file:

Code:
export XMODIFIERS=@im=uim
export GTK_IM_MODULE=uim
uim-toolbar-gtk-systray&
uim-xim&
Thanks for any assistance. ほんとうにありがとうございます。
 
Old 03-12-2005, 09:10 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
http://www.mayin.org/aragorn/Japan/linux.html
 
Old 03-13-2005, 12:34 AM   #3
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
Thanks, but that site is outdated. I had uim installed on my previous Debian system and it worked fine.


I think I found the problem though. I found out that those commands in my .xinitrc file weren't being run. Neither .xinitrc nor .xsession will run on start-up, and I think it's because I'm using WDM as my display manager. I'm a little confused as to what to do now. I found this directory:

Code:
roots@harima:~$ ls /etc/X11/wdm
Xaccess  Xreset_0    Xresources_0  Xsession  Xsetup_0  Xstartup_0  wdm.options
Xreset   Xresources  Xservers      Xsetup    Xstartup  wdm-config

And I thought Xsession might be a wrapper so I put those commands in there and re-booted, but when I logged in it said something bad about GTK_IM_MODULE and it would refuse to let me login, so I had to go and take out the commands from the file to get back into X. However, when I run those commands on my command line while I'm in X everything is fine...


Does anyone know what WDM file I should add these commands to?


>>>EDIT<<<
Nevermind, I found out I accidentally called set to set the environmental variables but it was a sh script. I can get into X fine now, but Japanese characters still refuse to display.

Last edited by R00ts; 03-13-2005 at 12:40 AM.
 
Old 03-13-2005, 10:13 AM   #4
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
*bump*

Anyone have a clue? I really need Japanese to display on this machine so I can do some work...
 
Old 03-13-2005, 08:57 PM   #5
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Original Poster
Rep: Reputation: 30
I FIXED IT!!! I FINALLY FIXED IT!!! kissed 32 hours of my life good-bye, but it's working!!! YES!!! これはさいこうだぞ

The problem was in my XF86Config-4 file not specifying the correct font-path. I added these two lines before the unix local font server line:

Code:
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/usr/share/fonts/truetype"

I hope this helps someone one day, because I asked on IRC ever 2 hours and no one responded to my pleas for help.
 
Old 03-13-2005, 09:04 PM   #6
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
cool

yea sadly must of us are rather clueless about internationalization issues
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Input of Japanese characters LostInTranslation Linux - General 3 10-29-2005 09:07 PM
Display Japanese characters. Lowe Debian 6 06-10-2005 07:58 PM
Displaying Japanese characters gjarman Linux - General 1 05-01-2003 05:28 AM
Displaying Japanese characters gjarman Linux - Newbie 0 05-01-2003 01:52 AM
how to make linux display Japanese characters? digizer0 Linux - General 20 04-12-2003 06:45 PM


All times are GMT -5. The time now is 02:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration