LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-04-2003, 02:42 AM   #1
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Rep: Reputation: 15
Unhappy Help Configuring Samba


Am new on Linux. I recently did install Linux8.0, then had problems configuring Samba after this command:

# smbclient -U% -L localhost

Error:

added interface ip=194.180.75.90 bcast=194.180.255 nmask=255.255.255.0
error connecting to 127.0.0.1:139 (connection refused)
error connecting to 127.0.0.1 (connection refused)

connection to localhost failed>

Can anyone pls help

Ad
 
Old 08-04-2003, 03:36 AM   #2
zmedico
Member
 
Registered: Feb 2002
Location: Mission Viejo, California, USA
Distribution: Gentoo
Posts: 707

Rep: Reputation: 30
Did you start the service ("/sbin/service smb start"). Does "netstat -tuanp" confirm that the servers are listening?
 
Old 08-04-2003, 03:39 AM   #3
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 49
Is samba running?

service smb start
 
Old 08-04-2003, 08:49 AM   #4
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Original Poster
Rep: Reputation: 15
When I tried: /usr/sbin/ smbd
or
smbd start from whatever directory level,

DID NOT RETURN ANY VALUE or ERROR MESSAGE

/usr/sbin/ smb start

RETURNED: Command not found!

what else have I got to do please?????
 
Old 08-04-2003, 09:05 AM   #5
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
Have you installed the samba server?

rpm -q samba

will tell you if you have or have not.

Find your installation disks and look for the samba rpm
and then install with

rpm -ivh samab-{whatever_version}.rpm

Please note that there have been many security fixes to samba since the RH8 version, so you should get the latest version from the Red Hat site.
 
Old 08-04-2003, 09:10 AM   #6
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Original Poster
Rep: Reputation: 15
SORRY I HAVE TO BOTHER U GUYS MORE111

#Testparm

result:

Load smb config files from //etc/samba/smb.conf
Processing Sections "[netlogon]"
Global parameter logon path found in Service Section!
Global parameter logon home found in Service Section!
Processing Sections "[profiles]"
Processing Sections "[homes]"
Processing Sections "[Printers]"
Loades Services file OK.

I still cant locate source of the problem.

Ad
 
Old 08-04-2003, 09:15 AM   #7
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Original Poster
Rep: Reputation: 15
Dear Corrin,

I hate installed Samba. The command:

rpm -q samba

produced the response:

samba-2.2.3a-64

How else can I resolve this please.

thanks

Ad
 
Old 08-04-2003, 09:28 AM   #8
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
Quote:
Originally posted by Adibe_Hamm
When I tried: /usr/sbin/ smbd
or
smbd start from whatever directory level,

DID NOT RETURN ANY VALUE or ERROR MESSAGE

/usr/sbin/ smb start

RETURNED: Command not found!

what else have I got to do please?????
Did you run the command as user root?

You can only start smb as root

Also if you want to ensure that smb starts whenever you but up your machine, as user root, fire up

redhat-config-services

and enable smb to stop in runlevels 0, 1, 2, and 6
and enable smb to start in runlevels 3, 4, 5

I trust that your default runlevel is either 3 or most probably 5
(with Xserver running).
 
Old 08-04-2003, 09:29 AM   #9
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Original Poster
Rep: Reputation: 15
Zmedico,

thanks for your tip.

/sbin/service smb start

produced response:

commend not found

and #whereis service

produced response

:service

what else can I do please???

ad
 
Old 08-04-2003, 11:24 AM   #10
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 49
As Corin pointed out, you need to have root privileges to start or stop a service.

you can login as root and run

service smb start
 
Old 08-04-2003, 03:02 PM   #11
zmedico
Member
 
Registered: Feb 2002
Location: Mission Viejo, California, USA
Distribution: Gentoo
Posts: 707

Rep: Reputation: 30
Quote:
Originally posted by Adibe_Hamm
/sbin/service smb start

produced response:

command not found
That's strange because on Redhat 9 that command is part of the initscripts package, which is required. You can verify that package with "rpm --verify initscripts". You may also want to verify the samba package.

BTW- /sbin/service isn't required. The script /etc/rc.d/init.d/smb can be ran directly. Of course, first use "su" to become root.

Last edited by zmedico; 08-04-2003 at 03:04 PM.
 
Old 08-05-2003, 05:21 AM   #12
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Original Poster
Rep: Reputation: 15
Zmediko,

rpm --verify initscripts

produced the response:

package initscripts is not installed.

must i install it thru Yast please?

thanks

ad
 
Old 08-05-2003, 03:49 PM   #13
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
If you are on a SuSE system, then you do indeed need to install the package initscripts, and this is most easily done through YaST[2].
 
Old 08-06-2003, 03:30 AM   #14
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Original Poster
Rep: Reputation: 15
thanks Corin, how do i install the Package Initscripts thru YaST2. Ihave tried several CDs from the available 7 CDs in the package, but cant get an auto run Installation.
 
Old 08-06-2003, 04:30 AM   #15
Adibe_Hamm
Member
 
Registered: Jul 2003
Posts: 36

Original Poster
Rep: Reputation: 15
HURRAH!!! I seems to be making some progress, but......

# smbclient -U% -L localhost

produced the response:


added interface ip=127.0.0.1 bcast=127.255.255.255 nmask=255.0.0.0
added interface ip=194.180.75.90 bcast=194.180.255 nmask=255.255.255.0
Domain=[ARBEITSGRUPPE] OS=[Unix] Service=[Samba 2.2.3a]

Sharename Type Comment
-------------- ------ ------------
netlogon Disk Network Logon Service
IPC$ IPC IPC Service (Samba 2.2.3a)
ADMIN$ Disk IPC Service (Samba 2.2.3a)

Server Comment
-------- ------------

Workgroup Master
------------- ---------

BUT AM YET TO LOCATE THE LINUX/SAMBA SERVER ON MY WINDOWS SERVER.

pls help

ad

Last edited by Adibe_Hamm; 08-06-2003 at 04:37 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Samba alexr186 SUSE / openSUSE 1 10-18-2005 10:19 AM
Configuring Samba sibtay Linux - Networking 3 10-04-2004 01:21 PM
Need ur help in configuring Samba safrout Linux - Networking 3 06-24-2004 05:04 AM
configuring samba raven Linux - Software 1 06-10-2002 08:56 AM
configuring samba gxd2639 Linux - Networking 2 03-13-2001 07:06 PM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration