LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 12-04-2008, 10:03 PM   #1
Nabu
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Rep: Reputation: 0
[Solved] Help configuring lpd and printcap


I am running RH 6.2 and I am having a problem getting lpd to print to a HP networked printer.

I think it may be permissions related and as far as I know cups is not being used (ps aux |grep cup returns nothing).

The printcap file looks like this:
##PRINTTOOL3## REMOTE TEXT NAxNA a4 {} TextPrinter Default {}
Q5:\
:lp=:\
:sd=/var/spool/lpd/Q5:\
:rm=10.1.1.12:\
:rp=text:\
:mx#0:\
:sh:

lpd looks to be running as root (ps aux returns root in the first column)
The spooler directory permission (var/spool/lpd/Q5) is 777 root:lp
The files that are created in that queue have: 660 bin:lp or 660 root:lp

lpc status returns:
Q5:
queuing is enabled
printing enabled
12 entires in spool area
waiting for 10.1.1.12 to come up

The printer (which is a HP with a DirectJet built-in) is confirmed to be on-line with paper loaded.
A windows workstation can print to the printer through the network.

If I submit a job with lpr -P Q5 text.txt is just adds to the queue.

/var/log/messages doesn't show up any errors...

Is there anywhere else I can look for clues in resolving this?

Thanks in advance.

N.

Last edited by Nabu; 12-17-2008 at 01:36 AM. Reason: Solved
 
Old 12-10-2008, 12:46 AM   #2
Nabu
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Ok still no success, however I have done some more testing.

I know the printer that I am trying to print to uses port 9100, as I can telnet from the RH server: telnet 10.1.1.12 9100

I can enter various strings of text,etc. and the page will print.

Is there a way to tell lpd to use port 9100 in the printcap configuration file? Perhaps it is using port 515...

N.
 
Old 12-17-2008, 01:34 AM   #3
Nabu
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Original Poster
Rep: Reputation: 0
[Solved]

In the end, port 515 (lpr) is not available on the HP printer, which is what lpd uses by default.
You specify an alternate port (9100 in this case) with the lp option and remove the rm option in the printcap file as follows:

##PRINTTOOL3## REMOTE TEXT NAxNA a4 {} TextPrinter Default {}
Q5:\
:lp=9100@10.1.1.12:\
:sd=/var/spool/lpd/Q5:\
:rp=Q5:\
:mx#0:\
:sh:


Thanks for listening..

N.
 
  


Reply

Tags
hp, jetdirect, laserjet, lpd, network, printing


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Get list of LPD queue names from LPD server? jantman Linux - Hardware 0 02-07-2008 12:21 PM
help with printcap config file gfem Fedora 1 10-18-2006 05:00 PM
cups-client and /etc/printcap mrodmac Linux - General 1 06-20-2006 08:42 PM
PRINTCAP File Que David@330 Linux - Newbie 0 07-28-2004 03:21 AM
How to keep CUPSfrom protecting etc/printcap ? lostboy Linux - General 5 06-17-2004 12:15 PM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration