LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-20-2005, 06:08 AM   #1
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Rep: Reputation: 15
Help! Can't build Software because of missing GLIB


OK, this is the second piece of software that has done this to me and its annoying me to no end. I am trying to build an alarm module for XMMS and as its configuring, it spits out this message:

*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error:
*** GLIB >= 1.2.6 not installed - please install GLIB first ***

Thing is, I've successfully (to my knowledge, its sitting on my system..) built and installed Glib 2.6

I'm running bash, and I am sure I have done the right thing by putting in this command:

set GLIB_CONFIG /usr/local/lib/glib-2.0/include/glibconfig.h

but its still not working--the build script is not seeing my glib install what-so-ever. Any suggestions?

Thanks for the help!
 
Old 01-20-2005, 02:45 PM   #2
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,

configuring you mean running a ".configure" file?
if yes, can you post the output of
Code:
cd /path_to_program_source
grep -i prefix .configure
this PREFIX is something defined in the .configure file. you need to change it.

regards

slackie1000
 
Old 01-20-2005, 04:34 PM   #3
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks for your help.

When I try to run that it says

grep: .configure: no such file or directory

I typed in thus...

cd /home/allexus/xmmstuff/xmms-alarm-0.3.4 && grep -i prefix .configure


Did I miss anything?

Thanks again!
 
Old 01-20-2005, 04:56 PM   #4
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
if you installed glib yourself you'll need to:

Code:
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH
(this is assuming you did a ./configure, make, make install on the glib you compiled yourself)

NOTE: if you did not remove your old glib (the one that came from the system) from /usr/lib then you will have runtime linker problems. 2 ways to get around this:

1) remove the old library and reinstall the new glib to /usr (./configure --prefix=/usr)

2) set LD_LIBRARY_PATH to pick up /usr/local/lib before /usr/lib:

Code:
export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
NOTE2: generally, it is not a good idea to install two of the same library of the same major version on the same machine (like glib-2.4.7 and glib-2.6.0) unless this is exactly what you want.
 
Old 01-20-2005, 11:03 PM   #5
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
I have done this thus far:

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

and then

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

as well as

set LD_LIBRARY_PATH /usr/local/lib/glib-2.0/include/glibconfig.h

So far..not working... -=\

Anymore suggestions? Thanks again!

Just a note...I apparently didn't have any glib libraries on my system so...
 
Old 01-21-2005, 02:55 AM   #6
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
Re: Help! Can't build Software because of missing GLIB

Quote:
Originally posted by otakuprinzess
OK, this is the second piece of software that has done this to me and its annoying me to no end. I am trying to build an alarm module for XMMS and as its configuring, it spits out this message:

*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error:
*** GLIB >= 1.2.6 not installed - please install GLIB first ***

hi there,

what exactly you mean with "as its configuring"? this xmms alarm module is a source code (./configure ;; make ;; make install) ??
and you don't see a '.configure' file?
anyway, as __J wrote it is necessary to be sure about the default env variables - PATH - of your libraries. if you have and where they ae.

regards

slackie1000
 
Old 01-21-2005, 03:14 AM   #7
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks for the second round of help slackie1000...

As I'm running the command ./configure it comes back at the end saying it cannot find glib.

Reading this forum I have found out this is not an uncommon thing with the newer versions.

So I did something *really* smart (read:sarcasm) and decided to install an older version of GLIB. Of course I didn't remove the older one, because I simply do not know how to do such things when I build code from source.

I've tried all the tricks everyone has mentioned thus far and found myself stuck. So I'm trying to revert to an older GLIB version but now things are messed up because I get this error...

Quote:
checking for GLIB - version >= 1.2.6... *** 'glib-config --version' returned 1.2.8, but GLIB (1.2.10) *** was found! If glib-config was correct, then it is best *** to remove the old version of GLIB. You may also be able to fix the error *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing *** /etc/ld.so.conf. Make sure you have run ldconfig if that is *** required on your system. *** If glib-config was wrong, set the environment variable GLIB_CONFIG *** to point to the correct copy of glib-config, and remove the file config.cache *** before re-running configure no configure: error: *** GLIB >= 1.2.6 not installed - please install GLIB first ***

So now, as you see, I have version 1.2.8 but now it is saying it is 1.2.10.

Its given me ways to fix this problem, but I am thoroughly confused at this point. I want to remove all versions and start from scratch. So here's a question: how do I do this? I've been using Linux since 2000, and this is my first problem on this scale...

Thanks again,

Allexus

Last edited by otakuprinzess; 01-21-2005 at 03:15 AM.
 
Old 01-21-2005, 06:05 AM   #8
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
ohhh...
I thought this was a glib-2.x problem. for the gnome-1.4 libraries (including glib and gtk 1.x), they build -config executables that store the include and linking information. so on those, you have to include the correct path to the glib-config for configure to pick it up ( which it should have found if you did a regular ./configure, make, make install). first things first, if you have the glib-1.2.8 source directory still around go to it and do:

make uninstall

to remove that version. Then you will probably need to reinstall glib-1.2.10 and reconfigure. Make sure you can type glib-config --version in the xterm/console and recieve output (which should be 1.2.10). if it gives you a command not found, make sure /usr/local/bin is in your PATH. that should give configure what it needs to find the libs.

also, after glib-1.2.10 is installed, make sure /usr/local/lib is in /etc/ld.so.conf and run (as root):

ldconfig

so the linker knows the new libraries are there.

EDIT: are you sure glib-1.2.x did not come with your system (its pretty much standard )

do:

rpm -qa glib

in a terminal and see if you get any output.

also, glib surely could be installed by rpmdrake/urpmi ( just make sure you remove all the other stuff installed from source and make sure you get glib-1.2.10-ixxx.rpm and glib-1.2.10-devel-ixxx.rpm)

Last edited by __J; 01-21-2005 at 06:08 AM.
 
Old 01-21-2005, 11:31 AM   #9
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
When running

rpm -qa glib

it seems that nothing was returned on the output. So I think my distro is acting a bit wonky...

However I'm going to try and the 2.x version and see if this helps clear things up a bit.

I checked the version of glib installed and it came back as 1.2.8.

I tried running

make uninstall glib-2.6.1 to take care of my first installation but make kept saying "target not found"
glib 2.0 is definitely on my system, is there anything I'm doing wrong? Thanks again for all your help guys.


Last edited by otakuprinzess; 01-21-2005 at 11:37 AM.
 
Old 01-21-2005, 10:11 PM   #10
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
OK guys, I'm not the dumbest girl around...I figured out how to uninstall glib-1.2.8 and glib-2.6.0 (by, of course, running "make uninstall" from the folder where there sources were)

I then tried to run ./configure on the xmms alarm module and it said that glib was not installed, as I had hoped--signalling to me there was, yet again, no glib on my system. My problem with glib-1.2.8 is that my system kept saying it was glib-1.2.10. Sucks! So I downloaded and combiled glib-1.2.6 and compiled it, installed it. But yet again I get this error message:

_____________________________________________________________________
checking for xmms-config... no
checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.6...
*** 'glib-config --version' returned 1.2.6, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error:
*** GLIB >= 1.2.6 not installed - please install GLIB first ***
______________________________________________________________________

OK. So how do I tell it I have 1.2.6? Please explain the correct syntax to use LD_LIBRARY_PATH.

Also, where should I look for the config.cache file?

And since I understand better when I know what is actually happening here...could someone explain what LD_LIBRARY_PATH is/does and why this whole situation might be happening?

I can't thank everyone enough for the help they've given so far!

~Allexus

Last edited by otakuprinzess; 01-21-2005 at 10:16 PM.
 
Old 01-22-2005, 01:36 AM   #11
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
Update:

Ran LD_PATH_CONFIG, etc and PKG_CONFIG_PATH, etc.

It found GLIB!!! But then did not find GTK (as expected, as GTK is in /usr/lib)

I then re-ran ./configure and it said the same old thing..."found version 2.0.10" etc..gah!

I tried to cp
/usr/lib/gtk to /usr/lib/local/gtk but it kept 'omitting' it. I'm at a loss here. -=\
 
Old 01-22-2005, 04:56 AM   #12
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,

i would use the /etc/ld.so.conf approach. the application ldconfig should take care of this kind of things.
like the message output says, you could edit the file /etc/ld.so.conf and after that run ldconfig - both as root user.
this should point all env variables to the correct directory.

regards

slackie1000
 
Old 01-22-2005, 06:03 AM   #13
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
exactly what do you have installed now (as in how many versions)?

I think we are going to have to start over from the beginning ( since you have multiple versions installed )

also, we need to know which version of glib this program wants (1.2.x or 2.x)

your best bet would be to uninstall everything you have installed and use the mandrake packages through urpmi/rpmdrake to install both glib-2.x and glib-1.2.x (make sure you get both glibs and both glib-devels )

and as far as glib-1.2.x, you want 1.2.10 (not a necessity, but it was the bug fix version ).
 
Old 01-22-2005, 01:49 PM   #14
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
OK, time to answer some questions.

I have glib v1.2.6 only right now. I'm about to uninstall and find an RPM for 1.2.10. Apparently, the program wants 1.2.6, which is why I installed it. But I believe it should work fine with a higher level version.

I can run ldconfig alright, but as soon as I type in /etc/ld.so.conf bash returns by saying "permission denied." And yes, this is when I am in su mode. I don't understand that what-so-ever. It cannot deny me, for I am root. What might be causing this?

I also tried to edit permissions through the MandrakeLinux Control Center and when I tried to change root's ld.so.conf options the "OK" button was greyed out--I couldn't make any changes.

Whats up with that?

I have once uninstalled all versions and then installed 1.2.6 but so far nothing really.
I'm off to uninstall my current version and track down an RPM for micro version 10...

~Allexus
 
Old 01-22-2005, 02:43 PM   #15
otakuprinzess
Member
 
Registered: Jan 2005
Location: My room...my car...at friends places
Distribution: MandrakeLinux 10.1 Official
Posts: 36

Original Poster
Rep: Reputation: 15
Old problem fixed, new problem to conquer!

OK, I fussed around with source RPMs and the likes and found that installing them was anything but fun. They caused too many dependancy/confliction problems that I just went back to installing glib with make.

I finally, after some fussing with glib-1.2.10 and 1.2.9 have got 1.2.8 to install using --prefix=/usr

When I run the xmms alarm module's ./configure it finds glib! Alright! However, it now does not find GTK's config file.

I ran ldconfig, but of course, cannot edit /etc/ld.so.conf for permission is denied even to root.

I searched for GTK's config file, in all the usual places (/usr/bin/) but could not find it. Ran a search on "/usr" and found no GTK-CONFIG file. How lame.

Here's the latest output from this file:

____________________________________________________________________________
checking for xmms-config... no
checking for glib-config... /usr/bin/glib-config
checking for GLIB - version >= 1.2.6... yes
checking for gtk-config... no
checking for GTK - version >= 1.2.6... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error:
*** GTK+ >= 1.2.6 not installed - please install GTK+ first ***
____________________________________________________________________________

I see a pattern here...and I don't know whats up with it. I believe it used to find GTK no problem. So whats going on here?

Thanks for the input.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Build symlink missing Bobo7581 Suse/Novell 4 12-08-2004 01:52 PM
Mplayerplug-in does not build, what's missing? axelsharper Slackware 6 07-23-2004 05:05 AM
missing file vector.h, do I need to upgrade glib++ ???? STrew Linux - Software 0 03-26-2004 07:27 AM
Glib build error. atheist Linux - Software 9 01-29-2004 01:57 PM
missing gtk & glib - config elite Linux - Newbie 2 04-12-2002 07:22 PM


All times are GMT -5. The time now is 12:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration