LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Headphones don't turn speaker off (http://www.linuxquestions.org/questions/linux-software-2/headphones-dont-turn-speaker-off-799854/)

Bth8 04-03-2010 10:15 PM

Headphones don't turn speaker off
 
Whenever i plug headphones into my computer, it won't turn the speakers off. I'm running Debian lenny with alsa

(from lspci)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

astrogeek 04-03-2010 10:52 PM

Unless things are radically different than they have been in the past, I think that is a physical function of the connector itself, not a software feature.

I expect it is a bad headphone jack on your box.

EDIT:
I was thinking of laptops with integrated speakers when I answered, and that would be true.

If you are on a desktop with a front headphone jack and rear speaker connection you will probably have to go into your mixer and mute the speakers, to my knowledge headphone insertion is not auto detected, and it would not interrupt the speakers.
/EDIT

GrapefruiTgirl 04-03-2010 11:01 PM

Actually, while a bad jack could result in the same problem, at can also be completely a software issue these days.

Most likely (other than a bad jack) the sound chip is very new (i.e. spanking new laptop??), and either the kernel driver, or the alsa package, is not quite new enough to have full/correct specs of the chip, leading to failing jack-sensing. A related possibility (and relatively common too, if you read the alsa-devel or kernel mailing lists) is that the BIOS incorrectly reports the "pin widgets" of the chip, which misleads the driver.

Two (or more) ways to diagnose:

--Install the newest alsa package you can find.
--Upgrade to a very new kernel.
--both of the above.

..and see if that fixes it.

If nothing is broken at all in either software or hardware, I suppose it's possible too that the machine simply does not mute the speakers when headphones are connected, in which case you'd need to manually mute the speakers when using phones (but this sounds rather funny to me too.)

Sasha

astrogeek 04-03-2010 11:11 PM

Quote:

Originally Posted by GrapefruiTgirl (Post 3923417)
... can also be completely a software issue these days.

HAHA! I guess my own age and that of my hardware is showing!

I defer to GrapefruiTgirl!

dogmaticslumbers 01-24-2014 09:03 PM

I know this is an old thread but having recently experienced this problem, posting this for posterity.

Open "alsamixer" and enable "auto-mute" mode.


All times are GMT -5. The time now is 01:32 AM.