LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-03-2010, 09:15 PM   #1
Bth8
LQ Newbie
 
Registered: Feb 2009
Distribution: Debian lenny
Posts: 21

Rep: Reputation: 0
Headphones don't turn speaker off


Whenever i plug headphones into my computer, it won't turn the speakers off. I'm running Debian lenny with alsa

(from lspci)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
 
Old 04-03-2010, 09:52 PM   #2
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,953

Rep: Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727
Unless things are radically different than they have been in the past, I think that is a physical function of the connector itself, not a software feature.

I expect it is a bad headphone jack on your box.

EDIT:
I was thinking of laptops with integrated speakers when I answered, and that would be true.

If you are on a desktop with a front headphone jack and rear speaker connection you will probably have to go into your mixer and mute the speakers, to my knowledge headphone insertion is not auto detected, and it would not interrupt the speakers.
/EDIT

Last edited by astrogeek; 04-03-2010 at 10:02 PM.
 
Old 04-03-2010, 10:01 PM   #3
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Actually, while a bad jack could result in the same problem, at can also be completely a software issue these days.

Most likely (other than a bad jack) the sound chip is very new (i.e. spanking new laptop??), and either the kernel driver, or the alsa package, is not quite new enough to have full/correct specs of the chip, leading to failing jack-sensing. A related possibility (and relatively common too, if you read the alsa-devel or kernel mailing lists) is that the BIOS incorrectly reports the "pin widgets" of the chip, which misleads the driver.

Two (or more) ways to diagnose:

--Install the newest alsa package you can find.
--Upgrade to a very new kernel.
--both of the above.

..and see if that fixes it.

If nothing is broken at all in either software or hardware, I suppose it's possible too that the machine simply does not mute the speakers when headphones are connected, in which case you'd need to manually mute the speakers when using phones (but this sounds rather funny to me too.)

Sasha
 
Old 04-03-2010, 10:11 PM   #4
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,953

Rep: Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727
Quote:
Originally Posted by GrapefruiTgirl View Post
... can also be completely a software issue these days.
HAHA! I guess my own age and that of my hardware is showing!

I defer to GrapefruiTgirl!
 
Old 01-24-2014, 08:03 PM   #5
dogmaticslumbers
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
I know this is an old thread but having recently experienced this problem, posting this for posterity.

Open "alsamixer" and enable "auto-mute" mode.
 
  


Reply

Tags
alsa, debian, headphone, help, lenny, sound, speaker, toshiba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HP laptop w/ hda-intel - headphones/speaker problem. ocularb0b Linux - Hardware 6 11-15-2007 12:44 PM
FC3 / AC97 - headphones and internal speaker switched Freespacer Linux - Hardware 0 01-31-2005 06:58 AM
VMware install - how do I turn off that speaker? neilman Linux - General 0 10-29-2004 11:23 PM
Turn off PC Speaker output. groover Linux - Software 1 09-07-2004 04:03 PM
how to turn off modem speaker jeff1500 VectorLinux 5 08-15-2004 07:42 PM


All times are GMT -5. The time now is 05:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration