LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-04-2002, 09:34 PM   #1
jang
Member
 
Registered: Nov 2002
Location: Manila
Distribution: Fedora core 2 Gnome 2.6
Posts: 156

Rep: Reputation: 30
hdparm question


I tried to check my hdparm setting on DVD, and indeed it is set to 0, so I would like to turn it on to improve my dvd performance during playback, instead, I get this message:

I issued this command while logged in as root----- hdparm -d 1 /dev/hdc

/dev/hdc:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
 
Old 12-04-2002, 10:00 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Your drive might not be able to do that?

Are you sure that's your dvd drive, and also, I don't put spaces:
hdparm -d1 /dev/hdc

I don't know if that'll make a difference though.

Cool
 
Old 12-04-2002, 10:01 PM   #3
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
/usr/sbin/hdparm -q -c3 -d1 -X udma4 -m16 /dev/hdX

That's the hdparm command I have setup in my rc.local script. You might need to tweak it a bit for that drive (like the udma) so that it will work, but that gave me a huge difference in my HARDdrive performance.

Cool

Last edited by MasterC; 12-04-2002 at 10:18 PM.
 
Old 12-04-2002, 10:11 PM   #4
jang
Member
 
Registered: Nov 2002
Location: Manila
Distribution: Fedora core 2 Gnome 2.6
Posts: 156

Original Poster
Rep: Reputation: 30
ok. will try again. I am sure that /dev/hdc is my dvd rom drive. I tried it without spaces and still the same.
 
Old 12-05-2002, 12:22 AM   #5
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
Have you made sure DMA is "turned on" for this drive by your
BIOS? Does your kernel have support for DMA?
 
Old 12-05-2002, 01:23 AM   #6
jang
Member
 
Registered: Nov 2002
Location: Manila
Distribution: Fedora core 2 Gnome 2.6
Posts: 156

Original Poster
Rep: Reputation: 30
I am using redhat 8 with kernel 2.4.18-18.0 My dvd drive must be at least 8X or 16X
 
Old 12-05-2002, 07:26 AM   #7
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
Post the output from:
dmesg | grep -i dma
 
Old 12-05-2002, 09:26 AM   #8
hammerstein02
LQ Newbie
 
Registered: Dec 2002
Location: Leeds, UK
Distribution: Redhat 8.0
Posts: 15

Rep: Reputation: 0
It is something to do..

I had this problem last night, it is something to do with Redhat messing up dma support as far as I know..

I do have a line that you can do that fixes it, I can't remember it right now.. but I do have the line noted at home. If you still haven't gotten the problem fixed I will post it later today..
 
Old 12-06-2002, 07:47 PM   #9
jang
Member
 
Registered: Nov 2002
Location: Manila
Distribution: Fedora core 2 Gnome 2.6
Posts: 156

Original Poster
Rep: Reputation: 30
thanks
 
Old 12-07-2002, 01:45 PM   #10
Zander
Member
 
Registered: Jul 2002
Posts: 65

Rep: Reputation: 15
I'm having the same problem- I get that error: HDIO_SET_DMA failed: Operation not permitted. I want to set the dma for my hard drive, but it never lets me. I have a Maxtor 40 gig 7200 RPM which is fairly new and fast. I tried setting something in the bios called dma but it still won't work. Any other ideas?
 
Old 12-08-2002, 07:52 AM   #11
hammerstein02
LQ Newbie
 
Registered: Dec 2002
Location: Leeds, UK
Distribution: Redhat 8.0
Posts: 15

Rep: Reputation: 0
Apologies

Hey,
Sorry for the delay.. if you still need it..

Make sure you are logged in as root, open up a terminal and type

echo options ide-cd dma=1 >> /etc/modules.conf

DMA should now be enabled
 
Old 12-08-2002, 08:00 PM   #12
jang
Member
 
Registered: Nov 2002
Location: Manila
Distribution: Fedora core 2 Gnome 2.6
Posts: 156

Original Poster
Rep: Reputation: 30
Yes. I still need it. I will try your suggestion. Just to confirm, do I type the line 'echo options ide-cd dma=1' inside /etc/modules.conf ???


Thanks again.
 
Old 12-09-2002, 02:11 AM   #13
hammerstein02
LQ Newbie
 
Registered: Dec 2002
Location: Leeds, UK
Distribution: Redhat 8.0
Posts: 15

Rep: Reputation: 0
No.. you..

You, you type that entire line on the command prompt. I don't fully understand what it does, but I think it inserts that line into the modules.conf, thats why I say type that entire line rather than copy anything into modules.conf.

Just open up the terminal as root and type that line.
 
Old 12-09-2002, 02:23 AM   #14
jang
Member
 
Registered: Nov 2002
Location: Manila
Distribution: Fedora core 2 Gnome 2.6
Posts: 156

Original Poster
Rep: Reputation: 30
Still won't work

the same output is returned
 
Old 12-09-2002, 07:39 AM   #15
hammerstein02
LQ Newbie
 
Registered: Dec 2002
Location: Leeds, UK
Distribution: Redhat 8.0
Posts: 15

Rep: Reputation: 0
Are you...

Are you still trying to run the hdparm command? You don't have too. Once you have entered that line, restart the machine and it is done. My DVD playback worked fine after I did it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hdparm -y question..... chunlee Linux - Newbie 2 11-16-2004 06:47 PM
how to use hdparm navarre9 Linux - Software 3 03-10-2004 10:19 AM
hdparm question newpenguin Linux - General 14 03-21-2003 12:00 PM
hdparm question Cheese Linux - General 1 12-25-2001 09:03 AM
hdparm -g NOT= hdparm -i ---LILO hangs @ L stevewalsh Linux - General 4 07-23-2001 10:37 PM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration