LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-20-2010, 08:27 AM   #1
steviebob
Member
 
Registered: Jan 2010
Location: Arkansas
Distribution: Slackware-Current, LFS
Posts: 136

Rep: Reputation: 16
Having trouble installing ATI Proprietary Linux Driver


Hi, everybody. I'm having a teensy problem with installing something. About time, too, everything was going so smoothly.

Anyway, I'm trying to install the ATI Proprietary Linux Drivers so this new video card (well, I say "new" though it's actually a rather old card, a Radeon x300, but still better than my embedded gpu) that I have will be stable whenever I play some games, and I get one particular problem I'm having trouble getting around..

Code:
bash-4.1# ./ati-driver-installer-9-3-x86.x86_64.run 
Created directory fglrx-install.mXfQ2B
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
which: no XFree86 in (/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/java/bin:/usr/lib/kde4/libexec:/usr/lib/qt/bin:/usr/share/texmf/bin)

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.33.4-smp; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.mXfQ2B
bash-4.1#
See? I really don't know how to fix this. Completely clueless, in fact, except for maybe reinstalling XFree86 or changing the PATH env variable to something else, but I don't know what to change it to. Hm...

Anyway, any way somebody could help me?

~Steve
 
Old 11-20-2010, 11:16 AM   #2
steviebob
Member
 
Registered: Jan 2010
Location: Arkansas
Distribution: Slackware-Current, LFS
Posts: 136

Original Poster
Rep: Reputation: 16
Bump.

Anyone? I really would like to install this driver. It's a bit unstable (Okay, I admit it, extremely unstable) when playing 3D games. D:
 
Old 11-20-2010, 11:19 AM   #3
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
RTFM ...is the driver meant for your kernel?

check with ATI ... the driver is closed
 
Old 11-20-2010, 01:51 PM   #4
replica9000
Member
 
Registered: Jul 2006
Location: Quahog, Rhode Island
Distribution: Debian 'Sid', FreeBSD, Android
Posts: 698
Blog Entries: 2

Rep: Reputation: 125Reputation: 125
I'm not really familiar with Slackware, but does the installer not compile itself with the currently running kernel??
 
Old 11-20-2010, 09:18 PM   #5
steviebob
Member
 
Registered: Jan 2010
Location: Arkansas
Distribution: Slackware-Current, LFS
Posts: 136

Original Poster
Rep: Reputation: 16
I don't really know what kernel it's for, but now that you mention it, it's probably for an earlier kernel than the current one... Downgrading would probably throw everything out of whack. Hm. Well, thanks anyway.
 
  


Reply

Tags
ati, driver, drivers, install, xfree86


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg crash after installing "ATI Catalyst™ 9.6 Proprietary Linux x86 Display Driver" mennowo Linux - Software 9 01-18-2010 10:31 AM
Problem installing the ATI Proprietary Driver jacatone Linux - Newbie 1 09-29-2007 05:02 AM
Problems installing Ati Radeon 9200 proprietary driver in Slack 10 sn_piranha Linux - Hardware 5 02-12-2005 04:59 PM
ATI Proprietary Linux Driver 3.12.0 Xerop Linux - Hardware 1 09-11-2004 02:53 PM
New ATi Proprietary Linux Driver (3.11.1) Xerop Linux - Hardware 6 08-26-2004 12:33 PM


All times are GMT -5. The time now is 10:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration