LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-04-2003, 12:07 AM   #1
Electrode
Member
 
Registered: Oct 2002
Location: Michigan
Distribution: Slackware, LFS, Gentoo
Posts: 158

Rep: Reputation: 16
Question Having a hard time getting mplayer to capture sound from TV tuner


Hello all. I finally decided to buy a TV tuner (a Leadtek Winfast TV 2000 XP Deluxe, if it matters) to do some occasional video capturing, and right now almost everything is working. I've got video working just fine, but I'm having a little trouble with sound.

I compiled the bttv audio module, and it modprobes without error, but I'm having a hard time trying to get MPlayer to 'listen' to it.

Code:
electrode@tetrahedron:~$ mplayer -tv driver=v4l:norm=ntsc:channel=3:amode=1:adevice=/dev/dsp1:width=704:height=480:chanlist=us-cable tv://
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale


MPlayer dev-CVS-030403-21:53-2.95.3 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Athlon 4 PM Palomino/Athlon MP Multiprocessor/Athlon XP eXtreme Performance (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/electrode/.mplayer/config
Reading /home/electrode/.mplayer/codecs.conf: can't open '/home/electrode/.mplayer/codecs.conf': No such file or directory
Reading /usr/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/electrode/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /home/electrode/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config

Playing tv://
TV detected! ;-)
Selected driver: v4l
 name: Video 4 Linux input
 author: Alex Beregszaszi <alex@naxine.org>
 comment: under development
Selected device: BT878(Leadtek WinFast 2000/ W)
Capabilites: capture tuner overlay clipping frameram scales 
 Device type: 235
 Supported sizes: 48x32 => 768x480
 Inputs: 4
  0: Television: tuner audio tv camera  (tuner:1, norm:ntsc)
  1: Composite1: audio camera  (tuner:0, norm:ntsc)
  2: S-Video: audio camera  (tuner:0, norm:ntsc)
  3: Composite3: audio camera  (tuner:0, norm:ntsc)
Card reports an unknown audio mode !
Trying two channel audio. Use forcechan to override.
Audio mode setup warning!
Requested mode was stereo, but v4l still reports unknown.
You may need "forcechan" option to force stereo/mono audio recording.
Using input 'Television'
Selected channel: 3 (freq: 61.250)
ioctl get picture failed: Invalid argument
ioctl get picture failed: Invalid argument
ioctl get picture failed: Invalid argument
ioctl get picture failed: Invalid argument
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 704 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 704x480 => 704x480 Planar YV12 
Selected video codec: [rawyv12] vfm:raw (RAW YV12)
==========================================================================
Audio: no sound
Starting playback...
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
MJP: returning!  11%  0.0% 0 0 0%

Exiting... (Quit)
/dev/dsp1 is indicated by dmesg as the btaudio-powered sound device. I have also tried with dsp2, no dice.

Code:
btaudio: driver version 0.7 loaded [digital+analog]
btaudio: Bt878 (rev 17) at 02:04.1, irq: 16, latency: 32, mmio: 0xf2101000
btaudio: using card config "default"
btaudio: registered device dsp1 [digital]
btaudio: registered device dsp2 [analog]
btaudio: registered device mixer1
Now, when I connect a cable between the audio-out jack on the TV card and the audio-in jack on the sound card, I can hear it just fine. The reason I'm not just accepting that is that I haven't the slightest idea how to capture audio along with video that way, whereas if mplayer was taking in audio and video this way (using the btaudio device), it would be easy. Also there's the matter of quality degredation that can not be avoided when using cables, so even if I DID know how to capture it, it wouldn't sound as good.

Anyone care to offer advice? Thanks in advance!
 
Old 04-04-2003, 02:20 AM   #2
Electrode
Member
 
Registered: Oct 2002
Location: Michigan
Distribution: Slackware, LFS, Gentoo
Posts: 158

Original Poster
Rep: Reputation: 16
forgot email notification
 
Old 04-06-2003, 12:03 AM   #3
Electrode
Member
 
Registered: Oct 2002
Location: Michigan
Distribution: Slackware, LFS, Gentoo
Posts: 158

Original Poster
Rep: Reputation: 16
anyone?
 
Old 04-06-2003, 01:08 AM   #4
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
OK - the btaudio support for maplayer will only work when using mencoder (to record) - not for tv playback. For mplayer you need to use the audio plug on your tv card.

I use mencoder to record on a remote machine, and then play it back with mplayer on a workstation. As long as the playback doesn't reach the end of the file (causing mplayer to exit) it's fine. This way mencoder is encoding the audio from the btaudio device to the file, which I begin playing back about 15 seconds after the encoding starts.

Last edited by mcleodnine; 04-06-2003 at 01:11 AM.
 
Old 04-06-2003, 05:02 PM   #5
Electrode
Member
 
Registered: Oct 2002
Location: Michigan
Distribution: Slackware, LFS, Gentoo
Posts: 158

Original Poster
Rep: Reputation: 16
I see. Thanks!
 
Old 06-17-2003, 02:14 AM   #6
Muddy
Member
 
Registered: May 2002
Location: Ohio
Distribution: Mandrake 9.2 Custom Kernel & Mythtv!
Posts: 256

Rep: Reputation: 30
how did you get btaudio to work? mine modprobes and actually in kmix I have a bt878 audio mixer tab with moving sliders but no sound unless I use the line in to my sound card. Do you have to use the sox command line options to map btaudio output?
 
Old 06-17-2003, 02:57 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
mc9 clearly states that btaduio is currently only used in mencoder, not mplayer....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
BLFS Trial/Hard Time/Mplayer rvijay Linux From Scratch 5 01-09-2005 04:44 AM
Hard time installing Debian and Mplayer zilaei Linux - Software 3 12-10-2003 05:10 AM
Ready to buy - TV tuner/capture card gwroy20 Linux - Hardware 1 09-13-2003 05:47 PM
Cant find your tv tuner/capture card on the CARDLIST? jimdaworm Linux - Newbie 2 09-03-2003 01:41 PM
Having a hard time capturing from TV card with mplayer Electrode Linux - Software 2 04-30-2003 04:55 PM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration