Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 06-22-2005, 04:58 PM   #1
LQ Newbie
Registered: Jun 2005
Posts: 4

Rep: Reputation: 0
having 2 Qmail probs - sending and receiving

hi all
i hope someone can help me - this issue has been going on over a week now.
i had a new plesk server, Fedora core 2, but converted it off of their custom psa qmail stuff to regular qmail.

the first issue is that the server doesn't appear to ever be able to send emails, even bounces. the send log constantly reads:
deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)

most of the info relating to this on the net says "oh, there must be an MX record issue", or "thats normal to get sometimes, the recipient system might have been down", or "dont worry, it will stay in the queue and be resent"

ok, but my stuff just isn't being sent.

got to be some qmail-???? program thats not correct, or some config file.
i'm trying to send email to my yahoo account, and it is never sent per the above msg.

can anyone help me debug this with some specific info of what to look at?

the 2nd issue is that mail delivered to myself at one of my domains goes into a subdirectory that was created by Plesk... I created a "jaymer" web user long ago on my plesk control panel, and that created a web-users directory with a directory for me inside it... ie. /home/httpd/vhosts/

inside that is where my mail is delivered... to a Maildir file which i have to read with "mail -f Maildir". I get mail, but its not accessible externally to the server, like via the pop server. when Thunderbird/Outlook checks my mail server, it successfully logs in but sees no mail. So there's something messed up between where mail is getting delivered and where qmail-pop3d is looking. I have qmailadmin installed but i think the email is going to that original Plesk User's mailbox.

my /service/qmail-pop3d/run file is:
/usr/local/bin/tcpserver -H -R 0 pop3 /var/qmail/bin/qmail-popup /home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-pop3d Maildir

please help
Old 06-24-2005, 12:11 AM   #2
LQ Newbie
Registered: Jun 2005
Posts: 4

Original Poster
Rep: Reputation: 0
issue one is fixed. godaddy was blocking my ports even though i have a dedicated server.

but the 2nd issue is that my incoming mail isn't going to the vpopmail accounts, but to a local Maildir file.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How To Divert Email While Receiving And Sending? kiranprashant Programming 2 09-14-2005 06:21 AM
How To Divert Email While Receiving And Sending? kiranprashant Linux - Newbie 2 09-13-2005 02:51 PM
Sending, receiving through the USB interface The_Nerd Programming 5 02-13-2005 03:49 AM
Apparently working NICs receiving but not sending CestusGW Linux - Networking 8 11-02-2003 02:28 PM
Sending And Receiving Mail Using Pine Bheki Linux - Newbie 1 01-25-2002 08:09 AM

All times are GMT -5. The time now is 08:06 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration