LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   having 2 Qmail probs - sending and receiving (http://www.linuxquestions.org/questions/linux-software-2/having-2-qmail-probs-sending-and-receiving-336188/)

jaymer 06-22-2005 03:58 PM

having 2 Qmail probs - sending and receiving
 
hi all
i hope someone can help me - this issue has been going on over a week now.
i had a new plesk server, Fedora core 2, but converted it off of their custom psa qmail stuff to regular qmail.

the first issue is that the server doesn't appear to ever be able to send emails, even bounces. the send log constantly reads:
deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)

most of the info relating to this on the net says "oh, there must be an MX record issue", or "thats normal to get sometimes, the recipient system might have been down", or "dont worry, it will stay in the queue and be resent"

ok, but my stuff just isn't being sent.

got to be some qmail-???? program thats not correct, or some config file.
i'm trying to send email to my yahoo account, and it is never sent per the above msg.

can anyone help me debug this with some specific info of what to look at?


the 2nd issue is that mail delivered to myself at one of my domains goes into a subdirectory that was created by Plesk... I created a "jaymer" web user long ago on my plesk control panel, and that created a web-users directory with a directory for me inside it... ie. /home/httpd/vhosts/aaa.com/web_users/jaymer

inside that is where my mail is delivered... to a Maildir file which i have to read with "mail -f Maildir". I get mail, but its not accessible externally to the server, like via the pop server. when Thunderbird/Outlook checks my mail server, it successfully logs in but sees no mail. So there's something messed up between where mail is getting delivered and where qmail-pop3d is looking. I have qmailadmin installed but i think the email is going to that original Plesk User's mailbox.

my /service/qmail-pop3d/run file is:
/usr/local/bin/tcpserver -H -R 0 pop3 /var/qmail/bin/qmail-popup mail.aaa.com /home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-pop3d Maildir

please help
thx
jaymer...

jaymer 06-23-2005 11:11 PM

issue one is fixed. godaddy was blocking my ports even though i have a dedicated server.

but the 2nd issue is that my incoming mail isn't going to the vpopmail accounts, but to a local Maildir file.

jaymer...


All times are GMT -5. The time now is 01:48 PM.