LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 05-09-2011, 10:08 AM   #1
gvanto
Member
 
Registered: Oct 2009
Posts: 40

Rep: Reputation: 0
gvim install on Redhat linux?


I would like to get gvim working on Linux Redhat (remote server which I ssh into using putty).

I have vim installed on the server yet can't seem to find a package for gvim or how to get it installed.

Also any other tips on the installation(s) required to get gvim to open locally (I know I need xming to run locally and some sort of Xserver on the server to run, how to install on redhat? a good one?)

Thanks much!
gvanto
 
Old 05-09-2011, 10:22 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806
The package you need is vim-gtk.
To run a X application like gvim over SSH you don't need a XServer on the server, you need it on the client. On the server side you just have to enable X-forwarding in the configuration file.
 
Old 05-09-2011, 10:58 AM   #3
gvanto
Member
 
Registered: Oct 2009
Posts: 40

Original Poster
Rep: Reputation: 0
Thanks Tobi

I have searched but can't seem to find this package: ?

Quote:
[01:34:50][root@host:/home]# yum search vim-gtk
Searching Packages:
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
No Matches found
Perhaps I need to update the repositories locations or something - this should be a common package?
 
Old 05-09-2011, 11:14 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806
Sorry, I have misread the information on the web, it seems that vim-gtk is only available for old versions of RHEL. I only have found vim-x11 in the RHEL repositories.
 
Old 05-09-2011, 11:35 AM   #5
gvanto
Member
 
Registered: Oct 2009
Posts: 40

Original Poster
Rep: Reputation: 0
Now i am trying to install xclock yet find that even a struggle!

Quote:
[02:32:07][root@host:/home]# rpm -ivh xclock-1.0.4-2mdv2010.1.i586.rpm
warning: xclock-1.0.4-2mdv2010.1.i586.rpm: V3 DSA signature: NOKEY, key ID 70771ff3
error: Failed dependencies:
rtld(GNU_HASH) is needed by xclock-1.0.4-2mdv2010.1.i586
rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by xclock-1.0.4-2mdv2010.1.i586

this package should be quite common i think?



Is there another X-type application I could use to test X-server?

Got X11 installed but get 'E233: cannot open display' error ...

Last edited by gvanto; 05-09-2011 at 12:01 PM.
 
Old 05-09-2011, 12:34 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806
Use yum to install your packages, this will resolve dependencies automatically.
And as stated above, you don't need X11 on the server, you need to enable X-forwarding.
 
Old 05-09-2011, 12:45 PM   #7
gvanto
Member
 
Registered: Oct 2009
Posts: 40

Original Poster
Rep: Reputation: 0
Sorry meant to say installed Gvim (not X11, not sure where I got that from!).

Having alot of trouble installing 'xhost' command (it is not found by yum search)

Not sure what to do :-(
 
Old 05-09-2011, 01:01 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806Reputation: 3806
As stated two times already, you don't need X on the server, therefore xhost will also be useless. Configure your SSH-server to enable X-forwarding.
By the way, X11 is another name for the X-Server.
 
Old 05-09-2011, 01:27 PM   #9
gvanto
Member
 
Registered: Oct 2009
Posts: 40

Original Poster
Rep: Reputation: 0
hi Tobi

Thanks

Any idea how to configure putty so that X11 forwarding doesn't get refused?

gvanto
 
Old 05-09-2011, 01:57 PM   #10
gvanto
Member
 
Registered: Oct 2009
Posts: 40

Original Poster
Rep: Reputation: 0
Got it thanks Tobi:
http://www.linuxquestions.org/questi...92#post4351192
 
  


Reply

Tags
gvim, linux, redhat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
More GVIM fonts on linux deepakna Linux - Software 3 04-26-2007 09:09 AM
GVIM for UBUNTU Linux ramin Linux - Software 3 12-09-2004 12:19 PM
Gvim font issue in Linux kseetharaman Linux - General 0 04-05-2004 09:38 AM


All times are GMT -5. The time now is 02:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration