LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-27-2005, 08:30 PM   #1
dlj2
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Rep: Reputation: 0
gtkpod error: relocation error: gtkpod: undefined symbol: gtk_tool_button_new


running red hat prof workstation. get this error when trying to run gtkpod.
installed from an rpm. installed gtk2 previously.

any ideas appreciated...
 
Old 01-28-2005, 05:27 AM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
you need to clarify *how* you installed gtk2.
rpm?
source?

all this is is an error telling you it couldn't find the gtk libs. if you installed (gtk2) from source and did the standard ./configure, make, make install then you need to add:

/usr/local/lib

to /etc/ld.so.conf and run (as root):

ldconfig
 
Old 01-28-2005, 07:14 AM   #3
dlj2
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by __J
you need to clarify *how* you installed gtk2.
rpm?
source?

all this is is an error telling you it couldn't find the gtk libs. if you installed (gtk2) from source and did the standard ./configure, make, make install then you need to add:

/usr/local/lib

to /etc/ld.so.conf and run (as root):

ldconfig
<<<<

I am pretty sure I installed it from source....but I am not positive. I will check out your suggestion and get back to you. thanks so much for the assistance.

<<
 
Old 01-28-2005, 08:45 PM   #4
dlj2
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by dlj2
<<<<

I am pretty sure I installed it from source....but I am not positive. I will check out your suggestion and get back to you. thanks so much for the assistance.

<<


<<<

ok I checked and I installed from source. I tried to install again (gtk2) and I am getting this error

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

<<<

I have installed all these library requirements so i guess I need to set the env. variable, but I dont know how.
I think the packages are installed in the directory just below my home directory. at least thats where I am seeing a lot of files related to each in a directory named after each libary package....

so how do I set this env variable path to the right way?

thanks

<<

so I guess I need to know where they are and how to set the path correctly.
 
Old 01-28-2005, 09:43 PM   #5
dlj2
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by dlj2
<<<

ok I checked and I installed from source. I tried to install again (gtk2) and I am getting this error

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

<<<

I have installed all these library requirements so i guess I need to set the env. variable, but I dont know how.
I think the packages are installed in the directory just below my home directory. at least thats where I am seeing a lot of files related to each in a directory named after each libary package....

so how do I set this env variable path to the right way?

thanks

<<

so I guess I need to know where they are and how to set the path correctly.
<<

also when attempting to install pango...get this error...might be the same problem..
<<
checking for GLIB - version >= 2.5.7... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** Glib 2.5.7 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.
 
Old 01-29-2005, 05:23 AM   #6
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
you need to set PKG_CONFIG_PATH to point to the new library pkg-config files like this (this is assuming you installed them to /usr/local):

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

the above about ldconfig still applies here.

NOTE: if you have earlier versions of these libraries that came with your base system (not gtk-1.x or glib-1.x but libraries of the same major version like gtk-2.x) still installed these will have to be removed or you will get runtime (and compile time) linker errors. There are ways around this, but if you don't want to manually manipulate all of your paths you need to remove the old libs you are upgrading.
 
Old 01-29-2005, 07:51 AM   #7
dlj2
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by __J
you need to set PKG_CONFIG_PATH to point to the new library pkg-config files like this (this is assuming you installed them to /usr/local):

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

the above about ldconfig still applies here.

NOTE: if you have earlier versions of these libraries that came with your base system (not gtk-1.x or glib-1.x but libraries of the same major version like gtk-2.x) still installed these will have to be removed or you will get runtime (and compile time) linker errors. There are ways around this, but if you don't want to manually manipulate all of your paths you need to remove the old libs you are upgrading.
<<<<

ok...

I found the libraries...they are where you thought they would be. I set PATH. I edited ld.so.config. ldconfig doesnt run...not found.
I am running RH workstation.

so that is problem 1...I am still getting this error after ./compile on gtk package

checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0... Requested 'glib-2.0 >= 2.6.0' but version of GLib is 2.2.3

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
<<<
I can't find an instance of GLib anywhere on my system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gtkpod Error vatten Linux - Hardware 3 07-03-2005 02:37 PM
bluefish: relocation error: bluefish: undefined symbol: gtk_file_chooser_di pymehta Linux - Software 3 02-05-2005 11:00 PM
"relocation error" when launching gtkpod on rh9 tektone Linux - Software 1 12-18-2003 02:31 PM
rpm error only says"rpm: relocation error: rpm: undefined symbol: poptAliasOptions" dlrsims Linux - Newbie 2 11-14-2003 09:22 PM
dcgui-qt: relocation error: /usr/lib/libqt-mt.so.3: undefined symbol: glXGetConfig akqw Linux - Software 0 10-05-2003 10:30 AM


All times are GMT -5. The time now is 09:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration