LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-04-2002, 09:46 AM   #1
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Rep: Reputation: 30
Question GTK2.0 installation


I am trying to install gtk 2.0 in a mandrake 8.0 machine. When run the ./configure it fails with 'pkg-config is too old', howver I installed the latest version of pkg sucessfully (I think, no errors). I've tried changing my env var to point to pkg but still get the same error. Thanks
 
Old 12-04-2002, 01:11 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
try a "which pkg-config" ... with a bit of bad luck the new
version sits in /usr/local/bin and the old one sits before
it in the search path ...

Cheers,
Tink
 
Old 12-05-2002, 12:47 PM   #3
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
I found that the pkg-config was not in may path. I added it to my path and got past the pkg-config errors, however now it is stating that I do not have glib-2.0.pc I downloaded glib2.0 and it seemed to install correctly(no errors). I tried to run the gtk ./configure again and this time it complains about atk.pc... I am starting to feel like I am going about this wrong. Is there a better way to get GTK installed (RPM) I am on Mandrake 8.0. Any suggestions would be nice. Thanks
 
Old 12-05-2002, 01:10 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
you need the -devel package aswell.
 
Old 12-05-2002, 01:34 PM   #5
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
Thanks, I searched for the glib2.0-devel on google and found libglib1.2-devel-1.2.10-6mdk.i586 for mandrake. I ran rpm -ivh on the file and it came back with conflict errors about 'files from the install of libglib1.2-devel-1.2.10-mdk6 conflicts with file from package glib-devel-1.2.7-2' Is there a way I can start over, or what is the best way to fix the problem (other than quit or give up) The frustration level is beginning to get out of hand...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
some question about GTK2.0 mcm1738 Fedora 0 10-24-2005 06:04 AM
Mozilla with GTK2 raysr Linux - Software 2 06-21-2005 04:20 PM
gtk2 and Anjuta Chryzmo Linux - Software 6 11-19-2003 02:31 PM
Installing GTK2 Teddy_Horse Linux - Software 1 10-27-2003 05:36 PM
GTK2 problems nocturnal Linux - Software 1 05-11-2003 08:26 AM


All times are GMT -5. The time now is 09:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration