Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-09-2004, 04:32 AM   #1
LQ Newbie
Registered: Aug 2003
Location: London, Engerland
Distribution: Debian (kernel 2.6.0)
Posts: 14

Rep: Reputation: 0
Question Gtk-WARNING **: Locale not supported by C library

Each time I try and run an application on my Debian install after a dist upgrade it complains about the language being all wrong. Has anyone else bumped into this problem? It currently means that I cannot run certain programs (ones that rely on gtk).

(process:1935): Gtk-WARNING **: Locale not supported by C library.
         Using the fallback 'C' locale.  

(straw:1935): Gdk-WARNING **: locale not supported by C library Traceback (most recent call last):   File "/usr/bin/straw", line 17, in ?     s = straw.Main()   File "/usr/lib/straw/straw/", line 41, in __init__     self._setlocale()   File "/usr/lib/straw/straw/", line 105, in _setlocale     locale.setlocale(locale.LC_ALL, '')   File "/usr/lib/python2.3/", line 381, in setlocale     return _setlocale(category, locale) locale.Error: unsupported locale setting
Old 12-06-2006, 10:37 AM   #2
Registered: Feb 2004
Location: Chester, UK
Distribution: Linux From Scratch. 64 bit. Kernel 3.7.9. KDE 4.9.1.
Posts: 42

Rep: Reputation: 19
locale not supported by C library

Hi -

I've just rebuilt my glibc (don't try that unless you are a bit mad - its very easy to get it wrong and end up with an unusable system). I needed the new posix compliant threading stuff. But the point is that after I did that I ran into very similar problems to the one you reported. The Google located suggestions of altering environment variables didn't help at all. But at last I stumbled across localedef, which is a command line function for compiling the locale definition files. In my case what I needed was
localedef -c -f iso885915 -i en_GB en_GB.iso885915
run as super-user.

That has done the trick for me. I'm not quite sure whether its persistent, because I haven't rebooted the system. But one sure sign is that if you run
locale -a
and it moans, then there is something wrong.
Well locale works fine now, and the Gtk warnings have stopped.

I hope that helps someone else.

1 members found this post helpful.
Old 07-04-2008, 07:54 AM   #3
Registered: Apr 2007
Location: Sydney
Distribution: Debian. (Formerly Slackware, Gentoo, RHEL, and Suse)
Posts: 80

Rep: Reputation: 15
And still good value after all these years

Thanks champ, this sorted a locale annoyance I'd been having on Ubuntu...

localedef -c -f iso88591 -i en_US en_US.ISO-8859-1
Old 04-13-2011, 12:29 PM   #4
LQ Newbie
Registered: Feb 2005
Posts: 15

Rep: Reputation: 2
On some distributions this simpler command might also help,

dpkg-reconfigure locales
2 members found this post helpful.
Old 06-21-2011, 06:59 AM   #5
Registered: Nov 2008
Distribution: Ubuntu Maverick
Posts: 31

Rep: Reputation: 16
Originally Posted by louisgag View Post
On some distributions this simpler command might also help,

dpkg-reconfigure locales
Thank you for that command. I was facing the same issue after generating a lot of locale definition files with locale-gen (I did Ctrl-C a few times which probably resulted in corrupted locale definition files). That 'dpkg-reconfigure' command recompiled all the locales I had previously compiled which solved the problem.
1 members found this post helpful.
Old 08-08-2014, 01:47 PM   #6
LQ Newbie
Registered: Jan 2007
Distribution: Ubuntu Edgy
Posts: 7

Rep: Reputation: 0
Impossible locale combo?


I had this problem because my system tried to run with the locale "sv_US".

Once I installed Swedish (sv) language support completely I got things running.

Check by running "locale" in the command prompt. The locales set there should be something possible (unlike sv_US...)


Last edited by erikalm; 08-08-2014 at 01:48 PM.
Old 08-11-2014, 02:55 PM   #7
Registered: Apr 2004
Location: Mesa, AZ USA
Distribution: Slackware 13.37 kernel gcc 4.5.2
Posts: 217

Rep: Reputation: 13
I have this problem under Slackware 13.37. It's more of an annoyance as the lib falls back to the C locale method. Apparently the Locale stuff never got installed correctly. The environment varibles have no effect.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
perl: warning: Please check that your locale settings: Daredevil Linux - Software 1 05-12-2005 10:47 AM
Help : X11 Locale Not Supported pokkie Linux - Software 1 08-02-2004 10:43 AM
Gdk-WARNING **: locale not supported by C library letdoit Slackware 1 05-28-2004 10:47 PM
NEdit: Xlib: locale C not supported slakmagik Linux - Software 2 04-07-2003 02:34 AM

All times are GMT -5. The time now is 10:24 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration