LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   gstreamer-plugins-base conflicts with gstreamer-plugins-good (http://www.linuxquestions.org/questions/linux-software-2/gstreamer-plugins-base-conflicts-with-gstreamer-plugins-good-768868/)

Raveolution 11-13-2009 04:37 AM

gstreamer-plugins-base conflicts with gstreamer-plugins-good
 
This is blocking me from installing practically anything now.

Is there a way I can fix this?

I'm using Fedora Core 11...

slott_hansen 11-13-2009 10:48 AM

quick fix
 
Just use

yum update --skip-broken

and you are good to go.

Raveolution 11-13-2009 12:37 PM

Quote:

Originally Posted by slott_hansen (Post 3755794)
Just use

yum update --skip-broken

and you are good to go.

When I do that, it gives me this error in response:


Resolving Dependencies
--> Running transaction check
---> Package gstreamer-plugins-base.i586 0:0.10.25-2.fc11 set to be updated
--> Processing Conflict: gstreamer-plugins-base-0.10.25-2.fc11.i586 conflicts gstreamer-plugins-good < 0.10.16-3
--> Finished Dependency Resolution
gstreamer-plugins-base-0.10.25-2.fc11.i586 from updates has depsolving problems
--> gstreamer-plugins-base conflicts with gstreamer-plugins-good

knudfl 11-13-2009 01:25 PM

Untill you find out, what the conflict is about,

.. you can just remove gstreamer-plugins-good
.. to see what happens.

May be the package is from another repo, not in sync
with the fedora.repo for the time.

Which repo's have you got ?
' ls /etc/yum.repos.d/ '
.. will show ..
.....

Raveolution 11-13-2009 01:34 PM

Quote:

Originally Posted by knudfl (Post 3755982)
Untill you find out, what the conflict is about,

.. you can just remove gstreamer-plugins-good
.. to see what happens.

May be the package is from another repo, not in sync
with the fedora.repo for the time.

Which repo's have you got ?
' ls /etc/yum.repos.d/ '
.. will show ..
.....

I've been trying to remove gstreamer-plugins-good but lots of apps apparently depend on it. :(

edited: er, that's quite a few repo's... is there a way to post this list without flooding?

Raveolution 11-13-2009 05:44 PM

I hope this isn't a flood.
These are my repos:

adobe-linux-i386.repo
fedora-rawhide.repo
fedora.repo
fedora-updates.repo
fedora-updates-testing.repo
livna.repo
rpmfusion-free-rawhide.repo
rpmfusion-free.repo
rpmfusion-free-updates.repo
rpmfusion-free-updates-testing.repo
rpmfusion-nonfree-rawhide.repo
rpmfusion-nonfree-rawhide.repo.rpmsave
rpmfusion-nonfree.repo
rpmfusion-nonfree.repo.rpmsave
rpmfusion-nonfree-updates.repo
rpmfusion-nonfree-updates.repo.rpmsave
rpmfusion-nonfree-updates-testing.repo
rpmfusion-nonfree-updates-testing.repo.rpmsave

oddtodd 11-13-2009 09:29 PM

identical issue here
 
fedora 11, same repos, except for the *.rpmsave.
tried 'yum clean all', no dice.
tried 'package-cleanup --problems', no cigar.
tried 'package-cleanup --dupes', nada.

original error message:
--> Processing Conflict: gstreamer-plugins-base-0.10.25-2.fc11.x86_64 conflicts gstreamer-plugins-good < 0.10.16-3

bvn 11-14-2009 01:02 AM

--skip-broken no help
 
I have this problem on three different machines (all my fc11 machines)
---
[my account ~]# yum --skip-broken install gnome-applets
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-applets.i586 1:2.26.3-1.fc11 set to be updated
--> Processing Dependency: gstreamer-plugins-good >= 0.10.6 for package: 1:gnome-applets-2.26.3-1.fc11.i586
--> Running transaction check
---> Package gstreamer-plugins-good.i586 0:0.10.16-2.fc11 set to be updated
--> Processing Conflict: gstreamer-plugins-base-0.10.25-2.fc11.i586 conflicts gstreamer-plugins-good < 0.10.16-3
--> Finished Dependency Resolution
gstreamer-plugins-base-0.10.25-2.fc11.i586 from installed has depsolving problems
--> gstreamer-plugins-base conflicts with gstreamer-plugins-good
--> Running transaction check
---> Package gnome-applets.i586 1:2.26.3-1.fc11 set to be updated
---> Package gstreamer-plugins-good.i586 0:0.10.16-2.fc11 set to be updated
--> Processing Conflict: gstreamer-plugins-base-0.10.25-2.fc11.i586 conflicts gstreamer-plugins-good < 0.10.16-3
--> Finished Dependency Resolution
gstreamer-plugins-base-0.10.25-2.fc11.i586 from installed has depsolving problems
--> gstreamer-plugins-base conflicts with gstreamer-plugins-good
Skip-broken could not solve problems
Error: gstreamer-plugins-base conflicts with gstreamer-plugins-good
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
[my account ~]#

nixitup 11-14-2009 01:04 AM

Same problem here...just started while trying to do updates this week. (fedora 11)

gstreamer-plugins-base-0.10.25-2.fc11.x86_64 conflicts gstreamer-plugins-good < 0.10.16-3

Removed gstreamer-plugins-base and gstreamer-plugins-good, installed base no problem, can't re-install gstreamer-plugins-good.

Resolving Dependencies
--> Running transaction check
---> Package gstreamer-plugins-good.x86_64 0:0.10.16-2.fc11 set to be updated
--> Processing Conflict: gstreamer-plugins-base-0.10.25-2.fc11.x86_64 conflicts gstreamer-plugins-good < 0.10.16-3
--> Finished Dependency Resolution
gstreamer-plugins-base-0.10.25-2.fc11.x86_64 from installed has depsolving problems
--> gstreamer-plugins-base conflicts with gstreamer-plugins-good
Error: gstreamer-plugins-base conflicts with gstreamer-plugins-good

lanidarc 11-14-2009 01:10 AM

simple fix
 
I had the same issues - and I noticed I couldn't use Pidgin or Rhythmbox either. I'm on F11 new install shortly after first coplete system update. The fix in my case was to do a 'yum clean all' and then a 'yum makecache' and then a 'yum update' and now the issue seems resolved. Hope this helps someone. - Lani

nixitup 11-14-2009 01:24 AM

That worked lanidarc, thanks...should have tried that.

DichlofoS 11-14-2009 02:13 AM

Well, thanx for 'yum makecache' advice. I'm already tried 'yum clean all' as a simpliest possible solution, but it does not work. The other one is to erase gstreamer-plugins-good if you can sacrifice pidgin.

Raveolution 11-16-2009 04:42 PM

yum clean all and yum makecache combined seems to have solved this issue for me.

mheslep 11-17-2009 12:22 PM

Quote:

Originally Posted by DichlofoS (Post 3756636)
Well, thanx for 'yum makecache' advice. I'm already tried 'yum clean all' as a simpliest possible solution, but it does not work. The other one is to erase gstreamer-plugins-good if you can sacrifice pidgin.

That's correct it does NOT solve the conflict. And we have to give up much more than pidgin with gs'-plugins-good. gnome-applets also has a dependency.

mheslep 11-17-2009 12:24 PM

Quote:

Originally Posted by Raveolution (Post 3759272)
yum clean all and yum makecache combined seems to have solved this issue for me.

Then please confirm: you are able to install

gstreamer-plugins-base-0.10.25-2.fc11.i586

AND

gstreamer-plugins-good < 0.10.16-3

?

I don't think so.


All times are GMT -5. The time now is 05:10 PM.