LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   GRUB2 after a minor update of GRUB2 /boot prefix no longer needed?? (http://www.linuxquestions.org/questions/linux-software-2/grub2-after-a-minor-update-of-grub2-boot-prefix-no-longer-needed-839972/)

wikapuki 10-23-2010 08:26 AM

GRUB2 after a minor update of GRUB2 /boot prefix no longer needed??
 
GRUB2: 1.98+20100804-6
Debian: sid/squeeze (testing)
uname -a: Linux Flo64 2.6.32-5-amd64 #1 SMP Wed Oct 20 00:05:22 UTC 2010 x86_64 GNU/Linux
kernel: 2.6.32-26 (2.6.32+28 meta package)

4 physical SATA drives. fdisk -l | grep Disk:
Disk /dev/sdb: 500.1 GB, 500107862016 bytes
Disk identifier: 0xf4b1995e
Disk /dev/sda: 300.1 GB, 300069052416 bytes
Disk identifier: 0x13871386
Disk /dev/sdd: 1500.3 GB, 1500301910016 bytes
Disk identifier: 0xcb9e8977
Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
Disk identifier: 0x000d495f
Disk /dev/dm-0: 6996 MB, 6996099072 bytes
Disk identifier: 0x00000000
Disk /dev/dm-1: 12.2 GB, 12192841728 bytes
Disk identifier: 0x00000000
Disk /dev/dm-2: 980.8 GB, 980754104320 bytes
Disk identifier: 0x00000000

The GRUB menu appears with my 3 menu entry's but when it tries to boot to either of the Linux images (alternate is 2nd, so only one kernel), it reports file not found (for the kernel and initrd). So I dropped to the command line and did an 'ls' and a 'ls /' and the ls showed the kernel and ls / the drives.

On a gut shot feeling I brought back the GRUB menu and went to edit it, this is the grub one:
insmod part_msdos
insmod ext2
set root='(hd2,msdos1)'
search --no-floppy --fs-uuid --set c3d6a582-5500-43b1-aeba-bdd7fc669419
echo 'Loading Linux 2.6.32-5-amd64 ...'
linux /boot/vmlinuz-2.6.32-5-amd64 root=/dev/mapper/Flo64-root ro quiet
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-2.6.32-5-amd64

So I removed the /boot from linux and initrd

linux /vmlinuz-2.6.32-5-amd64 root=/dev/mapper/Flo64-root ro quiet
initrd /initrd.img-2.6.32-5-amd64

and did a picard (for those who have not read the manual, I booted), that worked fine.

So then I figured after the GRUB update it was my fault as GRUB ticks all my drives to install to apart from the actual linux drive and I had forgotten to select /dev/sdc (the installer always leaves this unchecked and it shows the partitions of sdc for selection).

So then I just ran grub-install /dev/sdc and rebooted but the same problem is still there, I have to edit the entry removing /boot on the two lines then picard it.

I can manual edit the grub file permantly but am loathe to do just in case it is a bug and will mess things up at next refit.

Is the my fault or GRUB2?

wikapuki 10-24-2010 02:39 PM

Turns out you may have to hand edit removing the /boot prefix after a grub-update in debian testing.

Bug sorted as of GRUB2 version 1.98+20100804-7


All times are GMT -5. The time now is 10:57 AM.