LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-17-2007, 12:28 PM   #1
ilm0nty
LQ Newbie
 
Registered: Oct 2005
Posts: 14

Rep: Reputation: 0
grub timeout


Hello

I have a strange problem:
I'm running a DSL (damn small Linux) distribution on an old P233mmx pc. Everything works great, except for the fact that at boot time, the timeout on the grub menu doesn't expire ...
It says something like "booting the highlighted entry in 3 seconds..." but it doesn't move on. I have to press enter and then everything works fine.

Any hint?
thanks
Nicola
 
Old 11-17-2007, 12:44 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Post contents of /boot/grub.grub.conf or it could be /boot/grub/menu.1st. Not sure what DSL uses.

Brian
 
Old 11-17-2007, 01:17 PM   #3
ilm0nty
LQ Newbie
 
Registered: Oct 2005
Posts: 14

Original Poster
Rep: Reputation: 0
here is menu.lst:


# This sets the default entry to boot.
# Remember that GRUB counts from 0, so 1 is the second entry.

default 0

# This sets the length of time in seconds that grub will wait for the user to select an OS
# before it boots the default on. I reccommend at least 15 seconds.

timeout 3

# Enter the entry for DSL here. Something like this.

title DSL-custom
kernel /boot/linux24 root=/dev/hda2 quiet vga=normal

title DSL
kernel /boot/linux24 root=/dev/hda2 quiet vga=normal noacpi noapm nodma noscsi frugal

title DSL fb800x600
kernel /boot/linux24 root=/dev/hda2 quiet vga=788 noacpi noapm nodma noscsi frugal

title DSL fb1024x768
kernel /boot/linux24 root=/dev/hda2 quiet vga=791 noacpi noapm nodma noscsi frugal

title DSL fb1280x1024
kernel /boot/linux24 root=/dev/hda2 quiet vga=794 noacpi noapm nodma noscsi frugal

#title DSL with toram, mydsl, restore, hostname, and passwords
#kernel /boot/linux24 root=/dev/hda2 quiet vga=normal noacpi noapm noscsi frugal dma toram mydsl=hda5 restore=hda5 host=DSL1 secure

#title DSL with XFree86
#kernel /boot/linux24 root=/dev/hda2 quiet vga=normal noacpi noapm noscsi frugal dma toram mydsl=hda5/xfree restore=hda6 host=DSL1 secure

#title DSL with mydsl, restore, persistentancy, hostname, and passwords
#kernel /boot/linux24 root=/dev/hda2 quiet vga=normal noacpi noapm noscsi frugal dma toram mydsl=hda3 restore=hda3 home=hda3 opt=hda3 host=DSL1 secure

#title DSL Runlevel 2
#kernel /boot/linux24 root=/dev/hda2 quiet vga=normal noacpi noapm noscsi nodma frugal 2 base norestore

#title DSL Check filesystem(s)
#kernel /boot/linux24 root=/dev/hda2 quiet vga=normal noacpi noapm noscsi nodma frugal 2 base norestore legacy checkfs

#title Windows
#root (hd0,0)
#chainloader +1
#makeactive
#boot
 
Old 11-17-2007, 04:34 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I don't really see anything wrong at the moment.

Brian
 
Old 11-18-2007, 10:10 AM   #5
ilm0nty
LQ Newbie
 
Registered: Oct 2005
Posts: 14

Original Poster
Rep: Reputation: 0
Me neither ...
Moreover, I can't post in the DSL forum (no idea why ... I can't even access my account profile page because I don't have the rights ...)
Any hint? Maybe it's a faulty grub version?
I tried looking in the forums, but found nothing ...
thanks
Nicola
 
Old 11-19-2007, 04:29 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I can't think of anything for grub other than upgrading it like you mention.

Brian
 
Old 09-10-2008, 03:13 AM   #7
bracc0
LQ Newbie
 
Registered: Jul 2007
Location: Italy
Distribution: *buntu, Debian, CentOs, Tinyme...
Posts: 3

Rep: Reputation: 0
Question

Quote:
Originally Posted by ilm0nty View Post

It says something like "booting the highlighted entry in 3 seconds..." but it doesn't move on. I have to press enter and then everything works fine.

Any hint?
thanks
Nicola
Same problem here!

Xubuntu 8.04
Grub 0.97
In addition I can say that I did a modification in my /boot/grub/menu.lst file: after a fresh xubuntu installation the "hiddenmenu" feature was enabled; I edited the file and disabled it.

Xubuntu is the only OS in my (pretty old) box.
Tried to increase/decrease timeout. No success.
Tried to re-enable the "hiddenmenu" feature. No success.
Tried to reinstall grub thru Synaptics. No success.

Any help will be greatly appreciated

Regards
Claudio
 
Old 10-09-2008, 10:06 AM   #8
bracc0
LQ Newbie
 
Registered: Jul 2007
Location: Italy
Distribution: *buntu, Debian, CentOs, Tinyme...
Posts: 3

Rep: Reputation: 0
bump!

Thanks
Claudio
 
Old 10-20-2008, 02:57 AM   #9
bracc0
LQ Newbie
 
Registered: Jul 2007
Location: Italy
Distribution: *buntu, Debian, CentOs, Tinyme...
Posts: 3

Rep: Reputation: 0
Talking grub timeout [SOLVED]

The problem has gone!
Grub installation and /boot/grub/menu.lst are fine. The problem was elsewhere.

I replaced the CMOS battery of my mother board because since a couple of month my PC didn't keep date and time. To be honest I was too lazy before to open the case to replace the CMOS battery. Yesterday afternoon wheater was rainy so I decided to replace it.
I turned on my PC and... surprise: the grub menu started to countdown again!

I never could guess that a grub problem was due to the CMOS battery.
I hope this could be of some help for someone else

Cheers
Claudio
 
Old 12-14-2008, 04:14 AM   #10
farrukhndm
Member
 
Registered: Mar 2008
Location: Pakistan
Distribution: Fedora,Centos,RHEL
Posts: 75

Rep: Reputation: 15
Soleved,Thanks.Centos Grub Countdown 5 seconds doesn't start

Problem have been solved.
thanks...
i have also same problem that my Trixbox(centos) countdown of 5 seconds dosn't start and i have to manually press enter to start boot process .

so just i have replaced the CMOS battery cell which solve my problem.
i think reason is that Linux kernel unable to Calculate the timing which breach it to start .

thanks.bracc0
 
  


Reply

Tags
battery, cmos, dsl, grub, timeout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB no timeout icmp_request Debian 4 07-01-2007 07:00 PM
GRUB does not timeout arnuld Linux - General 4 06-11-2007 12:13 AM
change GRUB timeout Gijet Red Hat 3 02-12-2004 10:53 AM
GRUB timeout problem badar52 Red Hat 3 12-08-2003 11:23 AM
GRUB:is instant timeout possible? unholy Linux - General 2 10-08-2003 06:36 AM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration