LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-16-2006, 03:24 PM   #1
JackTheGrubber
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Rep: Reputation: 0
Grub freezes before `Uncompressing kernel'


Grub freezes after displaying `boot' but before `Uncompressing kernel'.



I installed Ubuntu 6.0.2 on a Athlon (now Sempron) 2000+ with 512Mb of RAM and four hard drives (15Gb, 20Gb, 1.2Gb, 1.2Gb). It worked fine, and my partition setup was as follows:

Code:
/dev/hda1 /boot 100Mb  ext2
/dev/hda2 swap  1Gb    swap
/dev/hda3 /     10Gb   ext3
/dev/hda4 /srv  ~3.9Gb ext3

/dev/hdb1 /var  20Gb   ext3

/dev/hdc1 md0   1.2Gb  RAID1
/dev/hdd1 md0   1.2Gb  RAID1

/dev/md0  /home 1.2Gb  ext3
However, my dad soon wanted his computer back, so I had to move my hard drives up to my system, which has the following specs: Pentium 133, 128Mb RAM, 5 PCI/ISA ports (5 of each),
and a fairly old BIOS, which doesn't support drives over 8.5Gb. However, since my /boot partition is in the first 100Mb of the first drive, it shouldn't matter too much.

My heating system is fine; I put brand new quality thermal paste on the CPU and added a 120mm fan. I also ran memtest86 for 10 hours, and my memory is fine.

When booting up I get the following output:
Code:
Booting 'Ubuntu, kernel 2.6.15-23-server'

root (hd0, 0)
  Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.15-23-server root=/dev/hda3 ro quiet splash
  [Linux-bzImage, setup=0x1c00, size=0x165b75f]
initrd /initrd.img-2.6.15-23-server
  [Linux-initrd @ 0x79500000, 0x69f637 byes]
savedefault
boot
At that point it freezes, with no hard drive activity whatsoever. I've left it for about 30 minutes, and no change.

I tried removing `quiet' and `splash' from the kernel line, as well as adding `acpi=off pci=noacpi, noapic, nopcm, pcm=off' and various combinations of those options. No change.


I've spent several hours searching for a solution, but I can't seem to figure it out. I also had this problem with Fedora Core 5. It worked fine on my laptop, a Pentium II 366Mhz with 256Mb of RAM. However, that system had one 4.5Gb HD and that was it.
 
Old 07-17-2006, 10:41 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Try adding the option to the kernel boot line:

edd=skipmbr

If that doesn't work, try:

edd=off

Some old BIOS may not like the new way of finding the master boot record.
 
Old 07-18-2006, 12:03 AM   #3
JackTheGrubber
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Nope, that didn't work.

At another forum (where I am one of the two knowledgeable tech guys, leaving exactly one person to help me), I was given the following advice:
Stop mixing RAID and non-RAID.
Use a HD size that the BIOS supports
Check all of your hardware.


Well, after replacing the motherboard, CPU, and PSU, and running memtest86 for 10 hours, I loaded a copy of FC5 onto a 4.5Gb disk and tried it. No dice. I also removed all my non-parity RAM, and that didn't help at all.

This seems very strange to me, as I've heard of people getting Linux to work on a P133. I've no idea what I'm doing wrong.


Windows 95/98 and DOS both run fine on this system, and XP Home did boot (although it barely ran). Also, I can boot into one diskette Linux, BootE. However, various other diskette Linuxes give me stuff like "Failed to load initial console." Grr.


Since the OP, one of my /home drives failed (thank God for RAID), and a Celeron motherboard I was testing flaked out, along with a spare PSU. Shouldn't have split molex connectors with electrical tape. None of that's relevant, but it's a testament to the bad luck I've been having.
 
Old 07-18-2006, 01:12 AM   #4
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,592

Rep: Reputation: 162Reputation: 162
Try a live CD like Knoppix, and see if that will boot. Then, check how the machine is seeing the partitions with fdisk -l
 
Old 09-09-2007, 07:49 AM   #5
budlightnmyhand
LQ Newbie
 
Registered: Nov 2005
Location: ohio
Distribution: mandrake 10.1
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by macemoneta View Post
Try adding the option to the kernel boot line:

edd=skipmbr

If that doesn't work, try:

edd=off

Some old BIOS may not like the new way of finding the master boot record.
I am a newbie.. and my dual boot with fedora core 7 and windows xp was giving me this same problem. It would boot into windows xp fine but as soon as i chose to boot fedora 7 it would freeze on me. How can i add the "edd=skipmbr" line so i don't have to type that in everytime i want to load fedora?

thanks,
Mike
 
Old 09-09-2007, 08:09 AM   #6
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
You can add the value to the kernel lines in /etc/grub.conf. Once you add it, any new kernels added by maintenance will automatically get the option, so you only have to do it once.
 
Old 09-09-2007, 08:23 AM   #7
budlightnmyhand
LQ Newbie
 
Registered: Nov 2005
Location: ohio
Distribution: mandrake 10.1
Posts: 15

Rep: Reputation: 0
ok so i'm a real noob and wanted windows xp to be the primary boot so i reinstalled fedora because i accidentally did the text mode install and wanted the graphical and made windows the main boot and now when it comes to grub loader i select fedora add the edd=skipmbr and its still freezing. neither the edd=skipmbr or edd=off worked this time :/ u guys have any ideas?? its a dell xps 1710 laptop with a sata hard drive oh i also just tried removing quiet from the editor thing and it gets to net: registered protocol family 2 and just sits there and freezes.

Last edited by budlightnmyhand; 09-09-2007 at 08:39 AM.
 
Old 09-09-2007, 02:33 PM   #8
Gerard0
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
Thumbs up Freeze uncompressing Kernel

At least in Fedora this is a known bug for certain dual core configs (mostly related to Dell machines)
Passing maxcpus=1 in kernel line worked around this for me, then upgrade to Kernel 2.6.22 allowed me to use dual core again fixing the problem.

See bug 241249 un redhat bugzilla (sorry not to post the full url, but since this is my first post, LinuxQuestions wants me to introduce myself and I have no time to do so now)

Hope this helps.
 
Old 09-09-2007, 07:09 PM   #9
budlightnmyhand
LQ Newbie
 
Registered: Nov 2005
Location: ohio
Distribution: mandrake 10.1
Posts: 15

Rep: Reputation: 0
I don't know what made me do this but after reading that last post i went into the bios and turned off a few features of the dual core processor and its working fine. Windows xp boots and so does fedora Thanks for all your help everyone!
 
  


Reply

Tags
boot, dualcore, fedora, freeze, grub, kernel, lockup, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stops at: Uncompressing Linux... Ok, booting the kernel destin Slackware 6 02-29-2008 04:45 AM
smp kernel: uncompressing Linux ..ok booting the kernel krissb Linux - General 1 11-16-2005 06:31 PM
Stops at Uncompressing Linux... Ok, booting the kernel reward72 Linux - Newbie 4 02-25-2004 11:12 PM
Uncompressing Linux... Ok, booting the kernel GlobShim Linux - General 2 01-29-2004 05:24 PM
mdk9.2 installation hangs while uncompressing kernel jaybee Mandriva 1 11-17-2003 11:02 PM


All times are GMT -5. The time now is 08:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration