LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-15-2003, 04:40 PM   #1
osiris
LQ Newbie
 
Registered: Jun 2003
Location: Cincinasty
Distribution: Suse Pro 8.2
Posts: 6

Rep: Reputation: 0
GRUB Error 23 on boot


I have recently completed a fresh install of SuSE 8.2 Pro. On boot I receive this error message:


Kernel (hd0,1)/boot/vmlinuz root=/dev/hda2 vga=nil splash=silent splash=silent
[Linux-bzImage, setup=0x1400, size=0x120452]

Error 23: Error while parsing number

Press any key to continue…


I checked the device map and that seems ok. The system will boot off of the CD just not off the hard disk. Any ideas?
 
Old 06-15-2003, 05:52 PM   #2
hamster
Member
 
Registered: Apr 2003
Location: Waterford, Ireland
Distribution: Mandrivia 2006.1, Ubuntu 7.10
Posts: 188

Rep: Reputation: 30
I did a google and got: http://www.uruk.org/orig-grub/errors.html. Although here the error is number 15. Have a look.
 
Old 06-15-2003, 07:48 PM   #3
osiris
LQ Newbie
 
Registered: Jun 2003
Location: Cincinasty
Distribution: Suse Pro 8.2
Posts: 6

Original Poster
Rep: Reputation: 0
yeah, I have seen that type of thing before...

the latest GRUB manual is at:

http://www.linuxselfhelp.com/gnu/gru...oc.html#TOC101

I am wondering if perhaps my menu.lst file is misconfig'd? Everything I use is kept on one partition (/dev/hda2). My only other partition is /dev/hda1 which is the linux swap file. Any comments based on that?
 
Old 06-18-2003, 07:39 AM   #4
osiris
LQ Newbie
 
Registered: Jun 2003
Location: Cincinasty
Distribution: Suse Pro 8.2
Posts: 6

Original Poster
Rep: Reputation: 0
cash money

So...

I noticed when I attempted to convert to LILO that I was getting a display definition error. Someone had mentioned to me early on that vga=nil from my title kernel wasn't quite right. Sure enough...it wasn't.

Basically, because I use a "partially" supported video card, YaST did not configure my menu.lst correctly at installation. Because it was "Unclassified Graphics Card" the setup simply inserted nil into the display definition.

Upon doing some googling I discovered the following chart...

Color depth | 640x480 800x600 1024x768 1280x1024
256 (8bit) | 769 771 773 775
32000 (15bit) | 784 787 790 793
65000 (16bit) | 785 788 791 794
16.7 Mill.(24bit) | 786 789 792 795

I simply amended my menu.lst to read vga=791 (my desired resolution) in the title kernel. Then I reconfigured Sax2 to read the same settings...rebooted...and it was cash money from there.
 
Old 06-18-2003, 01:36 PM   #5
hamster
Member
 
Registered: Apr 2003
Location: Waterford, Ireland
Distribution: Mandrivia 2006.1, Ubuntu 7.10
Posts: 188

Rep: Reputation: 30
good stuff osiris!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo-Im dumb and deleted /boot/boot Grub Says: Error 26 : Too many symbolic links smehi Linux - Software 5 06-24-2006 07:25 AM
Error 17 on GRUB Boot Area51mafia Linux - General 2 07-11-2005 05:51 PM
Grub (error 17) won't boot after new motherboard/vid card.. boot disk anyone? r3dhatter Linux - Newbie 5 02-16-2005 07:52 PM
Grub Error: 26, Deleted /boot/boot link. smehi Linux - Newbie 2 04-06-2004 12:53 PM
error on boot of new kernel. grub error. Pcghost Linux - General 4 05-10-2003 10:37 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration