LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   GRUB - Error 21 Dual Boot Kubuntu / XP (http://www.linuxquestions.org/questions/linux-software-2/grub-error-21-dual-boot-kubuntu-xp-396723/)

mjanveaux 12-26-2005 08:32 PM

GRUB - Error 21 Dual Boot Kubuntu / XP
 
Hi,

I have configured a dual boot setup using GRUB. Windows XP is installed on my internal hard drive partition 1 (hd0,1) and GRUB is installed at (hd0,0). Kubuntu I installed at (hd1,0) on an external USB drive and have successfully booted it (posting from it now) after modifying the initrd image to load my usb devices before attempting to mount the external drive.

Anyways, the problem I'm experiencing now is that GRUB will not load correctly and will give me the message 'Error Number 21' if my USB drive is turned off or not plugged in. I am suspecting that this is because it cannot find hd1 and just gives up. Is there anyway to configure GRUB so that the default OS to boot is Windows XP (hd0) and have it not 'worry' about my external USB drive? I have no problems what so ever if the external drive is turned on and plugged in.

Any advice on overcoming this would be greatly appreciated!

Kind regards,

Mark

BittaBrotha 12-26-2005 09:35 PM

Make sure Windows XP is listed first in /boot/grub/menu.lst file and default=0 is at the top.

The "default" command tells GRUB which system to highlight and boot if a user doesn't make a manual selection.

mjanveaux 12-26-2005 11:57 PM

default doesn't solve it
 
hi, thanks for the reply.

I already tried to make the entry the default entry by putting in '4', - GRUB correctly highlights the correct entry (Windows XP), but if the drive is unplugged, it doesn't even make it to the menu before printing the Error Number 21 message. I believe it says something like:

Loading Stage 1.5 (?)
Error Number 21

If the drive is plugged in and turned on then XP is highlighted and will boot properly...

Is there anything else I can try?

sab_new 06-21-2009 02:12 AM

Did you solve this yet?
 
I have a similar problem. Error 21 is solved with USB HD plugged in, I can then disconnect should I choose when XP begins its boot process. I want to boot from the internal(XP)HD should I run in to problems, which I do with some frequency. To rephrase-possible to have GRUB entry on both? Silly question possibly but I have had to reinstall more than once. I apologize if I ask this badly.

Lenovo 3000 G530 4446-25U Laptop
Windows XP Pro pre-installed internal HD 250GB
Debian Lenny Sid 2.6.29-2-686(for the wireless) external USB HD 160GB
GRUB with Linux as default

ronlau9 06-21-2009 04:23 AM

Quote:

Originally Posted by sab_new (Post 3581071)
I have a similar problem. Error 21 is solved with USB HD plugged in, I can then disconnect should I choose when XP begins its boot process. I want to boot from the internal(XP)HD should I run in to problems, which I do with some frequency. To rephrase-possible to have GRUB entry on both? Silly question possibly but I have had to reinstall more than once. I apologize if I ask this badly.

Lenovo 3000 G530 4446-25U Laptop
Windows XP Pro pre-installed internal HD 250GB
Debian Lenny Sid 2.6.29-2-686(for the wireless) external USB HD 160GB
GRUB with Linux as default

If you're external HD is listed in Fstab than on start up linux is looking for that drive and will not boot if it is not there or boot in failsafe mode .
You have the same issue with windows , if I remember it well it has somewhere a option called safe remove of a HD a even a thumdrive

sab_new 06-24-2009 08:08 AM

Thank you for your reply ronlau9
 
It is as I suspected. I have tried previously, twice, dual-boot installs, once on the same HD(different machine)and once on seperate HDs. I ended up having to rebuild the boot.ini once and had to reinstall windows the second time.

This install on the laptop worked. I worry that if the external drive fails I will lose access to the internal HD(the windows install)and obviously the Linux install.

You are correct about the safe options. I have discovered that I don't need to wait for windows to completely load for the disconnect of the USB drive, I just need to wait for the initial windows loader to start. I do so in hopes of conserving battery power as the power to USB is coming from the laptop.

I am not brave enough yet to "mess with" GRUB. This last successful install, I disabled the internal HD from boot in the BIOS before I installed Debian to the USB. I also discovered that in order to boot I have to have the internal HD listed in the BIOS as first before the external to boot at all.

Thank you again for your response. I'll do more research and leave well enough alone.


All times are GMT -5. The time now is 07:48 AM.