Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-22-2005, 05:49 PM   #1
LQ Newbie
Registered: Oct 2005
Location: toronto
Distribution: slackware
Posts: 10

Rep: Reputation: 0
GRUB error 17 boot problem

i originally had slackware installed on my computer. i then installed fedora core 3. deciding to go back to slackware, i reinstalled the system (assuming that the LILO boot loader would overwrite GRUB) and it would not boot - i got the GRUB error 17. i am currently booting up off of the floppy disk.

i have two questions:

1) how do i reinstall LILO so that slackware will boot from the hard drive?


2) is it possible and how would i install slackware so that it wil boot with GRUB loader?

Old 10-23-2005, 09:31 AM   #2
Senior Member
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Answers are

(1) While in Slackware, log in as root in terminal mode just type

lilo -b /dev/hda

(Change hda to sda if you boot from a Sata)

(2) Download Grub 0.97 and install it
Old 10-25-2005, 12:06 AM   #3
LQ Newbie
Registered: Oct 2005
Location: toronto
Distribution: slackware
Posts: 10

Original Poster
Rep: Reputation: 0
perfect!!! thanks so much.

i chose the former option.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo-Im dumb and deleted /boot/boot Grub Says: Error 26 : Too many symbolic links smehi Linux - Software 5 06-24-2006 07:25 AM
Boot problem: "GRUB Loading stage2read Error" after installing PCI Ethernet card nsyng Fedora - Installation 1 06-06-2005 07:53 AM
Grub (error 17) won't boot after new motherboard/vid card.. boot disk anyone? r3dhatter Linux - Newbie 5 02-16-2005 07:52 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
Grub Error: 26, Deleted /boot/boot link. smehi Linux - Newbie 2 04-06-2004 12:53 PM

All times are GMT -5. The time now is 11:39 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration