LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   GRUB boot of XP hangs at flashing cursor (http://www.linuxquestions.org/questions/linux-software-2/grub-boot-of-xp-hangs-at-flashing-cursor-808977/)

Richter12x2 05-19-2010 09:34 PM

GRUB boot of XP hangs at flashing cursor
 
I installed Fedora 11 today, because I'm really looking to replace Windows. I've been running a Fedora 11 webserver at home for over a year, but this is Linux, which means that I spent about 8 hours on it over a year ago, and then only logged in once or twice since. :P

So after the install, I booted to a GRUB prompt and no menu. After searching around, I changed my BIOS settings to Large for the hard drive, and got the GRUB menu to load, and now I'm posting this from within Fedora 11, and after some good healthy exercises with the soundcard, xvid drivers, and a few other things, it's great.

When I load XP from Grub, I just get a flashing underscore and no progress.

XP is installed in the first partition, and has been there for a few months.

Here's my grub.conf:

Code:

#boot=/dev/sda
default=1
timeout=5
splashimage=(hd0,5)/grub/splash.xpm.gz
hiddenmenu
title Fedora
        root (hd0,5)
        kernel /vmlinuz-2.6.29.4-167.fc11.x86_64 ro root=/dev/mapper/vg_joshlin-lv_root rhgb quiet
        initrd /initrd-2.6.29.4-167.fc11.x86_64.img
title Windows XP
        rootnoverify (hd0,0)
        makeactive
        chainloader +1

I still need it for things like Quicken and Photoshop. Thanks in advance!

Larry Webb 05-19-2010 09:50 PM

Your menu.lst looks right, open terminal and as root 'fdisk -l' without the quotes. Copy and paste the results. As a rule windows needs to be in the first partition or be made to think it is.

alan99 05-19-2010 10:11 PM

Could you provide some info on your machine and its partitions? It might be possible that XP is not the first partition. I once had problems with a computer whose disk got corrupted. I had to find out that the first partition was really a hidden rescue partition (unfortunately it was corrupted and wouldn't boot), before I could figure out how to fix it.

Richter12x2 05-20-2010 12:03 AM

Quote:

Originally Posted by Larry Webb (Post 3974861)
Your menu.lst looks right, open terminal and as root 'fdisk -l' without the quotes. Copy and paste the results. As a rule windows needs to be in the first partition or be made to think it is.

Sure thing - here's the output. Made me wonder for a moment as it didn't appear to do anything. After logging in as 'su' it came back. Just in case anyone else has the same issue.

Here's the output

Code:

fdisk -l

Disk /dev/sda: 750.1 GB, 750155292160 bytes
16 heads, 63 sectors/track, 1453518 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
Disk identifier: 0x8b1dfe42

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1      101587    51199816+  7  HPFS/NTFS
/dev/sda2          101588    1453517  681372720    f  W95 Ext'd (LBA)
/dev/sda5          101588    1320635  614400000    7  HPFS/NTFS
/dev/sda6  *    1320635    1321042      204799+  83  Linux
/dev/sda7        1321042    1453517    66767887+  8e  Linux LVM

Disk /dev/dm-0: 62.6 GB, 62679678976 bytes
255 heads, 63 sectors/track, 7620 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 5687 MB, 5687476224 bytes
255 heads, 63 sectors/track, 691 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table

I'm guessing it has something to do with not having a valid partition table - how do I get one of those? :D

Richter12x2 05-20-2010 12:08 AM

Quote:

Originally Posted by alan99 (Post 3974870)
Could you provide some info on your machine and its partitions? It might be possible that XP is not the first partition. I once had problems with a computer whose disk got corrupted. I had to find out that the first partition was really a hidden rescue partition (unfortunately it was corrupted and wouldn't boot), before I could figure out how to fix it.

It's a homebuilt computer with 1 physical 750GB SATA drive, so none of the dodgy HP/Dell/IBM rescue partitions. Windows had two partitions of its own, a 50 GiB System Partition and a 650 GiB Data partition. I squished the Data partition to allow 60ish GiB for Fedora, and it took another 200 MiB for Grub, I think is how it worked.

Also, as part of trying to make it work, I tried to add the bootable flag in DiskPart after I finally had Fedora working for sda1 - it wasn't checked before. When I checked it though, it never actually finished, and I ended up cancelling about an hour later to restart.

kurwongbah 05-20-2010 01:31 AM

Just to get my head around thge sequence of events ;)
You installed Windows long ago.
Then installed Fedora just now and it didn't boot.
After that you went into the BIOS and changed the LBA setting.
Now you are able to boot Linux but Windows don't work no more!?

It might take a reinstall of Windows after that BIOS change...

vigi 05-20-2010 03:20 AM

I am not sure if this will help but my version of grub has a different entry to load vista and xp.

title Windows Vista (on /dev/sda1)
rootnoverify (hd0,0)
makeactive
chainloader +1
#
#
title Windows XP, 98 (on /dev/sda1)
map (hd0,0) (hd0,0)
map (hd0,0) (hd0,0)
rootnoverify (hd0,0)
makeactive
chainloader +1

alan99 05-20-2010 03:40 AM

I'm not sure why you only have one primary and put the extended partition on partition #2, but I guess it would still be allowed. I don't know why you have two partitions marked as boot. Mine is dual boot (grub2 -- vista and Debian linux) I only have the first partition (Vista) marked as bootable.

alan99 05-20-2010 04:12 AM

Looks like your using a Logical Volume (not sure why you would do that if you only have one drive -does Fedora do that by default?) I don't know if that is why you are getting the error message about the partitions (I'm not familiar with Logical Volumes)

syg00 05-20-2010 04:24 AM

Quote:

Originally Posted by alan99 (Post 3975092)
I'm not sure why you only have one primary and put the extended partition on partition #2, but I guess it would still be allowed.

No problem.
Quote:

I don't know why you have two partitions marked as boot. Mine is dual boot (grub2 -- vista and Debian linux) I only have the first partition (Vista) marked as bootable.
This could be a problem - for Windoze. Remove the boot flag on /dev/sda6.

Richter12x2 05-20-2010 10:20 AM

Quote:

Originally Posted by syg00 (Post 3975146)
No problem.This could be a problem - for Windoze. Remove the boot flag on /dev/sda6.

Removed the boot flag in Parted and verified it was gone in fdisk - no change. Still boots to flashing cursor when I try to load the Windows partition.

Richter12x2 05-20-2010 10:31 AM

Quote:

Originally Posted by vigi (Post 3975074)
I am not sure if this will help but my version of grub has a different entry to load vista and xp.

title Windows Vista (on /dev/sda1)
rootnoverify (hd0,0)
makeactive
chainloader +1
#
#
title Windows XP, 98 (on /dev/sda1)
map (hd0,0) (hd0,0)
map (hd0,0) (hd0,0)
rootnoverify (hd0,0)
makeactive
chainloader +1

I added the map statements to grub.conf and retried, and still no change. Still the flashing underscore in the top left of the screen.

Richter12x2 05-20-2010 10:49 AM

Alright, I've had some mixed success:

If I switch the harddrive access mode back to normal, I get the Grub prompt instead of the menu. If I load the commands manually, then Windows loads just fine.

Now knowing that - is there a way I can make them both operate from the GRUB menu? I thought I remembered seeing a command to tell grub to use LBA or notLBA addressing?

Richter12x2 05-20-2010 05:10 PM

Looks like it was actually in the partition tool instead of GRUB. Flagging the Windows Partition as LBA = off didn't do anything for me.

10110111 05-20-2010 05:16 PM

Try adding
Code:

boot
line after this one:
Code:

initrd /initrd-2.6.29.4-167.fc11.x86_64.img
. I've had some problems when this command wasn't specified.


All times are GMT -5. The time now is 11:17 PM.