LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-23-2004, 10:12 AM   #1
wizardzx2
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
Grub boot loader problem


recently installed the fedora core 2 dist and everything was going fine until i decided to choose the win xp option in the grub program. I have a 100 mb partition mounted /boot and a 7gb one at / . the gruib program is installed at the master boot record but when i try to boot windows using the standard root (hd0,0)
chainloader +1
makeactive

that text come up but doesnt initiate the boot up process. i am quite confident that the other ntfs partition have not been affected but am now going to try to bot windows from the xp cd i have. Any ideas???

thanks

Martin
 
Old 06-23-2004, 10:48 AM   #2
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
It may be a drive geometry type of problem. Check this article here
 
Old 06-23-2004, 05:52 PM   #3
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
I'm still new to grub, but learning fast (and loving the edit abilities at bootup)

I wonder if you added this
Code:
rootnoverify (hd0,0)
to the windows stanza, if it would boot. Works for me, but I'm booting windows on 2nd HD (hd1,0). Cant' hurt to try.
 
Old 06-23-2004, 06:20 PM   #4
Irving
Member
 
Registered: May 2004
Distribution: Gentoo - KDE 3.2.2
Posts: 57

Rep: Reputation: 15
You definately need "rootnoverify". And if it's Windows XP, I think you can leave off the "makeactive", although I'm not really sure what that does. If you're absoultely sure that your windows partition is /dev/hda1, then your grub section for windows should look like:

Code:
title=Windows
rootnoverify (hd0,0)
chainloader +1
Be sure you have the right windows partition, I ran into the same problem because I had my math mixed up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
SUSE 10.0- GRUB boot loader problem soc_kev Suse/Novell 1 10-25-2005 06:52 PM
Grub boot loader problem DanielTan Linux - Newbie 13 05-05-2005 09:14 PM
GRUB boot loader problem bukich Linux - General 3 06-15-2004 01:22 AM
GRUB boot loader problem with Windows 2000 bukich Linux - General 1 06-11-2004 06:42 AM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration