LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-01-2004, 02:03 PM   #1
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Rep: Reputation: 30
Grip with cdparanoia question


I have been trying now for 5 hours to rip my CD using grip and cdparanoia but to no avail..i have searched and searched but found no solution(other than going to cdda2wav) for this problem and hence i am writing here.
When i tried with cdparanoia the so called ripping process was completed in 10 secs and the status bar said that the ripping and encoding has been completed(i am using lame to encode to .ogg format).however when i went to the created directory..neither the .wav(i had turned off deletion of the .wav files after ripping) nor the .ogg files were there.i read somewhere that to make cdparanoia work make sure u have read access to the genericscsi drive(/dev/scd0 in my case) which i do...and that i should add myself to the cdrom group in /etc/group which i did.however cdparanoia still did not work.
then i tried cdda2wav which did rip the CD but at a very slow rate...on all tracks it was going at 2X which means it took more that 15 minutes to rip a 60 minute cd(i am using a dvd rom here).
i was just wondering if anyone knows what is going on?
the config options for lame are like this:

lame -h -b %b %w %m ~/%A/%d/%n.ogg

can someone plz tell me what is wrong here...the wav files are also dumped at ~/%A/%d/ so i dont think the problem could be that lame is not finding the files.
plz let me know if u need some more information on this.
thanks

Last edited by rmanocha; 02-01-2004 at 02:10 PM.
 
Old 02-19-2004, 03:46 PM   #2
sueisfine
Member
 
Registered: Dec 2003
Distribution: Gentoo
Posts: 33

Rep: Reputation: 15
i have the same problem (not encoding to ogg, but that's not important). when i use cdda2wav, everything is fine (except the missingi error detection), but when i try cdparanoia, it only creates an empty wav.

i tried cdparanoia on shell and everything worked fine (with /dev/scd0 ).

grip version is 3.1.2, i havent tried the stable version, because i couldn't find package and compiling gave missing gnomeConf.sh (or smth) error.
 
Old 02-19-2004, 04:28 PM   #3
sueisfine
Member
 
Registered: Dec 2003
Distribution: Gentoo
Posts: 33

Rep: Reputation: 15
i was tracking the strange thing, that i could rip with shell paranoia and not with grip one.

i noticed that i tried ripping in shell under root, so i tried under user too and it didn't work. i noticed that my user had no rights to access scsi-device (dev/sg0).

Code:
bash-2.05b$ cdparanoia -v -d /dev/sg0 1 bla.wav
cdparanoia III release 9.8 (March 23, 2001)
(C) 2001 Monty <monty@xiph.org> and Xiphophorus

Report bugs to paranoia@xiph.org
http://www.xiph.org/paranoia/

Checking /dev/sg0 for cdrom...
        Testing /dev/sg0 for cooked ioctl() interface
                /dev/sg0 is not a cooked ioctl CDROM.
        Testing /dev/sg0 for SCSI interface
                Could not access device /dev/sg0: Permission denied
                generic device: /dev/sg0
                ioctl device: not found
                Could not open generic SCSI device /dev/sg0: Permission denied
i had no time and so i just chown'd the device to my user:

chown user /dev/sg0

and got things working.

Last edited by sueisfine; 02-19-2004 at 04:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing grip, not able to use cdparanoia arun3 Linux - Software 0 09-20-2004 10:51 PM
grip question AnimaSola Linux - Software 4 05-24-2004 08:14 PM
Grip - cdparanoia clipping end of track PhilD Linux - Software 0 08-05-2003 05:02 PM
grip tool cdparanoia cant access my cd drive ? qwijibow Linux - Software 5 05-17-2003 04:21 PM
Grip Question frkstein Linux - General 2 08-29-2002 06:15 AM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration