LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-14-2009, 10:34 AM   #1
fortez
Member
 
Registered: May 2009
Posts: 35

Rep: Reputation: 0
GQ LDAP client - Package requirements error


I'm trying to install gq ldap client (http://sourceforge.net/projects/gqclient/) on my debian lenny.
When i type configure in sources folder, i receive this error

Quote:
checking for GQ... configure: error: Package requirements (glib-2.0 >= 2.6
gtk+-2.0 >= 2.6
gnome-keyring-1 >= 0.4.4
libglade-2.0
libxml-2.0) were not met:

No package 'glib-2.0' found
No package 'gtk+-2.0' found
No package 'gnome-keyring-1' found
No package 'libglade-2.0' found
No package 'libxml-2.0' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables GQ_CFLAGS
and GQ_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details
.

I have checked: on my debian i have already installed these packeges:
libglib2.0-0 (2.16.6-1+lenny1)
libgtk2.0-0
gnome-keyring (2.22.3-2)
libgnome-keyring0 (2.22.3-2)
libgnome-keyring1.0-cil
libglade2-0
libxml2

In config.log i see, for any above package, an error message as this
Quote:
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
Where is the problem?
Thanks
Bye
 
Old 11-14-2009, 10:53 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Hi,

I guess you need to install also the development packages of the missing dependencies.

Regards
 
Old 11-14-2009, 12:13 PM   #3
fortez
Member
 
Registered: May 2009
Posts: 35

Original Poster
Rep: Reputation: 0
You are rigth, now is ok and i have installed software
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to setup open ldap server and solaris 10 as ldap client maheshlad Linux - Software 1 10-10-2009 01:55 AM
Error during LDAP Client Setup ??? ajeetraina Linux - Server 0 11-29-2007 12:21 AM
GStreamer package requirements jonasan Linux - Software 2 02-27-2006 03:59 AM
LDAP SERVER - CLIENT CONNECTION on suse 9.2 - connection error nicolasdiogo Linux - Networking 4 03-01-2005 02:43 PM
LDAP SERVER - CLIENT CONNECTION on suse 9.2 - connection error nicolasdiogo Suse/Novell 0 03-01-2005 06:43 AM


All times are GMT -5. The time now is 07:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration