LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-21-2004, 04:49 AM   #1
Duukkis
Member
 
Registered: May 2003
Location: Finland
Distribution: Debian Sarge
Posts: 75

Rep: Reputation: 15
gpm don't work properly


I have configuration like this:

Current configuration: -m /dev/psaux -t ps2 -r 78 -Rms3
Device: /dev/psaux
Typer: ps2
Responsiveness: 78
Repeat_Type: ms3

and I have tried to move the Responsiveness value between 30 and 80. The function of mouse is strange because it copies text when i move it. I read from gpm's manual that mouse should copy text when pressing the left button and dragging it. Should I change the gpm's options or did I understood it the wrong way?
 
Old 03-21-2004, 07:20 AM   #2
shedir
Member
 
Registered: Mar 2004
Location: Dresden, Germany
Distribution: Gentoo
Posts: 31

Rep: Reputation: 15
Hi,

it sounds as if you selected the wrong protocol (mouse) type. Try -t autops2.
 
Old 03-21-2004, 09:31 AM   #3
Duukkis
Member
 
Registered: May 2003
Location: Finland
Distribution: Debian Sarge
Posts: 75

Original Poster
Rep: Reputation: 15
Thanks, now it works better. The cursor moves still unusual if comparing to X Windows mouse and I cannot easily copy more than one line at a time. I believe that the options could be better than mine.
 
Old 03-21-2004, 09:58 AM   #4
shedir
Member
 
Registered: Mar 2004
Location: Dresden, Germany
Distribution: Gentoo
Posts: 31

Rep: Reputation: 15
Hi again,

I'm not sure what you mean with "the cursor moves unusual". You can play with the -r option - a higher value increases the speed of motion and vice versa. The -R option doesn't affect the movement of the cursor, it just makes gpm report the data to /dev/gpmdata (with the specified protocol). So, if your xserver is NOT configured to read from /dev/gpmdata you can leave this option blank or set it to none.
(Debian comes with gpmconfig to easily change the config.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CP command doesn't work properly? itz2000 Linux - Newbie 1 08-02-2005 01:14 PM
mysqladmin doesn't work properly Dark Severance Red Hat 0 04-21-2005 09:55 AM
NVIDIA does not work properly in 10.1 Cornholio Slackware 7 03-28-2005 03:00 PM
touchpad/mouse won't work in X 2.4.26 kernel synaptics/gpm issue? dns21 Slackware 4 10-15-2004 12:34 AM
Getting apt-get to work properly pwaring Debian 15 12-12-2003 04:10 PM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration