LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 07-13-2013, 03:23 PM   #1
HaroldWho
Member
 
Registered: Nov 2006
Location: southeastern PA
Distribution: Slackware
Posts: 130

Rep: Reputation: 23
Googleearth 6.0.1.2032 Reports "Invalid HTTP request" On Every Search


Googleearth 6.0.1.2032
Nvidia 304.88
Slack 14

Worked fine a few weeks (months?) ago. Now the error in the title on every location search. Yet, starts and connects to Googleearth server OK. I've tried tcpdump, but I'm not smart enough to get an answer from the dump log.

Both Googleearth and Nvidia say no newer versions available.

Anyone else seeing this? Find a fix?
 
Old 07-13-2013, 03:33 PM   #2
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,012

Rep: Reputation: Disabled
Quote:
Originally Posted by HaroldWho View Post
Googleearth 6.0.1.2032
Nvidia 304.88
Slack 14

Worked fine a few weeks (months?) ago. Now the error in the title on every location search. Yet, starts and connects to Googleearth server OK. I've tried tcpdump, but I'm not smart enough to get an answer from the dump log.

Both Googleearth and Nvidia say no newer versions available.

Anyone else seeing this? Find a fix?
Both Googleearth and Nvidia are wrong. Here's what I'm running.

Quote:
Google Earth 7.1.1.1580 (beta)
Build Date 4/19/2013
Build Time 7:38:45 pm
Renderer OpenGL
Operating System Linux (3.9.0.1)
Video Driver X.Org
Max Texture Size 8192x8192
Have you looked at the Googleearth website?
jdk
 
Old 07-15-2013, 02:18 PM   #3
HaroldWho
Member
 
Registered: Nov 2006
Location: southeastern PA
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 23
You were so right. Googleearth itself says nothing new, but I found 7.1 on the site itself. I'll update and seeif I can mark this "Solved."

Thanks
 
Old 07-15-2013, 03:14 PM   #4
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,012

Rep: Reputation: Disabled
Yes, please do. I'm glad you found it.
jdk
 
Old 07-17-2013, 03:45 PM   #5
HaroldWho
Member
 
Registered: Nov 2006
Location: southeastern PA
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 23
Ouch...still no joy. Converted the rpm to a Slackware tgz; everything installs under /opt. However, when I run googleearth script I get this enigmatic message:

line 43: ./googleearth-bin: No such file or directory.

Darn it, that file is there, and world-executable. Evidently some problem in my case with the googleearth bash script.

Are you using googleearth to start? Unmodified? Maybe I should just install directly from the rpm, perhaps some symling mojo isn't happening.

Any hints appreciated.
 
Old 07-18-2013, 12:32 AM   #6
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,012

Rep: Reputation: Disabled
You shouldn't run the googleearth script. You need to run this script: /opt/google/earth/free/google-earth
jdk
 
Old 07-18-2013, 03:19 PM   #7
HaroldWho
Member
 
Registered: Nov 2006
Location: southeastern PA
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 23
Well, now I AM stumped. Neither my new install nor my old install that gives the HTTP error contains a file called /opt/google/earth/free/google-earth.jdk. There are actually no files with jdk suffix. Now what?

BTW, thanks for your patience and your help.
 
Old 07-18-2013, 03:37 PM   #8
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,012

Rep: Reputation: Disabled
Quote:
Originally Posted by HaroldWho View Post
Well, now I AM stumped. Neither my new install nor my old install that gives the HTTP error contains a file called /opt/google/earth/free/google-earth.jdk. There are actually no files with jdk suffix. Now what?

BTW, thanks for your patience and your help.
Are you pissing around with me? I have better things to do. "jdk" are
my initials.
Practice your reading skills... please.
jdk jdk jdk jdk jdk
 
Old 07-19-2013, 03:16 PM   #9
HaroldWho
Member
 
Registered: Nov 2006
Location: southeastern PA
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 23
JDK is also an acronym for The Java Development Kit, and is sometime used as a suffix for Java scripts.

Practice your temper control skills.

And, speaking of reading skills, /opt/google/earth/free/google-earth is a symlink to
/opt/google/earth/free/googlearth, the very script I've been referring to all along.

Still, you gave it a try, and I appreciate that anyway.
 
Old 07-19-2013, 03:31 PM   #10
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,012

Rep: Reputation: Disabled
Apologies. Yes, google-earth is indeed a link to googleearth in the same folder. I tried replacing google-earth with googleearth in my desktop shortcut and it worked equally well. I can't for the life of me understand why they have both googleearth and google-earth.
Again, apologies.
jdk (not Java)
 
Old 07-19-2013, 07:52 PM   #11
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,111

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
I had this same problem today "Invalid HTTP request" on my machine running PCLinuxOS 2012. It had been working for some time previously so I googled the error and at some google forums it was suggested to remove the libcurl.so.4 file and replace it with a newer one (if available) from /usr/lib/ directory. I had updated PCLinux since installing google-earth so there was a newer libcurl.so.4.2.0 file and I copied it to the /opt/google/earth/free directory. No longer get the error. I also got the same error on Ubuntu 12.04 and Slackware 13.1 but haven't booted either to test yet.
 
1 members found this post helpful.
Old 07-20-2013, 02:44 PM   #12
HaroldWho
Member
 
Registered: Nov 2006
Location: southeastern PA
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 23
yancek, you are 'Da Man." Copied /usr/lib/libcurl.so.4.3.0 to my old googleearth as libcurl.so.4, replacing the old one there. Unbounded joy! No more error messages. I still can't imagine why the new version install won't work, but it's not a biggie any more.

Thanks again.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Mega-victory: Kim Dotcom search warrants "invalid," mansion raid "illegal" LXer Syndicated Linux News 0 07-11-2012 03:30 AM
Problem with squid as transparent proxy: "Invalid request" only on certain pages dtinazzi Linux - Networking 3 08-10-2011 04:41 AM
winbindd: "Invalid request size received" - help GailH Linux - Networking 0 08-05-2011 06:34 AM
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 02:16 PM
Somebody kill my Apache with "Invalid method in request", please help... hurieka Linux - Security 4 06-15-2005 12:29 AM


All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration