LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-23-2002, 04:43 PM   #1
GATTACA
Member
 
Registered: Feb 2002
Location: USA
Distribution: Fedora, CENTOS
Posts: 206

Rep: Reputation: 32
Unhappy GNU emacs issues


Hello,

I'm trying to do something I thought would be relatively easy.

I have gnu emacs (version 21.2.1) on my RedHat Linux 7.3 box. I'm trying to set it up so the default background color is a shade of gray (specifically #bfbfbf).

Here's what I'm doing:
1. I go to Optioins->Customize Emacs->Specific Face...
2. Scroll down to "Default" and for background color enter "#bfbfbf".
3. I choose to save the changes for future sessions and then the color change takes effect.

HOWEVER: After I quit emacs and restart it, the background color is reset to white.

I've tried editing the .emac file in my home directory but that hasn't helped either.

Maybe I'm changing the wrong option, I'm not sure...
Does anyone have any suggestions?
 
Old 06-23-2002, 05:37 PM   #2
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
i think there's an option to save the changes u made

also u can try this format in .emacs

(set-face-background 'default "oldlace")
 
Old 06-23-2002, 05:49 PM   #3
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
i think there's an option to save the changes u made..

and also u can try

(set-face-background 'default "oldlace")
in your .emacs
 
Old 06-23-2002, 08:10 PM   #4
GATTACA
Member
 
Registered: Feb 2002
Location: USA
Distribution: Fedora, CENTOS
Posts: 206

Original Poster
Rep: Reputation: 32
Tried that.

Thanks for the tip but it doesn't seem to work.

If I simply replace my .emacs file with a different one would that work?

Does anyone have an easy to edit .emacs file?
 
Old 06-23-2002, 08:21 PM   #5
GATTACA
Member
 
Registered: Feb 2002
Location: USA
Distribution: Fedora, CENTOS
Posts: 206

Original Poster
Rep: Reputation: 32
Maybe this will help.
Here is the .emacs file created after adjust the default face background color:

(custom-set-variables
;; custom-set-variables was added by Custom -- don't edit or cut/paste it!
;; Your init file should contain only one such instance.
)
(custom-set-faces
;; custom-set-faces was added by Custom -- don't edit or cut/paste it!
;; Your init file should contain only one such instance.
'(default ((t (:stipple nil :background "#bfbfbf" :foreground "#000000" :inverse-video nil :box nil :strike-through nil verline nil :underline nil :slant normal :weight normal :height 90 :width normal :family "adobe-courier")))))


Does this help?
 
Old 06-23-2002, 08:22 PM   #6
GATTACA
Member
 
Registered: Feb 2002
Location: USA
Distribution: Fedora, CENTOS
Posts: 206

Original Poster
Rep: Reputation: 32
Here's that same post,
A face got inserted in the middle of the file.


(custom-set-variables
;; custom-set-variables was added by Custom -- don't edit or cut/paste it!
;; Your init file should contain only one such instance.
)
(custom-set-faces
;; custom-set-faces was added by Custom -- don't edit or cut/paste it!
;; Your init file should contain only one such instance.
'(default ((t (:stipple nil :background "#bfbfbf" :foreground "#000000" :inverse-video nil :box nil :strike-through nil :overline nil :underline nil :slant normal :weight normal :height 90 :width normal :family "adobe-courier")))))
 
Old 06-24-2002, 06:45 AM   #7
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
also
in .emacs file
sometimes where u put the line matters....
try fresh .emacs with only one line...
 
Old 08-03-2003, 11:20 PM   #8
mayagenesis
LQ Newbie
 
Registered: Jul 2003
Posts: 6

Rep: Reputation: 0
I hope this will solve the problem.

Go to Control Center and Appearance and themes --> Colors and them disable Apply color to non KDE applications.

That worked for me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MUSIX GNU+LINUX language woes and install issues CinnamonGhoul Linux - Distributions 1 10-14-2005 02:49 AM
anyone read "GNU Emacs" before ? black Linux - General 7 08-12-2004 05:10 PM
emacs problems and USB issues clartonabike Linux - Newbie 2 02-20-2004 09:52 AM
how should I respond to "Encryption key for doc.gpg?" in GNU Emacs? Joseph Schiller Programming 1 10-24-2003 12:51 PM
Disabling GNU Emacs Toolbar and Menubar mayagenesis Linux - Newbie 2 08-05-2003 05:06 PM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration