LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 12-01-2009, 01:48 PM   #1
rdnelson
LQ Newbie
 
Registered: Aug 2003
Location: Princeton, NJ, USA
Distribution: Fedora, Centos, Ubuntu
Posts: 14

Rep: Reputation: 0
Gnome screen-saver does not turn on when system is idle, FC-11


This question was asked on a different thread about using the inhibit function -- which was the closest I could find -- but I am making a new thread because what I need is the opposite.

My Gnome screensaver doesn't work, although it once did.

I have searched for a solution to this problem but no luck. I am running FC 11 and out-of-the-box gnome. At first the screensaver worked normally, shutting off the screen after 5 mins. Now it does not do so. I found the following command line suggestion in the forums, and it looks like it may point to a problem -- the screensaver is inactive, but how to make it active? I may be misunderstanding the term inactive, of course. Logically, the screensaver would have to be inactive if I am typing a command. In any case, the query command shows:

home/rdn% gnome-screensaver-command --query
The screensaver is inactive
The screensaver is not inhibited

Just in case the screensaver really was not running, I tried this command (which I found in another post):

home/rdn% killall -CONT gnome-screensaver

But the query returns the same thing as before.

The only thing I can think of that might be an issue is that using the "appearances" background facility I added a couple dozen pictures that I thought I might use as screen background. Not long after that I discovered that my screen did not go black after 5 mins as expected. Not sure this correlation has any causal meaning, however. I then tried various things, finally returning to the plain (blue) default. That seemed to fix it for a short while, then after a couple of days, the bad or non-behavior returned -- the screensaver does not work.
(update -- I removed all the extra background pics and it makes no difference.)

Any help will be appreciated. My system runs all the time, but I don't want the screen to be on all the time.

Roger
 
Old 12-21-2009, 10:03 PM   #2
Kenichi Kato
Member
 
Registered: Jun 2007
Location: Asia
Distribution: Ubuntu, Fedora, CentOS & TCL
Posts: 62
Blog Entries: 1

Rep: Reputation: 16
How about using the Power Management & putting the Display to sleep after some scheduled inactivity?
 
Old 12-21-2009, 10:10 PM   #3
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
Check the screen saver settings

Code:
/usr/bin/gnome-screensaver-preferences
 
Old 12-22-2009, 05:43 AM   #4
rdnelson
LQ Newbie
 
Registered: Aug 2003
Location: Princeton, NJ, USA
Distribution: Fedora, Centos, Ubuntu
Posts: 14

Original Poster
Rep: Reputation: 0
I appreciate both efforts to help, but I had done those things. In the meantime I did find a partial solution -- and it was *hardware* related. To be thorough, I decided to unplug the monitor from the workstation and then re-insert the connector.
This resulted in the screensaver turning off the display as expected, so the problem was partly solved. What remains a problem is that the backlight does stay on, even though the power management is set to turn off the display after an interval (10 mins). So the LED display and most of the brightness of the picture is off (my screen-saver setting is a blank screen) but there is a faint glow due to the backlight. In previous incarnation, this faint glow was also off.
Thanks, Roger
 
Old 12-23-2009, 02:22 AM   #5
Kenichi Kato
Member
 
Registered: Jun 2007
Location: Asia
Distribution: Ubuntu, Fedora, CentOS & TCL
Posts: 62
Blog Entries: 1

Rep: Reputation: 16
Appreciate the feedback.

Cheers.
 
  


Reply

Tags
fc11, gnome, screensaver, software


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't turn off screen saver/blanking on FC 7 mallarj Linux - Software 5 12-04-2007 09:29 AM
Feisty: Screensavers Run Slowly During Idle Time, and Fast During screen Saver Test. bburgy Ubuntu 4 06-27-2007 10:05 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 12:50 PM
Hot to turn the screen saver off in RedHat 7.3? danielwpc Linux - General 3 07-28-2003 04:06 AM
KDE Screen Saver In Gnome MarcRJacobs Linux - Newbie 0 03-31-2003 08:33 PM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration