LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-08-2006, 07:35 AM   #1
salmanucit
Member
 
Registered: Jul 2004
Posts: 54

Rep: Reputation: 15
GNOME not working correctly


hi
i am using Red Hat Linux Advance Server 4 update 2

I used address bar of file browser of gnome to access a folder on windows as follows
"smb://lhrpc419/shared" i always use this and it works fine. without closing this window i shutdon my machine and when i restarted it, gnoe is not working correctly. i can see desktop but graphics are very pathatic and i cant see task baar.
when i open any application, i see the following error on a message box

***************
An error occured while loading or saving configuration information for Nautilus. Some of your configuration setting may not work properly
***************

When i click on details, i see the following error

***************
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory 2: IOR file '/tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory)
***************

Can anyone tell me that how to solve this problem



Regards
 
Old 02-08-2006, 10:53 AM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Well, your error messages all seem to be saying that they can't find the Oracle lock files. This suggests that your Nautilus session information that was saved included an active connection to an Oracle data base, and that that connection was closed during the shutdown, so the saved Nautilus state is inconsistent with the actual system state.

If you install gTweekUI, you should get (among outer things) an additional menu item under "More Preferences" which will let you disable the automatic saving of the session state on logout.

Or you could try to remove the Nautilus session restore from the ~/.gnome2/session file, and then restart Nautilus by hand.

Note that, by default, Nautilus is used to "draw" the entire GNOME window, so the Oracle connection may not have been active in Nautilus itself, but simply displayed in some GNOME window. If that's the case, perhaps removing the Oracle table display(s) from the session file would be the best thing to do. (You can also, using gTweekUI ask GNOME to not use Nautilus to display the GNOME window. This has the effect of removing all icons from the desktop, wich is a feature I like, since I prefer to use menus to access application.)

Edit: Oh, if your problem was caused by the saved session saving some Oracle table displays from your desktop, perhaps you should try to close all table displays before you shutdown, or add a shutdown shell script that does so for you.

Last edited by PTrenholme; 02-08-2006 at 10:58 AM.
 
Old 02-09-2006, 04:08 AM   #3
salmanucit
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
hi
i cleaned the whole "session" File. Actuall i have a user called ORACLE for management of Oracle Database Server and
i found this session file in its home folder. After that i restared the machine but its still not working
1) How to restart Nautilus by "hand" as u said
2) i dont understan the word u r using "Oracle Tables display from desktop". What does it mean. i have also washed out my
desktop now but same problem.
3) what do u mean by "close all table displays"

Its also displaying a dialog box with heading ""GConf Error" and displays "IOR FIle 'tmp/gconfd-oracle/lock/ior' not opened successfully, no gconfd located: No such file or directory"

Regards

Last edited by salmanucit; 02-09-2006 at 04:13 AM.
 
Old 02-09-2006, 10:49 AM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
First, sorry: Since you are a DBA, I assumed that the "Oracle" was referring to a live Oracle connection rather than a user. Hence my comments about a "table display on the desktop." (Since Nautilus draws the desktop, I think you can set up a TCP connection to an Oracle DB that can display an Oracle application in a window on the desktop.) Anyhow, my bad. Sorry.

OK, let's try this: Do a ls -l /tmp/gconfd-oracle/* and a ls -l /tmp/gconfd-oracle/*/* You should see something like this:
Code:
$ ls -l /tmp/gconfd-*
/tmp/gconfd-oracle:
total 8
drwx------  2 oracle oracle 4096 Feb  9 07:57 lock
ls: /tmp/gconfd-root: Permission denied
$ ls -l /tmp/gconfd-*/*
total 8
-rwx------  1 oracle oracle 601 Feb  9 07:57 ior
$ cat /tmp/gconfd-*/*/ior
3119:IOR:010000001600000049444c3a436f6e666967536572766572323a312e30000000030000000054424f500000000101020005000000554e495800000000060000007473732d340000002a0000002f746d702f6f726269742d70657465722f6c696e632d6332662d302d3364616464653839613635313000000000000000caaedfba54000000010102002a0000002f746d702f6f726269742d70657465722f6c696e632d6332662d302d336461646465383961363531300000001c00000000000000105acce0970468a8dc2928282828282801000000fccfad6901000000480000000100000002000000050000001c00000000000000105acce0970468a8dc2928282828282801000000fccfad6901000000140000000100000001000105000000000901010000000000
From the error message, either these directories and this file don't exist, or the permissions on the /tmp directory won't let the "oracle" user access them properly. Since they are in /tmp, first do a ls -l / to verify that the permissons on /tmp are drwxrwxrwt (Note the terminal "t", indicating a "sticky" directory, so the other premissions should be immutable.)

I believe that the /tmp/gconfd-oracle directories and the ior file should be created when the "oracle" user logs in, so (if I'm correct) log in as root and delete all those directories and files (e.g., rm -R /tmp/gconfd-oracle/), and then log back in as "oracle."

CAUTION! Of course, I may not be correct, and looking at the gconfd documentation is probably a good idea.

Oh, another thought: I did a $ gconf<tab><tab> and found several commands that might help you:
Code:
$ gconf
gconfd-1              gconf-merge-tree      gconftool-2
gconf-editor          gconf-sanity-check-1
gconfigger            gconftool-1
Good luck.

Last edited by PTrenholme; 02-09-2006 at 10:50 AM.
 
Old 02-17-2006, 06:10 AM   #5
salmanucit
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Nops
Still not working
 
Old 07-15-2010, 10:18 AM   #6
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
I was getting these messages for lots of applications, and for me it was fixed when I deleted my ~/.gconfd directory, which had a file called saved_state in it. Apparently that file got corrupted somehow.
 
Old 11-23-2010, 01:41 PM   #7
gfyork
LQ Newbie
 
Registered: Nov 2010
Distribution: Ubuntu
Posts: 2

Rep: Reputation: 0
That works for me

Quote:
Originally Posted by g4c9z View Post
I was getting these messages for lots of applications, and for me it was fixed when I deleted my ~/.gconfd directory, which had a file called saved_state in it. Apparently that file got corrupted somehow.
I had an apparently identical problem. Rebooted (for the umpteenth time) moved the ~/.gconfd directory to a safe place (~/_.gconfd), rebooted and -- oh my, all was wonderfully well.

Thanks.

G.
 
Old 11-23-2010, 09:17 PM   #8
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
It turned out that didn't fix my problem, after all. I thought it did initially, but it came back. Oh well, glad it fixed yours...
 
Old 11-24-2010, 01:27 AM   #9
gfyork
LQ Newbie
 
Registered: Nov 2010
Distribution: Ubuntu
Posts: 2

Rep: Reputation: 0
Well now I'm becoming a tad nervous.

My problem manifested after a screen freeze followed by a power down and reboot.

During the many subsequent reboot cycles, I'd found and deleted a few locks -- but no joy. Junking the 'saved_state' has seemed to make it all better. (And the system even seems to run faster -- though that may be due to the new *.26 generic coming in.)

I doubt you recall after these several years how long your apparent recover lasted -- and whether it lasted through your first reboot or not.

Have my fingers tightly crossed -- and it's really hard typing that way.

Best,

G.
 
Old 11-24-2010, 05:51 PM   #10
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
My apparent recovery only lasted a day or so. It might not have lasted through a reboot.
 
Old 04-23-2011, 08:52 PM   #11
JWilliamCupp
Member
 
Registered: Jul 2005
Location: Indiana, U.S.A.
Distribution: Fedora
Posts: 32

Rep: Reputation: 15
Quote:
Originally Posted by gfyork View Post
I had an apparently identical problem. Rebooted (for the umpteenth time) moved the ~/.gconfd directory to a safe place (~/_.gconfd), rebooted and -- oh my, all was wonderfully well.
Yep, this did it for me, too. Thanks for posting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to make my cd-rw working correctly kira Linux - Hardware 8 05-16-2005 10:27 PM
installpkg not working correctly Addict3dtoX Linux - Software 13 09-22-2004 05:31 PM
Gnome doesn't start correctly soren625 Linux - Software 0 07-08-2004 05:36 PM
gnome not running correctly lbtheone Linux - Networking 4 04-24-2004 12:33 PM
pacman not working correctly! Aman9090 Arch 2 03-26-2004 06:32 AM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration