LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-03-2003, 06:02 PM   #1
noir-gel
Member
 
Registered: Dec 2002
Posts: 51

Rep: Reputation: 15
gnome lib exists?


Hi all!!

I'm having a strange problem with my Debian SID compiling a program (for my creative jukebox)...

when I run the ./configure script I get this error during the execution:

...
...
checking whether make sets $(MAKE)... (cached) yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 gthread-2.0 gtk+-2.0 libgnome-2.0 libgnomeui-2.0... Package libgnome-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgnome-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnome-2.0' found

configure: error: Library requirements ( glib-2.0 gthread-2.0 gtk+-2.0 libgnome-2.0
libgnomeui-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

************************************
ok...
so now I try to reinstall libgnome-2.0 libraries:

apt-get install --reinstall libgnome-2.0

...same error...


now I take a look in aptitude:

it appears with a i followed with an h...
help says that means the package is on hold... but I don't know what to do. What's the meaning of the error instructions?

thanks you very much for your time!!

.alvaro.castro.
 
Old 02-03-2003, 06:35 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you need the libgnome-devel-2.0 (or whatever it is called) package.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SIOCADDRT: File exists SIOCCADDRT: File Exists Failed to bring up eth0. opsraja Linux - Networking 0 01-10-2005 09:29 AM
Compromised? Files "/usr/lib.hwm", "/usr/lib.pwd", "/usr/lib.pwi" Klaus Pforte Linux - Security 4 09-29-2004 12:33 AM
slack10.0 gnome file manager missing lib dr_unpleasant Slackware 1 07-16-2004 02:10 AM
gnome-development lib and packages carboncopy Slackware 0 07-09-2004 10:53 PM
gnome lib problem cyberia_2ooo Slackware 1 05-08-2003 08:17 AM


All times are GMT -5. The time now is 03:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration