LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-09-2004, 01:50 AM   #1
reaky
Member
 
Registered: Oct 2003
Posts: 60

Rep: Reputation: 15
gnome can't be removed


hi all
there is a problem facing me
i tried to remove all gnome packages from my system i do it from add/remove applications
but when i click update he told me that there is packages not found to my system to complete this
like control-center , libgpilotd.so.2 , and others
when i try to install all this packages again he told me that they are already installed
i don't know what's the problem
can anyone help me
 
Old 03-10-2004, 09:57 AM   #2
bigearsbilly
Senior Member
 
Registered: Mar 2004
Location: england
Distribution: FreeBSD, Debian, Mint, Puppy
Posts: 3,287

Rep: Reputation: 173Reputation: 173
are you using gnome to remove gnome?

what you got? suse redhat etc.

billy
 
Old 03-11-2004, 03:40 AM   #3
reaky
Member
 
Registered: Oct 2003
Posts: 60

Original Poster
Rep: Reputation: 15
noooo
i use kde
and the distro is Fedora
 
Old 03-11-2004, 04:15 AM   #4
bigearsbilly
Senior Member
 
Registered: Mar 2004
Location: england
Distribution: FreeBSD, Debian, Mint, Puppy
Posts: 3,287

Rep: Reputation: 173Reputation: 173
Open a terminal,
do:
rpm -qa | grep -i gnome | xargs -n1 rpm -e

or safer
rpm -qa | grep -i gnome
then manually
rpm -e

each package. As some applications still rely on
the GNOME libraries.

cut and paste is middle button on X term.


billy





that will remove all gnome.
 
Old 03-11-2004, 01:36 PM   #5
reaky
Member
 
Registered: Oct 2003
Posts: 60

Original Poster
Rep: Reputation: 15
he gives me the following error message

error: Failed dependencies:
gnome-python2 is needed by (installed) redhat-config-bind-2.0.0-18
gnome-python2 is needed by (installed) redhat-config-httpd-1.1.0-5
gnome-python2 is needed by (installed) redhat-config-services-0.8.5-23
gnome-python2 is needed by (installed) redhat-config-network-1.3.10-1
gnome-python2 is needed by (installed) redhat-config-printer-gui-0.6.79.5-1
gnome-python2 is needed by (installed) up2date-gnome-4.1.21-3
gnome-python2 >= 1.99.11-7 is needed by (installed) rhn-applet-2.1.4-3
gnome-python2 >= 1.99.11-3 is needed by (installed) redhat-config-packages-1.2.7-1
error: Failed dependencies:
gnome-spell >= 1.0.2 is needed by (installed) evolution-1.4.5-7
error: Failed dependencies:
gnome-utils >= 2.0.2 is needed by (installed) desktop-printing-0.1.10-18
error: Failed dependencies:
libgnomecanvas-devel >= 2.3.0 is needed by (installed) gail-devel-1.4.0-1
libgnomecanvas-devel >= 2.0.1 is needed by (installed) libbonoboui-devel-2.4.0-1
libgnomecanvas-devel >= 2.0.0 is needed by (installed) libgnomeui-devel-2.4.0.1-1
error: Failed dependencies:
libart_lgpl.so.2 is needed by (installed) gtoaster-1.0beta6-6
libart_lgpl.so.2 is needed by (installed) gdk-pixbuf-gnome-0.22.0-3.0
libart_lgpl.so.2 is needed by (installed) libcapplet0-1.4.0.1-13
libart_lgpl.so.2 is needed by (installed) libglade-0.17-12.2
libart_lgpl.so.2 is needed by (installed) libgnomeprint15-0.37-7.1
libart_lgpl.so.2 is needed by (installed) bonobo-1.0.22-7
libart_lgpl.so.2 is needed by (installed) gnome-print-0.37-7.1
libart_lgpl.so.2 is needed by (installed) gtkhtml-1.1.9-5
libart_lgpl.so.2 is needed by (installed) grip-3.0.7-3
libgnome.so.32 is needed by (installed) gtoaster-1.0beta6-6
libgnome.so.32 is needed by (installed) gdk-pixbuf-gnome-0.22.0-3.0
libgnome.so.32 is needed by (installed) libcapplet0-1.4.0.1-13
libgnome.so.32 is needed by (installed) libglade-0.17-12.2
libgnome.so.32 is needed by (installed) libgnomeprint15-0.37-7.1
libgnome.so.32 is needed by (installed) bonobo-1.0.22-7
libgnome.so.32 is needed by (installed) gnome-print-0.37-7.1
libgnome.so.32 is needed by (installed) gtkhtml-1.1.9-5
libgnome.so.32 is needed by (installed) grip-3.0.7-3
libgnomesupport.so.0 is needed by (installed) gtoaster-1.0beta6-6
libgnomesupport.so.0 is needed by (installed) gdk-pixbuf-gnome-0.22.0-3.0
libgnomesupport.so.0 is needed by (installed) libcapplet0-1.4.0.1-13
libgnomesupport.so.0 is needed by (installed) libglade-0.17-12.2
libgnomesupport.so.0 is needed by (installed) libgnomeprint15-0.37-7.1
libgnomesupport.so.0 is needed by (installed) bonobo-1.0.22-7
libgnomesupport.so.0 is needed by (installed) gnome-print-0.37-7.1
libgnomesupport.so.0 is needed by (installed) gtkhtml-1.1.9-5
libgnomesupport.so.0 is needed by (installed) grip-3.0.7-3
libgnomeui.so.32 is needed by (installed) gtoaster-1.0beta6-6
libgnomeui.so.32 is needed by (installed) gdk-pixbuf-gnome-0.22.0-3.0
libgnomeui.so.32 is needed by (installed) libcapplet0-1.4.0.1-13
libgnomeui.so.32 is needed by (installed) libglade-0.17-12.2
libgnomeui.so.32 is needed by (installed) libgnomeprint15-0.37-7.1
libgnomeui.so.32 is needed by (installed) bonobo-1.0.22-7
libgnomeui.so.32 is needed by (installed) gnome-print-0.37-7.1
libgnomeui.so.32 is needed by (installed) gtkhtml-1.1.9-5
libgnomeui.so.32 is needed by (installed) Guppi-0.40.3-16
libgnomeui.so.32 is needed by (installed) grip-3.0.7-3
libgnorba.so.27 is needed by (installed) libcapplet0-1.4.0.1-13
libgnorba.so.27 is needed by (installed) gtkhtml-1.1.9-5
libgtkxmhtml.so.1 is needed by (installed) gimp-1.2.5-1
gnome-libs is needed by (installed) libglade-0.17-12.2
gnome-libs >= 1:1.2.5 is needed by (installed) bonobo-1.0.22-7
gnome-libs is needed by (installed) gnome-print-0.37-7.1
gnome-libs = 1:1.4.1.2.90 is needed by (installed) gnome-libs-devel-1.4.1.2.90-36
error: Failed dependencies:
gnome-mime-data >= 2.0.0-11 is needed by (installed) gnome-vfs2-2.4.1-1
gnome-mime-data is needed by (installed) magicdev-1.1.4-7
gnome-mime-data is needed by (installed) gnome-vfs-1.0.5-15
error: Failed dependencies:
libgnome-desktop-2.so.2 is needed by (installed) nautilus-2.4.0-7
libgnome-desktop-2.so.2 is needed by (installed) gnome-utils-2.4.0-1
libgnome-desktop-2.so.2 is needed by (installed) control-center-2.4.0-3
libgnome-desktop-2.so.2 is needed by (installed) bug-buddy-2.4.0-1
libgnome-desktop-2.so.2 is needed by (installed) gnome-panel-2.4.2-3
gnome-desktop = 2.4.0 is needed by (installed) gnome-desktop-devel-2.4.0-1
gnome-desktop >= 2.3.0 is needed by (installed) gnome-panel-2.4.2-3
error: Failed dependencies:
libgnomeprintui-2-2.so.0 is needed by (installed) gpdf-0.110-1
libgnomeprintui-2-2.so.0 is needed by (installed) libgal2-1.99.10-2
libgnomeprintui-2-2.so.0 is needed by (installed) gtkhtml3-3.0.9-5
libgnomeprintui-2-2.so.0 is needed by (installed) evolution-1.4.5-7
libgnomeprintui-2-2.so.0 is needed by (installed) mrproject-0.10-1
libgnomeprintui-2-2.so.0 is needed by (installed) eog-2.4.0-1
libgnomeprintui-2-2.so.0 is needed by (installed) gedit-2.4.0-3
libgnomeprintui22 is needed by (installed) gpdf-0.110-1
libgnomeprintui22 >= 2.2.0 is needed by (installed) mrproject-0.10-1
libgnomeprintui22 >= 2.3.0 is needed by (installed) gedit-2.4.0-3
error: Failed dependencies:
gnome-vfs2-extras is needed by (installed) nautilus-2.4.0-7
error: Failed dependencies:
gnome-python2-bonobo is needed by (installed) gnome-python2-2.0.0-2
error: Failed dependencies:
gnome-icon-theme >= 0.1.5 is needed by (installed) gnome-vfs2-extras-0.99.10-3.1
gnome-icon-theme >= 1.0.2 is needed by (installed) nautilus-2.4.0-7
error: Failed dependencies:
libgail-gnome is needed by (installed) control-center-2.4.0-3
error: Failed dependencies:
libgnomeprintui-2.so.0 is needed by (installed) gthumb-2.0.2-1
error: Failed dependencies:
gnome-vfs >= 1.0.0 is needed by (installed) gnome-vfs-extras-0.2.0-7
gnome-vfs = 1.0.5 is needed by (installed) gnome-vfs-devel-1.0.5-15
error: Failed dependencies:
gnome-vfs2-devel >= 2.1.0 is needed by (installed) libgnome-devel-2.4.0-1
gnome-vfs2-devel >= 2.2.0 is needed by (installed) libgnomeui-devel-2.4.0.1-1
gnome-vfs2-devel >= 2.3.0 is needed by (installed) eel2-devel-2.4.0-1
gnome-vfs2-devel >= 2.2.0 is needed by (installed) gnome-desktop-devel-2.4.0-1
error: Failed dependencies:
gnome-python2-canvas is needed by (installed) redhat-config-bind-2.0.0-18
gnome-python2-canvas is needed by (installed) redhat-config-services-0.8.5-23
gnome-python2-canvas is needed by (installed) redhat-config-network-1.3.10-1
gnome-python2-canvas is needed by (installed) up2date-gnome-4.1.21-3
error: Failed dependencies:
gnome-python2-gtkhtml2 is needed by (installed) redhat-config-printer-gui-0.6.79.5-1
gnome-python2-gtkhtml2 is needed by (installed) rhn-applet-2.1.4-3
error: Failed dependencies:
libgnomeui-2.so.0 is needed by (installed) gnome-python2-2.0.0-2
libgnomeui-2.so.0 is needed by (installed) gnome-desktop-2.4.0-1
libgnomeui-2.so.0 is needed by (installed) gnome-pilot-2.0.10-4
libgnomeui-2.so.0 is needed by (installed) gnome-spell-1.0.5-2
libgnomeui-2.so.0 is needed by (installed) libcroco-0.3.0-1
libgnomeui-2.so.0 is needed by (installed) librsvg2-2.4.0-3
libgnomeui-2.so.0 is needed by (installed) eel2-2.4.0-1
libgnomeui-2.so.0 is needed by (installed) rhythmbox-0.5.4-1
libgnomeui-2.so.0 is needed by (installed) sound-juicer-0.5.5-1
libgnomeui-2.so.0 is needed by (installed) gpdf-0.110-1
libgnomeui-2.so.0 is needed by (installed) libgal2-1.99.10-2
libgnomeui-2.so.0 is needed by (installed) gtkhtml3-3.0.9-5
libgnomeui-2.so.0 is needed by (installed) evolution-1.4.5-7
libgnomeui-2.so.0 is needed by (installed) ggv-2.4.0.1-1
libgnomeui-2.so.0 is needed by (installed) mrproject-0.10-1
libgnomeui-2.so.0 is needed by (installed) nautilus-cd-burner-0.5.3-1
libgnomeui-2.so.0 is needed by (installed) eog-2.4.0-1
libgnomeui-2.so.0 is needed by (installed) nautilus-2.4.0-7
libgnomeui-2.so.0 is needed by (installed) gnome-terminal-2.4.0.1-1
libgnomeui-2.so.0 is needed by (installed) gnome-utils-2.4.0-1
libgnomeui-2.so.0 is needed by (installed) libgail-gnome-1.0.2-2
libgnomeui-2.so.0 is needed by (installed) m


and go on
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
removed GNOME from mandriva 10.2, lost system icon and openoffice??? nopibaru Linux - Newbie 2 10-12-2005 04:27 PM
What have i done! :( (removed pkgtools) BBB Slackware 9 12-31-2004 12:55 PM
Help: Removed Alsa UmneyDurak Fedora 3 09-19-2004 11:22 AM
Accidentaly removed top gnome panel :-( khermans Linux - General 3 07-22-2004 04:53 PM
Removed Forum jeremy LQ Suggestions & Feedback 4 08-12-2000 03:18 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration