LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-01-2003, 10:21 PM   #1
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
Gnome 2.4 and OpenOffice 1.1


Just installed Slackware 9.1 with Gnome 2.4 and am really impressed with it's stability. I tried to install OpenOffice 1.1 and none of the menu item were installed and when I tried to start from a terminal it brings up an error message.

I saw a report the the release candidates of OO1.1 did not support Gnome initially But I now can find a Gnome directory in /usr/local/OpenOffice.org1.1.0.

The same package installed without problem in kde 3.12 on my laptop.

Any one else having this problem?
 
Old 10-02-2003, 07:07 AM   #2
Raptor Ramjet
Member
 
Registered: Apr 2003
Location: Under a rock
Distribution: Slackware "current" - Praise "Bob" !!!!
Posts: 92

Rep: Reputation: 15
I too installed OpenOffice 1.1 - No menu items in Gnome but it works

Hello,

I too have installed Slackware 9.1 and am (mostly) using GNOME 2.4. As I am rather new to Linux I simply downloaded the .tar.gz file from the OpenOffice org website and installed it as per the instructions on the site.

I then logged in to my user, ran the user setup script and did a "startx" but whilst this all worked there were no new menu items for OO in GNOME .

So, for the time being, I've simply added my own menu items in the "Office" menu with shortcuts of "soffice -write" for OO writer and "soffice -calc" for OO Calc. I can also succesfully launch OO from a terminal window using these commands (in fact this is how I worked out what the commands were !)

Sadly I'm at work on a Windoze box at the moment so I can't remember exactly how I set up the shortcuts but I think the sequence of events is:

Click on "Start Here"
Click on "Application"
Add a new shortcut specifying "soffice -write" for the command and one of the OO icons from /opt/OpenOffice/Share/Icons (or something similar) as the icon.

However I'll be doing a spot more digging about for a better way of getting the full OO menu in GNOME 2.4 so will update this thread when (if ?) I get some proper results.

But I'll take the opportunity to say this again... Slackware 9.1 is the most fun I've had with a computer in ages. I've also learnt more about Linux by using Slackware than I have with any other distro.

I love it !
 
Old 11-08-2003, 01:01 PM   #3
SADANA
LQ Newbie
 
Registered: Nov 2001
Location: Amman - Jordan
Distribution: Slackware
Posts: 25

Rep: Reputation: 15
hi, i recently installed Salckware9.1 and have had the same problem as you, i found a solution to the missing OpenOffice menu in Gnome. FYI, i'm using OpenOffice1.1 and Gnome2.4, i don't know if this works in other versions.

1. make sure that after running the workstaion setup of OpenOffice, this folder "~/.gnome2/vfolders/applications/" contains a bunch of text files with the following names:

ooo645calc.desktop ooo645math.desktop ooo645web.desktop
ooo645draw.desktop ooo645printeradmin.desktop ooo645writer.desktop
ooo645impress.desktop ooo645template.desktop

these text files are responsible for the menu items of OpenOffice.
*if these files do not exist you should re-run the workstaion setup and choose repair, if that doesn't create them either then i have no idea how to create them!!?

2. check to see if this file exists "~/.gnome2/vfolders/applications.vfolder-info" if it does go to step 5.

3. you now have to create that file and paste the following into it, just be sure to replace each occurance of "sadana" with your login name. there are 9 occurances!


<?xml version="1.0"?>
<VFolderInfo>
<WriteDir>/home/sadana/.gnome2/vfolders/applications</WriteDir>
<Folder>
<Name>Root</Name>
<Parent>applications-all-users:///</Parent>
<Folder>
<Name>OpenOffice</Name>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645calc.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645draw.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645impress.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645math.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645printeradmin.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645template.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645web.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645writer.desktop</Include>
</Folder>
</Folder>
</VFolderInfo>


4. save the file and go to step 8

5. if the file already exists then that means you've added a couple of items to your menu. open the file. it should read something like:

<?xml version="1.0"?>
<VFolderInfo>
<WriteDir>/home/sadana/.gnome2/vfolders/applications</WriteDir>
<Folder>
<Name>Root</Name>
<Parent>applications-all-users:///</Parent>
<Folder>
<Name>Multimedia</Name>
<Parent>applications-all-users:///Multimedia</Parent>
<Include>/home/sadana/.gnome2/vfolders/applications/1068178486-Mplayer.desktop</Include>
</Folder>
</Folder>
</VFolderInfo>


6. paste the following just after the line "<Parent>applications-all-users:///</Parent>". be sure to replace each occurance of "sadana" with your login name. there are 8 occurances!

<Folder>
<Name>OpenOffice</Name>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645calc.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645draw.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645impress.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645math.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645printeradmin.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645template.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645web.desktop</Include>
<Include>/home/sadana/.gnome2/vfolders/applications/ooo645writer.desktop</Include>
</Folder>

7. save the file

8. log out, log in. hopefully you now have a new menu called OpenOffice!

*beware, if you screw up (like i did once) the panel won't load, the "applications.vfolder-info" file is an XML file and the tags are case sensitive! just delete the file, the all should go well!

hope this works for you!
 
Old 11-08-2003, 04:49 PM   #4
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Original Poster
Rep: Reputation: 33
Since that post I have found an easier way to set up an OpenOffice Menu in Gnome 2.4.

First copy the icons in /usr/local/OpenOffice.org1.1.0/share/icons into /usr/share/pixmaps.

Next click on "Start Here" on your user desktop. Then "Applications". Then create a new folder I named OpenOffice with a custom icon (I used the OpenOffice gulls icon). Open your newly created folder and move the nautilus window to one corner.

Open a second nautilus window and browse to /usr/local/OpenOffice.org1.1.0/share/gnome/net.

This has a series of files like OpenOffice.org1.1.0 Calc. Use your mouse to drag that file to your first Nautilus window with the OpenOffice folder. Then drag Writer, Printer administration etc over.

There appear to be 2 icons for each openoffice application so I just drag and dropped the first 8 from the second nautilus window.

Once you are done drag and dropping then close Gnome 2.4. The next time you start Gnome 2.4 the OpenOffice icons should be on your Applications menu.
 
Old 11-09-2003, 07:58 AM   #5
Raptor Ramjet
Member
 
Registered: Apr 2003
Location: Under a rock
Distribution: Slackware "current" - Praise "Bob" !!!!
Posts: 92

Rep: Reputation: 15
Well thankyou for the highly detailed advice !

Unfortunately though my new monitor has just died so until it gets replaced I'll not be able to try out your solutions as I don't want to set up my X-server to use with my old monitor (again) as I've have enough trouble with X for the time being (why all Linux GUIs don't have GNOMEs ability to choose the desired monitor size and resolution from the list of options supported by the device, rather than the "use the X-Servers maximum capabilities, one size fits all approach" is beyond me)

But I shall bookmark this article and will get straight to it later in the week (a replacement monitor is being delivered thursday)

So thankyou very much once again for the info. It was most helpful and looks guaranteed to work !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware OpenOffice gnome-integration Package taylor_venable Slackware 5 09-16-2005 05:04 PM
SCIM and OpenOffice on Gnome r-t Linux - Software 0 01-30-2005 05:19 AM
Not adding accents in OpenOffice with GNOME Jose Muņiz Linux - Software 0 10-20-2003 10:19 AM
Gnome OpenOffice quickstarter haamann Linux - Software 0 10-07-2003 03:21 AM
OpenOffice in Slack 9's gnome dbkluck Slackware 1 07-17-2003 04:02 AM


All times are GMT -5. The time now is 08:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration