Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


LinkBack Search this Thread
Old 06-02-2004, 11:10 AM   #1
Registered: Mar 2004
Posts: 56

Rep: Reputation: 15
glib wont be recognized

Ok I am in a bit of a mess. I am trying to get a cd writing software and i am in the process of getting all of the dependencies installed for it. One of them is glib and i installed 2.4.0. Another dependency is atk and i am trying to install it and it doesnt seem to recognize the new glib. also i just installed pkg-config. Here is the errors it gives when running configure:
checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.2.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
I have seen other people with similar errors but no clear solution has been found by me. could someone please tell me how to get glib to be recognized?
Old 06-02-2004, 11:24 AM   #2
Senior Member
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,037

Rep: Reputation: 54
I had the same problem, do "./configure --disable-glibtest"
It worked for me
Old 06-02-2004, 11:34 AM   #3
Registered: Mar 2004
Posts: 56

Original Poster
Rep: Reputation: 15
ok it worked. but will this cause any problems later? you are a god
Old 06-02-2004, 01:25 PM   #4
Senior Member
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,037

Rep: Reputation: 54
It happened to me while installing Gimp 2, and Gimp works like a charm. I am not a guru, so I cannot tell if there will be some problems. I don't think so, as you got Glib2 on your system, but for some reason it is not detected.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
MA101 is recognized but wont work wpg9210 Linux - Wireless Networking 7 03-11-2005 09:57 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
glib-2.3.3 not recognized by ./configure tektone Linux - Software 1 03-01-2004 05:16 PM
help - glib-2.0 not recognized?! mjk Linux - Newbie 2 10-07-2003 01:51 PM

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration