LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-21-2003, 10:08 PM   #1
-=SnakeyeS=-
LQ Newbie
 
Registered: Jan 2003
Posts: 4

Rep: Reputation: 0
GLIB install problems


I'm having trouble installing Glib. I just installed MDK 9 yesterday.

So far I have successfully installed Pango and PkgConfig. I have supposedly installed GLib 2.2.0, but it doesn't seem to be recognized.

My problem begins with the fact that I am trying to install Gaim. The dependencies go like this:



Gaim
|
GTK (Gimp Toolkit)
|
Pango, Atk, Glib

Glib
|
PkgConfig

PkgConfig came with Glib ~1.6
When installing Atk, I get an error as follows:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.0, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.
[root@localhost atk-1.2.0]#


Basically my question is, what are environment variables, and how do I change them?
 
Old 01-22-2003, 01:15 AM   #2
oulevon
Member
 
Registered: Feb 2001
Location: Boston, USA
Distribution: Slackware
Posts: 437

Rep: Reputation: 30
Have you run ldconfig?

I believe you need to run the ldconfig command as su in order to update things.

Last edited by oulevon; 01-22-2003 at 01:50 AM.
 
Old 01-22-2003, 06:46 PM   #3
-=SnakeyeS=-
LQ Newbie
 
Registered: Jan 2003
Posts: 4

Original Poster
Rep: Reputation: 0
no i havent
how do I do it?
just ldconfig in root console?
 
Old 01-22-2003, 06:48 PM   #4
oulevon
Member
 
Registered: Feb 2001
Location: Boston, USA
Distribution: Slackware
Posts: 437

Rep: Reputation: 30
Yeah just run it from the shell. I think you need to be root.
 
Old 01-30-2003, 11:08 AM   #5
agkrueger
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Rep: Reputation: 15
I have the exact same problem tryin to install all of the packages required to install the latest release of nautilus...i've probably searched rpmnet and installed 5 or 6 other dependant packages and now when i get to installing atk-1.2.0 I am getting the exact same error message.

i've run ldconfig a couple times as root (not su or su-, actually logged in as root) and I can't seem to figure this one out.

i'm well on my way to converting off of windows, but man...i've never had this much trouble with .dlls

any help is appreciated, if i figure it out i will post what I did. TIA
 
Old 01-30-2003, 11:41 AM   #6
agkrueger
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Rep: Reputation: 15
ok, i got around this one with a little help from a couple of other postings:

I ran this command: (from post: http://www.linuxquestions.org/questi...=LDLIBRARYPATH)

find /usr -name lib >> /etc/ld.so.conf&
/sbin/ldconfig

-which seemed to add a ton of other paths to the /etc/ld.so.conf file.

I then ran 'ldconfig' and reran the ./configure, which resulted in the same error. So i went looking in /usr/lib. I found a file named, libglib-2.0.so.0.0.6 and renamed (for backup) it then reran 'ldconfig' and again the ./configure.

This time it got past the original complaint and gave me another, which I expected...on to the next one.

I have since gone back and renamed the file back to the original name.

So, in closing...I'm not sure if this was the proper way of doing this but it seems to have worked for me thusfar...YMMV yadda x3

btw - running RH8.0 (2.4.18-19.8.0)
 
Old 01-30-2003, 04:00 PM   #7
agkrueger
LQ Newbie
 
Registered: Jan 2003
Posts: 21

Rep: Reputation: 15
not to hijack your thread, but the problems just keep coming...

running RedHat8 (2.4.18-19.8.0)

i now have become stumped. i recently installed gtk+-2.2.0 package, but when trying to do the ./configure for the latest nautilus i get the following...:

------------------------------------------------------
checking for pkg-config... /usr/local/bin/pkg-config
checking for gconf-2.0 >= 1.1.11 gdk-pixbuf-2.0 >= 2 gthread-2.0 >= 2 glib-2.0 >= 2 gnome-vfs-2.0 >= 1.9 gtk+-2.0 >= 2.1.0 gail >=
0.16 libart-2.0 >= 2.3.8 libgnome-2.0 >= 2.0 libgnomeui-2.0 >= 2.0
libxml-2.0 >= 2.4.7 libglade-2.0 >= 2.0.0... Requested 'gtk+-2.0 >= 2.1.0' but version of GTK+ is 2.0.6

configure: error: Library requirements ( gconf-2.0 >= 1.1.11 gdk-pixbuf-2.0 >= 2 gthread-2.0 >= 2 glib-2.0 >= 2 gnome-vfs-2.0 >= 1.9
gtk+-2.0 >= 2.1.0 gail >= 0.16 libart-2.0 >= 2.3.8 libgnome-2.0 >=
2.0 libgnomeui-2.0 >= 2.0 libxml-2.0 >= 2.4.7 libglade-2.0 >= 2.0.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

--------------------------------------------------------

when i do #rpm -q gtk+ i get: gtk+-1.2.10-22

but i have just installed gtk+-2.2.0 earlier and done a 'ldconfig' numerous times....

any ideas how to get past this? I am trying to get nautilus-2.2.0.2 to install and have had to install about 10 other packages to get to this point.

*edit: I'm starting to think the problem IS related to my PKG_CONFIG_PATH variable....but I'm not entirely sure what paths are supposed to be in there...? Currently it is reflecting /usr/local/lib/pkgconfig/ -but that doesn't seem right to me...


Any help is greatly appreciated.

Last edited by agkrueger; 01-30-2003 at 04:10 PM.
 
Old 04-09-2003, 12:55 AM   #8
alonsoac
LQ Newbie
 
Registered: Apr 2003
Posts: 2

Rep: Reputation: 0
may this helps

This may help some of you. I was trying to install gaim and got errors with the glib version. The problem is this is an old install of redhat 6 which I then upgraded to 7.3 and I had some very old glib libs lying around.

You need to delete /usr/lib/libglib.* and /usr/local/lib/libglib.* any file named libglib-1.2 don't delete it!
then I did ldconfig then make install on the glib source dir and glib worked ok. I had the same problem then with gtk+, you need to delete /usr/lib/libgdk.* same in /usr/local/lib and also /usr/lib/libgtk.* same in usr/local/lib.
If you find any libgdk-x11-2* or libgtk-x11-2* delete those also.
then ldconfig then make install on gtk+.

That should do it.

I also added /usr/lib /etc/ld.so.conf but that may not be necessary.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glib-2.0 install problems winward Linux - Software 2 09-26-2005 02:40 PM
glib-2.4.6 install problems? pfaendtner Linux - Software 0 09-23-2004 04:17 PM
glib 2.5.1 install problems. Devboy *BSD 5 08-17-2004 02:50 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Glib install problems Greg21 Linux - Software 5 06-05-2003 04:31 PM


All times are GMT -5. The time now is 10:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration