LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-04-2003, 09:48 PM   #1
kwanc
LQ Newbie
 
Registered: Feb 2003
Distribution: YDL 2.3 (broken)
Posts: 4

Rep: Reputation: 0
glib >=2.0 failed dependency


I'm running YDL 2.3 with GNOME 2.0.3, and I'm having some serious compile-from-soucre issues. I installed glib2 via RPM and Source, and yet when I try to compile something depending on glib2 I get a dependency error. What's going on? should I kill TerraSoft for giving me crap? help a brotha out.
 
Old 02-05-2003, 06:48 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
What's the dependency error? I guess it's during configure that glib2 cannot be found. If so, you need to check if you have /usr/local/lib in your LD_LIBRARY_PATH or /etc/ld.conf.so.
 
Old 02-05-2003, 07:00 AM   #3
vladkrack
Member
 
Registered: Oct 2002
Location: Curitiba - Brazil
Distribution: Conectiva
Posts: 334

Rep: Reputation: 30
Did you instaled gli2-devel?
 
Old 02-05-2003, 01:43 PM   #4
lopoetve
Member
 
Registered: Aug 2001
Distribution: Too many.
Posts: 102

Rep: Reputation: 15
ldconfig. Run it. That might help.
 
Old 02-06-2003, 07:34 PM   #5
kwanc
LQ Newbie
 
Registered: Feb 2003
Distribution: YDL 2.3 (broken)
Posts: 4

Original Poster
Rep: Reputation: 0
none of the above works; although I don't know how to check if /usr/local/lib is in my LD_LIBRARY_PATH.

I added it to /etc/ld.so.conf though.

getting the same error; and apparently I don't have ldconfig, are there any special arguments i need to run it?
 
Old 02-06-2003, 07:57 PM   #6
kwanc
LQ Newbie
 
Registered: Feb 2003
Distribution: YDL 2.3 (broken)
Posts: 4

Original Poster
Rep: Reputation: 0
okay, I installed glib 2.2.1 from source. Now, when I try to install, this comes up.

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.7, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.


grrrr.
 
Old 02-07-2003, 02:51 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
well then you need to upgrade glib-devel, or rather remove it if you installed glib from source. i'm not totally sure who pkgconfig deals with source installed pacakges, but i guess you could probably just edit the existing glib-2.0.pc file if you can find it.
 
Old 02-08-2003, 04:14 PM   #8
kwanc
LQ Newbie
 
Registered: Feb 2003
Distribution: YDL 2.3 (broken)
Posts: 4

Original Poster
Rep: Reputation: 0
i recompiled glib-2.2.0 and pkgconfig. now, configure scripts get past the glib >= 2.0.0, but they then fail on GTK+ >= 2.0.0. same error:


checking for GLIB - version >= 2.0.0... yes (version 2.2.0)
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
*** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
*** development headers installed. The latest version of GTK+ is
*** always available at http://www.gtk.org/.
 
Old 02-08-2003, 04:44 PM   #9
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Do you have gtk-devel package?
 
Old 02-09-2003, 03:38 AM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
i would have thought that seeing as you fixed your problem and now have *excatly* the same problem with a different library that the answer would be nothign short of obvious...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
failed dependency libXm.so.3 Curtux Mandriva 19 05-04-2011 06:23 AM
mkinitrd - Failed Dependency (libc.so.6) d1g1ta7 Linux - Software 3 08-15-2005 08:30 PM
failed dependency vijaysh Debian 1 12-26-2004 03:18 AM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 09:03 PM
failed dependency while trying to install gtk2-2.2.2-2.0 kinghari Linux - Newbie 2 10-17-2003 12:46 AM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration